summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/mysql/mysql-3.23.57-r1.ebuild4
-rw-r--r--dev-db/mysql/mysql-3.23.58-r1.ebuild4
-rw-r--r--dev-db/mysql/mysql-3.23.58.ebuild4
-rw-r--r--games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild4
-rw-r--r--games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild4
-rw-r--r--games-emulation/daphne/daphne-0.99.6-r2.ebuild4
-rw-r--r--games-rpg/egoboo/egoboo-2.22.ebuild4
-rw-r--r--media-libs/flac/flac-1.1.0-r2.ebuild4
-rw-r--r--media-libs/jpeg/jpeg-6b-r3.ebuild4
-rw-r--r--media-libs/libpng/libpng-1.2.5-r8.ebuild6
-rw-r--r--media-libs/libpng/libpng-1.2.7.ebuild9
-rw-r--r--sys-devel/bison/bison-1.875.ebuild4
12 files changed, 27 insertions, 28 deletions
diff --git a/dev-db/mysql/mysql-3.23.57-r1.ebuild b/dev-db/mysql/mysql-3.23.57-r1.ebuild
index 8d5d93a8cf6b..8bb0721cbc4a 100644
--- a/dev-db/mysql/mysql-3.23.57-r1.ebuild
+++ b/dev-db/mysql/mysql-3.23.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.57-r1.ebuild,v 1.8 2004/06/29 17:36:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.57-r1.ebuild,v 1.9 2004/09/25 07:40:33 vapier Exp $
inherit flag-o-matic eutils
@@ -45,7 +45,7 @@ src_unpack() {
src_compile() {
# bug #11681; get b0rked code when using -march=k6 with this package.
- replace-cpu-flags i586 k6 k6-2 k6-3
+ replace-cpu-flags k6 k6-2 k6-3 i586
local myconf
# The following fix is due to a bug with bdb on sparc's. See:
diff --git a/dev-db/mysql/mysql-3.23.58-r1.ebuild b/dev-db/mysql/mysql-3.23.58-r1.ebuild
index a8cbd4cf690b..5964fecaaaa6 100644
--- a/dev-db/mysql/mysql-3.23.58-r1.ebuild
+++ b/dev-db/mysql/mysql-3.23.58-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58-r1.ebuild,v 1.6 2004/08/29 04:56:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58-r1.ebuild,v 1.7 2004/09/25 07:40:33 vapier Exp $
inherit flag-o-matic eutils
@@ -50,7 +50,7 @@ src_unpack() {
src_compile() {
# bug #11681; get b0rked code when using -march=k6 with this package.
- replace-cpu-flags i586 k6 k6-2 k6-3
+ replace-cpu-flags k6 k6-2 k6-3 i586
local myconf
# The following fix is due to a bug with bdb on sparc's. See:
diff --git a/dev-db/mysql/mysql-3.23.58.ebuild b/dev-db/mysql/mysql-3.23.58.ebuild
index a9927a997a8c..f770568a9c26 100644
--- a/dev-db/mysql/mysql-3.23.58.ebuild
+++ b/dev-db/mysql/mysql-3.23.58.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58.ebuild,v 1.2 2004/08/24 17:41:22 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58.ebuild,v 1.3 2004/09/25 07:40:33 vapier Exp $
inherit flag-o-matic eutils
@@ -45,7 +45,7 @@ src_unpack() {
src_compile() {
# bug #11681; get b0rked code when using -march=k6 with this package.
- replace-cpu-flags i586 k6 k6-2 k6-3
+ replace-cpu-flags k6 k6-2 k6-3 i586
local myconf
# The following fix is due to a bug with bdb on sparc's. See:
diff --git a/games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild
index 31e0a6a49a2a..90b956b7ab2d 100644
--- a/games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild
+++ b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild,v 1.4 2004/07/01 03:08:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.0.8.ebuild,v 1.5 2004/09/25 07:40:36 vapier Exp $
inherit flag-o-matic games
@@ -30,7 +30,7 @@ src_unpack() {
}
src_compile() {
- replace-cpu-flags i586 k6 k6-1 k6-2
+ replace-cpu-flags k6 k6-1 k6-2 i586
local makeopts="RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
if use X || { ! use X && ! use sdl; } ; then
diff --git a/games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild b/games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild
index 788ab6e77a98..f90942d7e237 100644
--- a/games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild
+++ b/games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild,v 1.1 2004/07/10 10:22:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.1.0.ebuild,v 1.2 2004/09/25 07:40:36 vapier Exp $
inherit flag-o-matic games
@@ -47,7 +47,7 @@ src_unpack() {
}
src_compile() {
- replace-cpu-flags i586 k6 k6-1 k6-2
+ replace-cpu-flags k6 k6-1 k6-2 i586
local makeopts="RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
if use X || { ! use X && ! use sdl; } ; then
diff --git a/games-emulation/daphne/daphne-0.99.6-r2.ebuild b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
index bf9a79fdaeb3..3474b83cf2dc 100644
--- a/games-emulation/daphne/daphne-0.99.6-r2.ebuild
+++ b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.7 2004/08/21 04:29:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.8 2004/09/25 07:40:54 vapier Exp $
inherit eutils flag-o-matic games
@@ -25,7 +25,7 @@ S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
- replace-cpu-flags i586 i686 pentium3 pentium4 #18807
+ replace-cpu-flags i686 pentium3 pentium4 i586 #18807
cd "${S}/src"
sed -e "s:-march=i686:${CFLAGS}:" \
diff --git a/games-rpg/egoboo/egoboo-2.22.ebuild b/games-rpg/egoboo/egoboo-2.22.ebuild
index c563fcdb30e7..59651a40dd0d 100644
--- a/games-rpg/egoboo/egoboo-2.22.ebuild
+++ b/games-rpg/egoboo/egoboo-2.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22.ebuild,v 1.11 2004/07/01 11:22:21 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22.ebuild,v 1.12 2004/09/25 07:41:11 vapier Exp $
inherit eutils flag-o-matic games gcc
@@ -24,7 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
src_unpack() {
- replace-cpu-flags i686 'athlon*' pentium4
+ replace-cpu-flags 'athlon*' pentium4 i686
unpack ${A}
cd ${S}
diff --git a/media-libs/flac/flac-1.1.0-r2.ebuild b/media-libs/flac/flac-1.1.0-r2.ebuild
index 4d5c83df0446..95b944243258 100644
--- a/media-libs/flac/flac-1.1.0-r2.ebuild
+++ b/media-libs/flac/flac-1.1.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r2.ebuild,v 1.7 2004/08/08 14:48:25 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r2.ebuild,v 1.8 2004/09/25 07:41:37 vapier Exp $
inherit libtool eutils flag-o-matic gcc
@@ -35,7 +35,7 @@ src_unpack() {
}
src_compile() {
- use hppa && [ "`gcc-fullversion`" == "3.4.0" ] && replace-cpu-flags 1.0 2.0
+ use hppa && [ "`gcc-fullversion`" == "3.4.0" ] && replace-cpu-flags 2.0 1.0
econf \
--with-pic \
diff --git a/media-libs/jpeg/jpeg-6b-r3.ebuild b/media-libs/jpeg/jpeg-6b-r3.ebuild
index 7b65a19fff57..ce94a6ea2250 100644
--- a/media-libs/jpeg/jpeg-6b-r3.ebuild
+++ b/media-libs/jpeg/jpeg-6b-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r3.ebuild,v 1.30 2004/09/22 20:09:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r3.ebuild,v 1.31 2004/09/25 07:41:51 vapier Exp $
inherit gnuconfig flag-o-matic libtool
@@ -29,7 +29,7 @@ src_unpack() {
}
src_compile() {
- replace-cpu-flags i586 k6 k6-2 k6-3
+ replace-cpu-flags k6 k6-2 k6-3 i586
econf --enable-shared --enable-static || die "econf failed"
diff --git a/media-libs/libpng/libpng-1.2.5-r8.ebuild b/media-libs/libpng/libpng-1.2.5-r8.ebuild
index 259971c397ab..c507012725f0 100644
--- a/media-libs/libpng/libpng-1.2.5-r8.ebuild
+++ b/media-libs/libpng/libpng-1.2.5-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.5-r8.ebuild,v 1.9 2004/09/23 03:45:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.5-r8.ebuild,v 1.10 2004/09/25 07:43:24 vapier Exp $
inherit flag-o-matic eutils gcc
@@ -25,8 +25,8 @@ src_unpack() {
epatch ${FILESDIR}/macos.patch # implements strnlen
fi
- [ "`gcc-version`" == "3.2" ] && replace-cpu-flags i586 k6 k6-2 k6-3
- [ "`gcc-version`" == "3.3" ] && replace-cpu-flags i586 k6 k6-2 k6-3
+ [ "`gcc-version`" == "3.2" ] && replace-cpu-flags k6 k6-2 k6-3 i586
+ [ "`gcc-version`" == "3.3" ] && replace-cpu-flags k6 k6-2 k6-3 i586
sed \
-e "s:ZLIBLIB=.*:ZLIBLIB=/usr/lib:" \
diff --git a/media-libs/libpng/libpng-1.2.7.ebuild b/media-libs/libpng/libpng-1.2.7.ebuild
index c12e51923732..103b3d6515a9 100644
--- a/media-libs/libpng/libpng-1.2.7.ebuild
+++ b/media-libs/libpng/libpng-1.2.7.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.7.ebuild,v 1.5 2004/09/23 12:55:28 gustavoz Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.7.ebuild,v 1.6 2004/09/25 07:43:24 vapier Exp $
inherit flag-o-matic eutils gcc
@@ -12,7 +10,8 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="as-is"
SLOT="1.2"
-KEYWORDS="x86 ~ppc sparc ~arm ~hppa amd64 ~alpha ~mips ~macos ~ppc-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 ~macos ~mips ~ppc ~ppc64 ~ppc-macos ~s390 sparc x86"
+IUSE=""
DEPEND="sys-libs/zlib"
@@ -23,7 +22,7 @@ src_unpack() {
epatch "${FILESDIR}/${PV}-gentoo.diff"
if [ "$(gcc-version)" == "3.3" -o "$(gcc-version)" == "3.2" ] ; then
- replace-cpu-flags i586 k6 k6-2 k6-3
+ replace-cpu-flags k6 k6-2 k6-3 i586
fi
if use macos || use ppc-macos ; then
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index 04b45873575a..ab2a49d4b831 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.23 2004/07/19 15:53:22 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.24 2004/09/25 07:43:50 vapier Exp $
inherit gcc flag-o-matic eutils gnuconfig
@@ -38,7 +38,7 @@ src_compile() {
# (04 Feb 2004 agriffis)
#
if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
- replace-cpu-flags i586 k6 k6-1 k6-2
+ replace-cpu-flags k6 k6-1 k6-2 i586
fi
econf `use_enable nls` || die