summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xfe/ChangeLog7
-rw-r--r--x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch35
-rw-r--r--x11-misc/xfe/xfe-1.32.2.ebuild4
3 files changed, 44 insertions, 2 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index d0721a0eb439..d6cb08950d56 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.63 2010/10/31 23:32:50 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.64 2010/11/02 12:46:54 ssuominen Exp $
+
+ 02 Nov 2010; Samuli Suominen <ssuominen@gentoo.org> xfe-1.32.2.ebuild,
+ +files/xfe-1.32.2-missing_Xlib_h.patch:
+ Fix building with USE="-startup-notification" wrt #343825 by Diego Elio
+ Pettenò.
*xfe-1.32.2 (31 Oct 2010)
diff --git a/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch b/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch
new file mode 100644
index 000000000000..a29a252dc8e6
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch
@@ -0,0 +1,35 @@
+http://bugs.gentoo.org/343825
+
+--- src/ViewWindow.cpp
++++ src/ViewWindow.cpp
+@@ -12,6 +12,8 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#include <X11/Xlib.h>
++
+ #include <fx.h>
+ #include <fxkeys.h>
+ #include <FXPNGIcon.h>
+--- src/WriteWindow.cpp
++++ src/WriteWindow.cpp
+@@ -12,6 +12,8 @@
+ #include <unistd.h>
+ #include <signal.h>
+
++#include <X11/Xlib.h>
++
+ #include <fx.h>
+ #include <fxkeys.h>
+ #include <FXPNGIcon.h>
+--- src/XFileExplorer.cpp
++++ src/XFileExplorer.cpp
+@@ -8,6 +8,8 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
+
++#include <X11/Xlib.h>
++
+ #include <fx.h>
+ #include <fxkeys.h>
+ #include <FXPNGIcon.h>
diff --git a/x11-misc/xfe/xfe-1.32.2.ebuild b/x11-misc/xfe/xfe-1.32.2.ebuild
index 936319341845..c19b8ba7cb5a 100644
--- a/x11-misc/xfe/xfe-1.32.2.ebuild
+++ b/x11-misc/xfe/xfe-1.32.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.2.ebuild,v 1.1 2010/10/31 23:32:50 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.2.ebuild,v 1.2 2010/11/02 12:46:54 ssuominen Exp $
EAPI=2
inherit eutils
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-missing_Xlib_h.patch
+
cat >po/POTFILES.skip <<-EOF
src/icons.cpp
xfe.desktop.in.in