summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/rtorrent/ChangeLog6
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.4.4-inttypes.patch12
-rw-r--r--net-p2p/rtorrent/rtorrent-0.4.4.ebuild8
3 files changed, 24 insertions, 2 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 1c55834cbf6d..675d90083582 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.33 2006/02/04 23:06:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.34 2006/02/06 12:46:01 flameeyes Exp $
+
+ 06 Feb 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/rtorrent-0.4.4-inttypes.patch, rtorrent-0.4.4.ebuild:
+ Add patch to fix building on some systems, bug #121771.
04 Feb 2006; Diego Pettenò <flameeyes@gentoo.org> -rtorrent-0.4.0.ebuild,
-rtorrent-0.4.1.ebuild, -rtorrent-0.4.2.ebuild:
diff --git a/net-p2p/rtorrent/files/rtorrent-0.4.4-inttypes.patch b/net-p2p/rtorrent/files/rtorrent-0.4.4-inttypes.patch
new file mode 100644
index 000000000000..b057bd934d12
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.4.4-inttypes.patch
@@ -0,0 +1,12 @@
+Index: rtorrent/src/command_scheduler.h
+===================================================================
+--- rtorrent/src/command_scheduler.h (revision 629)
++++ rtorrent/src/command_scheduler.h (working copy)
+@@ -39,6 +39,7 @@
+
+ #include <vector>
+ #include <string>
++#include <inttypes.h>
+ #include <rak/functional_fun.h>
+
+ class CommandSchedulerItem;
diff --git a/net-p2p/rtorrent/rtorrent-0.4.4.ebuild b/net-p2p/rtorrent/rtorrent-0.4.4.ebuild
index 389d7fe5b797..e28740d0111f 100644
--- a/net-p2p/rtorrent/rtorrent-0.4.4.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.4.4.ebuild,v 1.1 2006/02/04 22:59:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.4.4.ebuild,v 1.2 2006/02/06 12:46:01 flameeyes Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -18,6 +18,12 @@ DEPEND=">=net-libs/libtorrent-0.8.0
>=net-misc/curl-7.12
sys-libs/ncurses"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-inttypes.patch"
+}
+
src_compile() {
[[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
replace-flags -Os -O2