summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/files/digest-python-2.2.1-r51
-rw-r--r--dev-lang/python/python-2.2.1-r5.ebuild99
3 files changed, 4 insertions, 101 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 90a15e0e210d..df0725817af7 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.88 2004/03/10 15:42:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.89 2004/03/11 00:38:59 liquidx Exp $
+
+ 11 Mar 2004; Alastair Tse <liquidx@gentoo.org> python-2.2.1-r5.ebuild:
+ removing 2.2.1 from tree for security reasons (#44230)
09 Mar 2004; <agriffis@gentoo.org> python-2.3.3.ebuild:
stable on alpha and ia64
diff --git a/dev-lang/python/files/digest-python-2.2.1-r5 b/dev-lang/python/files/digest-python-2.2.1-r5
deleted file mode 100644
index ea99f8857c06..000000000000
--- a/dev-lang/python/files/digest-python-2.2.1-r5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e7012d611602b62e36073c2fd02396a3 Python-2.2.1.tgz 6535104
diff --git a/dev-lang/python/python-2.2.1-r5.ebuild b/dev-lang/python/python-2.2.1-r5.ebuild
deleted file mode 100644
index 7bd378692f60..000000000000
--- a/dev-lang/python/python-2.2.1-r5.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r5.ebuild,v 1.11 2003/09/11 01:08:24 msterret Exp $
-
-IUSE="readline tcltk berkdb bootstrap"
-
-PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
-PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
-S=${WORKDIR}/Python-${PV}
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
-
-HOMEPAGE="http://www.python.org"
-LICENSE="PSF-2.2"
-KEYWORDS="x86 ppc sparc alpha"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-if [ -z "`use build`" -a -z "`use bootstrap`" ]; then
- DEPEND="$DEPEND dev-libs/expat"
-fi
-RDEPEND="$DEPEND dev-python/python-fchksum"
-
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
-
-PROVIDE="virtual/python"
-
-SLOT="2.2"
-
-inherit flag-o-matic
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p4 < ${FILESDIR}/${PF}-gentoo.diff
-}
-
-src_compile() {
- filter-flags -malign-double
-
- if [ "${ARCH}" = "alpha" ]; then
- CFLAGS="${CFLAGS} -fPIC"
- CXXFLAGS="${CXXFLAGS} -fPIC"
- fi
- export OPT="$CFLAGS"
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
- local myopts
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
- then
- myopts="--with-cxx=no"
- fi
-
- econf --with-fpectl \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- $myopts || die
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python${PYVER_MAJOR} /usr/bin/python
- dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PV} python-config
-
- # seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # While we're working on the config stuff... Let's fix the OPT var
- # so that it doesn't have any opts listed in it. Prevents the problem
- # with compiling things with conflicting opts later.
- dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' /usr/lib/python${PYVER}/config/Makefile
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- dodir /usr/lib/python${PYVER}/tools
- mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
- dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
- fi
-}