summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/mesa/ChangeLog8
-rw-r--r--media-libs/mesa/files/src-mesa-drivers-Makefile29
-rw-r--r--media-libs/mesa/mesa-7.1_rc2.ebuild294
3 files changed, 330 insertions, 1 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index a8acd532c3fa..a8b51c72d752 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.177 2008/07/01 08:35:09 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.178 2008/07/08 22:08:08 dberkholz Exp $
+
+*mesa-7.1_rc2 (08 Jul 2008)
+
+ 08 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/src-mesa-drivers-Makefile, +mesa-7.1_rc2.ebuild:
+ Bump.
01 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+files/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch,
diff --git a/media-libs/mesa/files/src-mesa-drivers-Makefile b/media-libs/mesa/files/src-mesa-drivers-Makefile
new file mode 100644
index 000000000000..c5998413e86d
--- /dev/null
+++ b/media-libs/mesa/files/src-mesa-drivers-Makefile
@@ -0,0 +1,29 @@
+# src/mesa/drivers/Makefile
+
+TOP = ../../..
+include $(TOP)/configs/current
+
+
+default:
+ @for dir in $(DRIVER_DIRS) ; do \
+ if [ -d $$dir ] ; then \
+ (cd $$dir && $(MAKE)) || exit 1; \
+ fi \
+ done
+
+
+clean:
+ @for dir in $(DRIVER_DIRS) ; do \
+ if [ -d $$dir ] ; then \
+ (cd $$dir && $(MAKE) clean) || exit 1; \
+ fi \
+ done
+
+
+install:
+ @for dir in $(DRIVER_DIRS) ; do \
+ if [ -d $$dir ] ; then \
+ (cd $$dir && $(MAKE) install) || exit 1; \
+ fi \
+ done
+
diff --git a/media-libs/mesa/mesa-7.1_rc2.ebuild b/media-libs/mesa/mesa-7.1_rc2.ebuild
new file mode 100644
index 000000000000..21da366d6128
--- /dev/null
+++ b/media-libs/mesa/mesa-7.1_rc2.ebuild
@@ -0,0 +1,294 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.1_rc2.ebuild,v 1.1 2008/07/08 22:08:08 dberkholz Exp $
+
+GIT=
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
+ GIT="git"
+fi
+
+inherit autotools multilib flag-o-matic ${GIT} portability
+
+OPENGL_DIR="xorg-x11"
+
+MY_PN="${PN/m/M}"
+MY_P="${MY_PN}-${PV//_/-}"
+MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+if [[ $PV = *_rc* ]]; then
+ SRC_URI="http://www.mesa3d.org/beta/${MY_SRC_P}.tar.gz"
+elif [[ $PV = 9999 ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/mesa3d/${MY_SRC_P}.tar.bz2"
+fi
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE_VIDEO_CARDS="
+ video_cards_i810
+ video_cards_mach64
+ video_cards_mga
+ video_cards_none
+ video_cards_r128
+ video_cards_radeon
+ video_cards_s3virge
+ video_cards_savage
+ video_cards_sis
+ video_cards_sunffb
+ video_cards_tdfx
+ video_cards_trident
+ video_cards_via"
+IUSE="${IUSE_VIDEO_CARDS}
+ debug
+ doc
+ pic
+ motif
+ nptl
+ xcb
+ kernel_FreeBSD"
+
+RDEPEND="app-admin/eselect-opengl
+ dev-libs/expat
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXdamage
+ >=x11-libs/libdrm-2.3.1
+ x11-libs/libICE
+ motif? ( x11-libs/openmotif )
+ doc? ( app-doc/opengl-manpages )
+ !<=x11-base/xorg-x11-6.9"
+DEPEND="${RDEPEND}
+ !<=x11-proto/xf86driproto-2.0.3
+ dev-util/pkgconfig
+ x11-misc/makedepend
+ x11-proto/inputproto
+ x11-proto/xextproto
+ !hppa? ( x11-proto/xf86driproto )
+ x11-proto/dri2proto
+ x11-proto/xf86vidmodeproto
+ >=x11-proto/glproto-1.4.8
+ motif? ( x11-proto/printproto )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Think about: ggi, svga, fbcon, no-X configs
+
+pkg_setup() {
+ if use xcb; then
+ if ! built_with_use x11-libs/libX11 xcb; then
+ msg="You must build libX11 with xcb enabled."
+ eerror ${msg}
+ die ${msg}
+ fi
+ fi
+
+ if use debug; then
+ append-flags -g
+ fi
+
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
+ # recommended by upstream
+ append-flags -ffast-math
+}
+
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ git_src_unpack
+ else
+ unpack ${A}
+ cd "${S}"
+ fi
+
+ cp "${FILESDIR}"/src-mesa-drivers-Makefile \
+ "${S}"/src/mesa/drivers/Makefile || die
+
+ # Don't compile debug code with USE=-debug - bug #125004
+ if ! use debug; then
+ einfo "Removing DO_DEBUG defs in dri drivers..."
+ find src/mesa/drivers/dri -name *.[hc] -exec egrep -l "\#define\W+DO_DEBUG\W+1" {} \; | xargs sed -i -re "s/\#define\W+DO_DEBUG\W+1/\#define DO_DEBUG 0/" ;
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ # This is where we might later change to build xlib/osmesa
+ myconf="${myconf} --with-driver=dri"
+
+ # No TTM
+ myconf="${myconf} --disable-ttm-api"
+
+ # Do we want thread-local storage (TLS)?
+ myconf="${myconf} $(use_enable nptl glx-tls)"
+
+ # Configurable DRI drivers
+ driver_enable swrast
+ driver_enable video_cards_i810 i810 i915 i965
+ driver_enable video_cards_mach64 mach64
+ driver_enable video_cards_mga mga
+ driver_enable video_cards_r128 r128
+ driver_enable video_cards_radeon radeon r200 r300
+ driver_enable video_cards_s3virge s3v
+ driver_enable video_cards_savage savage
+ driver_enable video_cards_sis sis
+ driver_enable video_cards_sunffb ffb
+ driver_enable video_cards_tdfx tdfx
+ driver_enable video_cards_trident trident
+ driver_enable video_cards_via unichrome
+
+ # Set drivers to everything on which we ran driver_enable()
+ myconf="${myconf} --with-dri-drivers=${DRI_DRIVERS}"
+
+ # Deactivate assembly code for pic build
+ myconf="${myconf} $(use_enable pic asm)"
+
+ # Sparc assembly code is not working
+ myconf="${myconf} $(use_enable sparc asm)"
+
+ myconf="${myconf} --disable-glut"
+
+ myconf="${myconf} --without-demos"
+
+ myconf="${myconf} $(use_enable xcb)"
+
+ myconf="${myconf} $(use_enable debug)"
+
+ # Get rid of glut includes
+ rm -f "${S}"/include/GL/glut*h
+
+ myconf="${myconf} $(use_enable motif glw)"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr
+ emake \
+ DESTDIR="${D}" \
+ install || die "Installation failed"
+
+ if ! use motif; then
+ rm "${D}"/usr/include/GL/GLwMDrawA.h
+ fi
+
+ # Don't install private headers
+ rm -f "${D}"/usr/include/GL/GLw*P.h
+
+ fix_opengl_symlinks
+ dynamic_libgl_install
+
+ # Install libtool archives
+ insinto /usr/$(get_libdir)
+ # (#67729) Needs to be lib, not $(get_libdir)
+ doins "${FILESDIR}"/lib/libGLU.la
+ sed -e "s:\${libdir}:$(get_libdir):g" "${FILESDIR}"/lib/libGL.la \
+ > "${D}"/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
+
+ # On *BSD libcs dlopen() and similar functions are present directly in
+ # libc.so and does not require linking to libdl. portability eclass takes
+ # care of finding the needed library (if needed) witht the dlopen_lib
+ # function.
+ sed -i -e 's:-ldl:'$(dlopen_lib)':g' \
+ "${D}"/usr/$(get_libdir)/libGLU.la \
+ "${D}"/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
+
+ # libGLU doesn't get the plain .so symlink either
+ #dosym libGLU.so.1 /usr/$(get_libdir)/libGLU.so
+
+ # Figure out why libGL.so.1.5 is built (directfb), and why it's linked to
+ # as the default libGL.so.1
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+
+ # We need the outer check, because xorg-server may not be installed
+ # first, and built_with_use() dies if the package isn't installed.
+ if has_version x11-base/xorg-server; then
+ if built_with_use x11-base/xorg-server nptl; then
+ ewarn "Rebuild x11-base/xorg-server without USE=nptl"
+ ewarn "or AIGLX (compiz, etc.) will not work."
+ ewarn "This is because of a bug in the Mesa NPTL assembly code"
+ ewarn "in all Mesa 7.0.x versions (Mesa 6.x is OK)."
+ fi
+ fi
+}
+
+fix_opengl_symlinks() {
+ # Remove invalid symlinks
+ local LINK
+ for LINK in $(find "${D}"/usr/$(get_libdir) \
+ -name libGL\.* -type l); do
+ rm -f ${LINK}
+ done
+ # Create required symlinks
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ # FreeBSD doesn't use major.minor versioning, so the library is only
+ # libGL.so.1 and no libGL.so.1.2 is ever used there, thus only create
+ # libGL.so symlink and leave libGL.so.1 being the real thing
+ dosym libGL.so.1 /usr/$(get_libdir)/libGL.so
+ else
+ dosym libGL.so.1.2 /usr/$(get_libdir)/libGL.so
+ dosym libGL.so.1.2 /usr/$(get_libdir)/libGL.so.1
+ fi
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving libGL and friends for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
+ local x=""
+ for x in "${D}"/usr/$(get_libdir)/libGL.so* \
+ "${D}"/usr/$(get_libdir)/libGL.la \
+ "${D}"/usr/$(get_libdir)/libGL.a; do
+ if [ -f ${x} -o -L ${x} ]; then
+ # libGL.a cause problems with tuxracer, etc
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib
+ fi
+ done
+ # glext.h added for #54984
+ for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}
+
+# $1 - VIDEO_CARDS flag
+# other args - names of DRI drivers to enable
+driver_enable() {
+ case $# in
+ # for enabling unconditionally
+ 1)
+ DRI_DRIVERS="${DRI_DRIVERS},$1"
+ ;;
+ *)
+ if use $1; then
+ shift
+ for i in $@; do
+ DRI_DRIVERS="${DRI_DRIVERS},${i}"
+ done
+ fi
+ ;;
+ esac
+}