summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/opera/ChangeLog8
-rw-r--r--www-client/opera/files/digest-opera-8.5412
-rw-r--r--www-client/opera/opera-8.54.ebuild140
3 files changed, 159 insertions, 1 deletions
diff --git a/www-client/opera/ChangeLog b/www-client/opera/ChangeLog
index 4bd6b1d00ac7..a1ca258cdf7e 100644
--- a/www-client/opera/ChangeLog
+++ b/www-client/opera/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/opera
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.38 2006/04/11 14:28:31 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.39 2006/05/25 20:47:32 kloeri Exp $
+
+*opera-8.54 (25 May 2006)
+
+ 25 May 2006; Bryan Østergaard <kloeri@gentoo.org> +opera-8.54.ebuild:
+ Bump opera for bug 129800. Thanks to Aquila <bart.braem@gmail.com> for the
+ ebuild.
11 Apr 2006; Simon Stelling <blubb@gentoo.org> opera-8.51.ebuild,
opera-8.52.ebuild:
diff --git a/www-client/opera/files/digest-opera-8.54 b/www-client/opera/files/digest-opera-8.54
new file mode 100644
index 000000000000..90605f28b82e
--- /dev/null
+++ b/www-client/opera/files/digest-opera-8.54
@@ -0,0 +1,12 @@
+MD5 16969fd3b4c5c4ccdfffddf34f95f71d opera-8.54-20060330.1-static-qt.i386-en.tar.bz2 3288384
+RMD160 774b312d3d6d2d9b63757d67b4774667633bc7bb opera-8.54-20060330.1-static-qt.i386-en.tar.bz2 3288384
+SHA256 947a52f81451c3c3aec058393596090d5cb13ccb3f657844e366a070dd8d31f7 opera-8.54-20060330.1-static-qt.i386-en.tar.bz2 3288384
+MD5 022ab96cbf6c48239e45a63cf057f1bd opera-8.54-20060330.1-static-qt.ppc-en.tar.bz2 5812618
+RMD160 1beb66093c894501a0694267f7251c5db9df07a3 opera-8.54-20060330.1-static-qt.ppc-en.tar.bz2 5812618
+SHA256 cefebea61175335818bfaf11ee0483da9c6e00b651f4058b2b48c1bd42c6bd22 opera-8.54-20060330.1-static-qt.ppc-en.tar.bz2 5812618
+MD5 1225c949dca9782a82a4f275e4271a87 opera-8.54-20060330.1-static-qt.sparc-en.tar.bz2 5706851
+RMD160 8a87e4960c518a712e8a09cbeedb94b8699214ac opera-8.54-20060330.1-static-qt.sparc-en.tar.bz2 5706851
+SHA256 1da7dc960698d686260a9b1b5c66f1724ce012aaf2a14e7cdc45fc42c83d1eed opera-8.54-20060330.1-static-qt.sparc-en.tar.bz2 5706851
+MD5 4887d49469a374b993010807dba79d32 opera-8.54-20060330.5-shared-qt.i386-en.tar.bz2 3977898
+RMD160 440c7e44e5781750e0a9fca9075786ad5d3380c1 opera-8.54-20060330.5-shared-qt.i386-en.tar.bz2 3977898
+SHA256 c2a73f252467fe786e27fb5c5e4f1d39e844543649d1456e4e92408dbc7c03fe opera-8.54-20060330.5-shared-qt.i386-en.tar.bz2 3977898
diff --git a/www-client/opera/opera-8.54.ebuild b/www-client/opera/opera-8.54.ebuild
new file mode 100644
index 000000000000..60e21985a374
--- /dev/null
+++ b/www-client/opera/opera-8.54.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-8.54.ebuild,v 1.1 2006/05/25 20:47:32 kloeri Exp $
+
+inherit eutils
+
+IUSE="qt-static spell qt kde"
+
+OPERAVER="8.54-20060330"
+OPERAFTPDIR="854/final/en"
+
+S=${WORKDIR}/${A/.tar.bz2/}
+
+DESCRIPTION="Opera web browser."
+HOMEPAGE="http://www.opera.com/linux/"
+
+# that's an ugly workaround for the broken src_uri syntax
+OPERA_URI="mirror://opera/linux/${OPERAFTPDIR}/"
+SRC_URI="
+ x86? ( qt-static? ( ${OPERA_URI}i386/static/${PN}-${OPERAVER}.1-static-qt.i386-en.tar.bz2 ) )
+ x86? ( !qt-static? ( ${OPERA_URI}i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-en.tar.bz2 ) )
+ amd64? ( qt-static? ( ${OPERA_URI}i386/static/${PN}-${OPERAVER}.1-static-qt.i386-en.tar.bz2 ) )
+ amd64? ( !qt-static? ( ${OPERA_URI}i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-en.tar.bz2 ) )
+ sparc? ( ${OPERA_URI}sparc/static/${PN}-${OPERAVER}.1-static-qt.sparc-en.tar.bz2 )
+ ppc? ( ${OPERA_URI}ppc/static/${PN}-${OPERAVER}.1-static-qt.ppc-en.tar.bz2 )"
+
+# sparc? ( !qt-static? ( ${OPERA_URI}/sparc/${PN}-${OPERAVER}.2-shared-qt.sparc-en.tar.bz2 ) )
+# ppc? ( !qt-static? ( ${OPERA_URI}/ppc-linux/en/${PN}-${OPERAVER}.3-shared-qt.ppc-en.tar.bz2 ) )
+
+# Dependencies may be augmented later (see below).
+DEPEND=">=sys-apps/sed-4
+ amd64? ( sys-apps/setarch )"
+
+RDEPEND="|| ( ( x11-libs/libXrandr
+ x11-libs/libXp
+ x11-libs/libXmu
+ x11-libs/libXi
+ x11-libs/libXft
+ x11-libs/libXext
+ x11-libs/libXcursor
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ virtual/x11
+ )
+ >=media-libs/fontconfig-2.1.94-r1
+ amd64? ( qt-static? ( app-emulation/emul-linux-x86-xlibs )
+ !qt-static? ( app-emulation/emul-linux-x86-qtlibs ) )
+ !amd64? ( virtual/motif
+ spell? ( app-text/aspell )
+ x86? ( !qt-static? ( =x11-libs/qt-3* ) )
+ media-libs/jpeg )"
+
+SLOT="0"
+LICENSE="OPERA-8.50"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:config_dir=\"/etc\":config_dir=\"${D}/etc/\":g" \
+ -e "s:/usr/share/applnk:${D}/usr/share/applnk:g" \
+ -e "s:/usr/share/pixmaps:${D}/usr/share/pixmaps:g" \
+ -e "s:/usr/share/icons:${D}/usr/share/icons:g" \
+ -e "s:/etc/X11:${D}/etc/X11:g" \
+ -e "s:/usr/share/gnome:${D}/usr/share/gnome:g" \
+ -e "s:/opt/gnome/share:${D}/opt/gnome/share:g" \
+ -e "s:/usr/share/applications:${D}/usr/share/applications:g" \
+ -e "s:/usr/local/share/applications:${D}/usr/share/applications:g" \
+ -e 's:#\(OPERA_FORCE_JAVA_ENABLED=\):\1:' \
+ -e 's:#\(export LD_PRELOAD OPERA_FORCE_JAVA_ENABLED\):\1:' \
+ -e 's:read str_answer:return 0:' \
+ -e "s:/opt/kde:${D}/usr/kde:" \
+ -e "s:\(str_localdirplugin=\).*$:\1/opt/opera/lib/opera/plugins:" \
+ install.sh || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ # Prepare installation directories for Opera's installer script.
+ dodir /etc
+
+ # Opera's native installer.
+ if [ ${ARCH} = "amd64" ]; then
+ linux32 ./install.sh --prefix="${D}"/opt/opera || die
+ else
+ ./install.sh --prefix="${D}"/opt/opera || die
+ fi
+
+ # java workaround
+ sed -i -e 's:LD_PRELOAD="${OPERA_JAVA_DIR}/libawt.so":LD_PRELOAD="$LD_PRELOAD"\:"${OPERA_JAVA_DIR}/libawt.so":' ${D}/opt/opera/bin/opera
+
+ dosed /opt/opera/bin/opera
+ dosed /opt/opera/share/opera/java/opera.policy
+
+ # Install the icons
+ insinto /usr/share/pixmaps
+ doins images/opera.xpm
+
+ # Install the menu entry
+ insinto /usr/share/applications
+ doins ${FILESDIR}/opera.desktop
+
+ # Install a symlink /usr/bin/opera
+ dodir /usr/bin
+ dosym /opt/opera/bin/opera /usr/bin/opera
+
+ # fix plugin path
+ echo "Plugin Path=/opt/opera/lib/opera/plugins" >> ${D}/etc/opera6rc
+
+ # enable spellcheck
+ if use spell; then
+ if use qt-static; then
+ DIR=$OPERAVER.1
+ else
+ use sparc && DIR=$OPERAVER.2 || DIR=$OPERAVER.5
+ fi
+ echo "Spell Check Engine=/opt/opera/lib/opera/${DIR}/spellcheck.so" >> ${D}/opt/opera/share/opera/ini/spellcheck.ini
+ fi
+
+ #if use qt || use kde; then
+ # cd ${D}/opt/opera/bin
+ # epatch ${FILESDIR}/opera-qt.2.patch
+ #fi
+
+ dodir /etc/env.d
+ echo 'SEARCH_DIRS_MASK="/opt/opera/lib/opera/plugins"' > ${D}/etc/env.d/90opera
+}
+
+pkg_postinst() {
+ einfo "For localized language files take a look at:"
+ einfo "http://www.opera.com/download/languagefiles/index.dml?platform=linux"
+ einfo
+ einfo "To change the spellcheck language edit /opt/opera/share/opera/ini/spellcheck.ini"
+ einfo "and emerge app-text/aspell-language."
+}