summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/ampache/ChangeLog7
-rw-r--r--www-apps/ampache/ampache-3.5.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/www-apps/ampache/ChangeLog b/www-apps/ampache/ChangeLog
index 5fa2ecc82abc..61611676e912 100644
--- a/www-apps/ampache/ChangeLog
+++ b/www-apps/ampache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/ampache
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ChangeLog,v 1.44 2009/05/09 16:12:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ChangeLog,v 1.45 2009/12/20 22:01:06 marineam Exp $
+
+*ampache-3.5.3 (20 Dec 2009)
+
+ 20 Dec 2009; Michael Marineau <marineam@gentoo.org> +ampache-3.5.3.ebuild:
+ Vesrion bump, includes a security fix
09 May 2009; Raúl Porcel <armin76@gentoo.org> ampache-3.4.4.ebuild:
Add ~sparc wrt #268989
diff --git a/www-apps/ampache/ampache-3.5.3.ebuild b/www-apps/ampache/ampache-3.5.3.ebuild
new file mode 100644
index 000000000000..ae1130e879f3
--- /dev/null
+++ b/www-apps/ampache/ampache-3.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.5.3.ebuild,v 1.1 2009/12/20 22:01:06 marineam Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface."
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre session unicode iconv xml mysql gd zlib
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Install and upgrade instructions can be found here:"
+ elog " /usr/share/doc/${P}/INSTALL.gz"
+ elog " /usr/share/doc/${P}/MIGRATION.gz"
+ webapp_pkg_postinst
+}