summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/haskell-mode/ChangeLog14
-rw-r--r--app-emacs/haskell-mode/files/50haskell-mode-gentoo.el1
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild22
3 files changed, 33 insertions, 4 deletions
diff --git a/app-emacs/haskell-mode/ChangeLog b/app-emacs/haskell-mode/ChangeLog
index ac2b4fd221a2..c0e4e1a45f03 100644
--- a/app-emacs/haskell-mode/ChangeLog
+++ b/app-emacs/haskell-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/haskell-mode
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.32 2009/01/29 01:56:31 fauli Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.33 2009/10/27 06:31:27 ulm Exp $
+
+*haskell-mode-2.5.1 (27 Oct 2009)
+
+ 27 Oct 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/50haskell-mode-gentoo.el, +haskell-mode-2.5.1.ebuild:
+ Version bump. Thanks to <Ivan.Miljenovic@gmail.com> in bug 290675.
29 Jan 2009; Christian Faulhammer <fauli@gentoo.org>
-haskell-mode-2.3.ebuild:
@@ -135,9 +141,9 @@
*haskell-mode-1.44 (09 Feb 2003)
09 Feb 2003; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
- haskell-mode-1.44.ebuild, files/50haskell-mode-gentoo.el,
+ haskell-mode-1.44.ebuild, files/50haskell-mode-gentoo.el,
files/digest-haskell-mode-1.44 :
Initial import. Ebuild contributed by Peter Simons
- <simons+gentoo@cryp.to> of bug #13156 (polished up by
+ <simons+gentoo@cryp.to> of bug #13156 (polished up by
<mkennedy@gentoo.org>)
diff --git a/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el b/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el
new file mode 100644
index 000000000000..90e85d0a4291
--- /dev/null
+++ b/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el
@@ -0,0 +1 @@
+(load "@SITELISP@/haskell-site-file" nil t)
diff --git a/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild b/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild
new file mode 100644
index 000000000000..2f2c7bdd67cb
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild,v 1.1 2009/10/27 06:31:27 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Haskell_mode_for_Emacs"
+SRC_URI="http://projects.haskell.org/haskellmode-emacs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DOCS="ChangeLog NEWS README *.hs"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake || die "emake failed"
+}