summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/grep/ChangeLog10
-rw-r--r--sys-apps/grep/grep-2.5.1a-r1.ebuild6
-rw-r--r--sys-apps/grep/grep-2.5.3-r1.ebuild4
-rw-r--r--sys-apps/grep/grep-2.5.4-r1.ebuild41
-rw-r--r--sys-apps/grep/grep-2.5.4.ebuild4
5 files changed, 57 insertions, 8 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 558ba201d405..88587a82361e 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.83 2009/03/12 15:51:07 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.84 2009/04/09 16:09:35 loki_val Exp $
+
+*grep-2.5.4-r1 (09 Apr 2009)
+
+ 09 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> grep-2.5.1a-r1.ebuild,
+ grep-2.5.3-r1.ebuild, grep-2.5.4.ebuild, +grep-2.5.4-r1.ebuild:
+ Revision bump for new libpcre. We can now use libpcre.so since it's in
+ /lib - bug 1638 and bug 53627. Change DEPENDS of previous versions to
+ reflect this, since new libpcre no longer includes .a archives.
11 Mar 2009; Timothy Redaelli <drizzt@gentoo.org> grep-2.5.4.ebuild:
Add ~amd64-fbsd keyword.
diff --git a/sys-apps/grep/grep-2.5.1a-r1.ebuild b/sys-apps/grep/grep-2.5.1a-r1.ebuild
index 3d4daf6e4083..509c487a28bb 100644
--- a/sys-apps/grep/grep-2.5.1a-r1.ebuild
+++ b/sys-apps/grep/grep-2.5.1a-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1a-r1.ebuild,v 1.8 2007/03/14 10:50:40 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1a-r1.ebuild,v 1.9 2009/04/09 16:09:35 loki_val Exp $
inherit flag-o-matic eutils
@@ -16,7 +16,7 @@ IUSE="nls pcre static"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- pcre? ( dev-libs/libpcre )
+ pcre? ( <=dev-libs/libpcre-7.8 )
nls? ( sys-devel/gettext )"
src_unpack() {
diff --git a/sys-apps/grep/grep-2.5.3-r1.ebuild b/sys-apps/grep/grep-2.5.3-r1.ebuild
index 13266a028a95..98780986e10f 100644
--- a/sys-apps/grep/grep-2.5.3-r1.ebuild
+++ b/sys-apps/grep/grep-2.5.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.3-r1.ebuild,v 1.4 2009/01/04 21:07:46 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.3-r1.ebuild,v 1.5 2009/04/09 16:09:35 loki_val Exp $
inherit flag-o-matic eutils
@@ -18,7 +18,7 @@ IUSE="nls pcre static"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- pcre? ( dev-libs/libpcre )
+ pcre? ( <=dev-libs/libpcre-7.8 )
nls? ( sys-devel/gettext )"
src_unpack() {
diff --git a/sys-apps/grep/grep-2.5.4-r1.ebuild b/sys-apps/grep/grep-2.5.4-r1.ebuild
new file mode 100644
index 000000000000..973810950222
--- /dev/null
+++ b/sys-apps/grep/grep-2.5.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.4-r1.ebuild,v 1.1 2009/04/09 16:09:35 loki_val Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls pcre"
+
+RDEPEND="nls? ( virtual/libintl )
+ pcre? ( >=dev-libs/libpcre-7.8-r1 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.5.3-po-builddir-fix.patch
+ epatch "${FILESDIR}"/${PN}-2.5.3-nls.patch
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ $(use elibc_FreeBSD || echo --without-included-regex) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
diff --git a/sys-apps/grep/grep-2.5.4.ebuild b/sys-apps/grep/grep-2.5.4.ebuild
index 5ff7c7fa3ea0..090b0f5d23e3 100644
--- a/sys-apps/grep/grep-2.5.4.ebuild
+++ b/sys-apps/grep/grep-2.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.4.ebuild,v 1.3 2009/03/12 15:51:07 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.4.ebuild,v 1.4 2009/04/09 16:09:35 loki_val Exp $
inherit eutils
@@ -16,7 +16,7 @@ IUSE="nls pcre static"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- pcre? ( dev-libs/libpcre )
+ pcre? ( <=dev-libs/libpcre-7.8 )
nls? ( sys-devel/gettext )"
src_unpack() {