summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/grep/ChangeLog9
-rw-r--r--sys-apps/grep/files/digest-grep-2.5.1a3
-rw-r--r--sys-apps/grep/files/grep-2.5.1-bracket.patch11
-rw-r--r--sys-apps/grep/files/grep-2.5.1-color.patch10
-rw-r--r--sys-apps/grep/grep-2.5.1-r8.ebuild4
-rw-r--r--sys-apps/grep/grep-2.5.1a.ebuild79
6 files changed, 113 insertions, 3 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index c90e235efd03..e91fc41afe63 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.58 2006/01/06 01:08:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.59 2006/02/07 01:37:55 vapier Exp $
+
+*grep-2.5.1a (07 Feb 2006)
+
+ 07 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/grep-2.5.1-bracket.patch, +files/grep-2.5.1-color.patch,
+ +grep-2.5.1a.ebuild:
+ Update to latest version and grab some patches from Fedora.
24 Dec 2005; Mike Frysinger <vapier@gentoo.org> grep-2.5.1-r8.ebuild,
grep-2.5.1-r9.ebuild:
diff --git a/sys-apps/grep/files/digest-grep-2.5.1a b/sys-apps/grep/files/digest-grep-2.5.1a
new file mode 100644
index 000000000000..86f3e9144a79
--- /dev/null
+++ b/sys-apps/grep/files/digest-grep-2.5.1a
@@ -0,0 +1,3 @@
+MD5 52202fe462770fa6be1bb667bd6cf30c grep-2.5.1a.tar.bz2 527386
+RMD160 f02c36c5a1efe805eafb0b4c0171ddb7ff15fbeb grep-2.5.1a.tar.bz2 527386
+SHA256 38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92bdd3132 grep-2.5.1a.tar.bz2 527386
diff --git a/sys-apps/grep/files/grep-2.5.1-bracket.patch b/sys-apps/grep/files/grep-2.5.1-bracket.patch
new file mode 100644
index 000000000000..f99571c02034
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.5.1-bracket.patch
@@ -0,0 +1,11 @@
+--- grep-2.5.1/src/dfa.c.bracket 2003-10-30 16:21:14.000000000 +0000
++++ grep-2.5.1/src/dfa.c 2003-10-30 16:22:38.000000000 +0000
+@@ -586,7 +586,7 @@
+ work_mbc->coll_elems[work_mbc->ncoll_elems++] = elem;
+ }
+ }
+- wc = -1;
++ wc1 = wc = -1;
+ }
+ else
+ /* We treat '[' as a normal character here. */
diff --git a/sys-apps/grep/files/grep-2.5.1-color.patch b/sys-apps/grep/files/grep-2.5.1-color.patch
new file mode 100644
index 000000000000..f54c258e114a
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.5.1-color.patch
@@ -0,0 +1,10 @@
+--- grep-2.5.1/src/grep.c.color 2004-11-16 16:46:22.845505847 +0000
++++ grep-2.5.1/src/grep.c 2004-11-16 16:46:27.961530537 +0000
+@@ -607,6 +607,7 @@
+ fputs ("\33[00m", stdout);
+ beg = b + match_size;
+ }
++ fputs ("\33[K", stdout);
+ }
+ fwrite (beg, 1, lim - beg, stdout);
+ if (ferror (stdout))
diff --git a/sys-apps/grep/grep-2.5.1-r8.ebuild b/sys-apps/grep/grep-2.5.1-r8.ebuild
index b8b221d717a7..9b722bd3949f 100644
--- a/sys-apps/grep/grep-2.5.1-r8.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r8.ebuild,v 1.13 2006/02/07 01:37:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r8.ebuild,v 1.14 2006/02/07 01:37:55 vapier Exp $
inherit flag-o-matic eutils
diff --git a/sys-apps/grep/grep-2.5.1a.ebuild b/sys-apps/grep/grep-2.5.1a.ebuild
new file mode 100644
index 000000000000..c8bee56f9ae7
--- /dev/null
+++ b/sys-apps/grep/grep-2.5.1a.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1a.ebuild,v 1.1 2006/02/07 01:37:55 vapier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/grep.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc-macos ~ppc64 s390 sh ~sparc ~x86"
+IUSE="build nls static"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix a weird sparc32 compiler bug
+ echo "" >> src/dfa.h
+
+ epatch "${FILESDIR}"/${PN}-2.5.1-manpage.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-fgrep.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-color.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-bracket.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-i18n.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-oi.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-restrict_arr.patch
+ epatch "${FILESDIR}"/2.5.1-utf8-case.patch
+ epatch "${FILESDIR}"/${PN}-2.5.1-perl-segv.patch #95495
+ epatch "${FILESDIR}"/${PN}-2.5.1-libintl.patch #92586
+ epatch "${FILESDIR}"/${PN}-2.5.1-fix-devices-skip.patch #113640
+
+ # retarded
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c || die
+}
+
+src_compile() {
+ if use static ; then
+ append-flags -static
+ append-ldflags -static
+ fi
+
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ --disable-perl-regexp \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # Override the default shell scripts... grep knows how to act
+ # based on how it's called
+ ln -sfn grep "${D}"/bin/egrep || die "ln egrep failed"
+ ln -sfn grep "${D}"/bin/fgrep || die "ln fgrep failed"
+
+ if use build ; then
+ rm -r "${D}"/usr/share
+ else
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ fi
+}
+
+pkg_postinst() {
+ if has pcre ${USE} ; then
+ ewarn "This grep ebuild no longer supports pcre. If you want this"
+ ewarn "functionality, please use 'pcregrep' from the pcre package."
+ fi
+}