summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/gsoap/ChangeLog8
-rw-r--r--net-libs/gsoap/gsoap-2.8.0.ebuild72
-rw-r--r--net-libs/gsoap/gsoap-2.8.1.ebuild71
-rw-r--r--net-libs/gsoap/gsoap-2.8.10.ebuild (renamed from net-libs/gsoap/gsoap-2.8.8.ebuild)2
4 files changed, 8 insertions, 145 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 5609fc93f0b2..d4603e1aa78c 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.18 2012/07/17 07:23:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.19 2012/08/23 04:06:12 patrick Exp $
+
+*gsoap-2.8.10 (23 Aug 2012)
+
+ 23 Aug 2012; Patrick Lauer <patrick@gentoo.org> +gsoap-2.8.10.ebuild,
+ -gsoap-2.8.0.ebuild, -gsoap-2.8.1.ebuild, -gsoap-2.8.8.ebuild:
+ Bump
*gsoap-2.8.9 (17 Jul 2012)
diff --git a/net-libs/gsoap/gsoap-2.8.0.ebuild b/net-libs/gsoap/gsoap-2.8.0.ebuild
deleted file mode 100644
index 7dd7f9db96da..000000000000
--- a/net-libs/gsoap/gsoap-2.8.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.0.ebuild,v 1.2 2010/10/02 10:28:46 polynomial-c Exp $
-
-EAPI=2
-
-inherit autotools eutils
-
-MY_P="${PN}-2.8"
-
-DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
-HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
-
-LICENSE="GPL-2 gSOAP"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc debug examples +ssl"
-
-DEPEND="app-arch/unzip
- sys-devel/flex
- sys-devel/bison
- sys-libs/zlib
- ssl? ( dev-libs/openssl )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # Fix Pre-ISO headers
- epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
- epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
-
- # causes compilation of app-emulation/virtualbox-ose[vboxwebsrv] to
- # break (bug #320901):
- #epatch "${FILESDIR}/${PN}-2.7.15-use_libtool.patch"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable ssl openssl) \
- $(use_enable examples samples) \
- $(use_enable debug)
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- # yes, we also install the license-file since
- # it contains info about how to apply the licenses
- dodoc *.txt
-
- dohtml changelog.html
-
- rm -rf "${D}"/usr/lib*/*.la
-
- if use examples; then
- rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
- insinto /usr/share/doc/${PF}/examples
- doins -r gsoap/samples/*
- fi
-
- if use doc; then
- dohtml -r gsoap/doc/*
- fi
-}
diff --git a/net-libs/gsoap/gsoap-2.8.1.ebuild b/net-libs/gsoap/gsoap-2.8.1.ebuild
deleted file mode 100644
index e21aff80c9ee..000000000000
--- a/net-libs/gsoap/gsoap-2.8.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.1.ebuild,v 1.1 2011/01/19 16:40:49 polynomial-c Exp $
-
-EAPI=2
-
-inherit autotools eutils
-
-MY_P="${PN}-2.8"
-
-DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
-HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
-
-LICENSE="GPL-2 gSOAP"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc debug examples +ssl"
-
-DEPEND="app-arch/unzip
- sys-devel/flex
- sys-devel/bison
- sys-libs/zlib
- ssl? ( dev-libs/openssl )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # Fix Pre-ISO headers
- epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
-
- # causes compilation of app-emulation/virtualbox-ose[vboxwebsrv] to
- # break (bug #320901):
- #epatch "${FILESDIR}/${PN}-2.7.15-use_libtool.patch"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable ssl openssl) \
- $(use_enable examples samples) \
- $(use_enable debug)
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- # yes, we also install the license-file since
- # it contains info about how to apply the licenses
- dodoc *.txt
-
- dohtml changelog.html
-
- rm -rf "${D}"/usr/lib*/*.la
-
- if use examples; then
- rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
- insinto /usr/share/doc/${PF}/examples
- doins -r gsoap/samples/*
- fi
-
- if use doc; then
- dohtml -r gsoap/doc/*
- fi
-}
diff --git a/net-libs/gsoap/gsoap-2.8.8.ebuild b/net-libs/gsoap/gsoap-2.8.10.ebuild
index f980c1e70e18..bf5c358678fe 100644
--- a/net-libs/gsoap/gsoap-2.8.8.ebuild
+++ b/net-libs/gsoap/gsoap-2.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.8.ebuild,v 1.1 2012/03/24 10:27:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.10.ebuild,v 1.1 2012/08/23 04:06:12 patrick Exp $
EAPI=4