summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/rpm/ChangeLog7
-rw-r--r--app-arch/rpm/files/digest-rpm-4.21
-rw-r--r--app-arch/rpm/rpm-4.2.ebuild59
3 files changed, 66 insertions, 1 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 491bd72ab42b..7993faa95aee 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/rpm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.17 2003/03/06 18:38:17 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.18 2003/03/06 19:49:23 cretin Exp $
+
+*rpm-4.2 (6 Mar 2003)
+
+ 6 Mar 2003; Stefan Jones <cretin@gentoo.org> rpm-4.2.ebuild :
+ Newest rpm available from redhat rawhide. Seems to work fine.
*rpm-4.0.4-r5 (28 Feb 2003)
diff --git a/app-arch/rpm/files/digest-rpm-4.2 b/app-arch/rpm/files/digest-rpm-4.2
new file mode 100644
index 000000000000..16e6e0cf0e87
--- /dev/null
+++ b/app-arch/rpm/files/digest-rpm-4.2
@@ -0,0 +1 @@
+MD5 5f49ade214a8395fd9a7fcd947ff2b22 rpm-4.2.tar.gz 8712478
diff --git a/app-arch/rpm/rpm-4.2.ebuild b/app-arch/rpm/rpm-4.2.ebuild
new file mode 100644
index 000000000000..63e658c6f60c
--- /dev/null
+++ b/app-arch/rpm/rpm-4.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2.ebuild,v 1.1 2003/03/06 19:49:23 cretin Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Red Hat Package Management Utils"
+SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/${P}.tar.gz"
+HOMEPAGE="http://www.rpm.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="nls python doc"
+RDEPEND="=sys-libs/db-3.2*
+ >=sys-libs/zlib-1.1.3
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ nls? ( sys-devel/gettext )
+ python? ( =dev-lang/python-2.2* )
+ doc? ( app-doc/doxygen )"
+
+strip-flags
+
+src_compile() {
+ unset LD_ASSUME_KERNEL
+ local myconf
+ myconf="--enable-posixmutexes --without-javaglue"
+ use python \
+ && myconf="${myconf} --with-python=2.2" \
+ || myconf="${myconf} --without-python"
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ mv ${D}/bin/rpm ${D}/usr/bin
+ rm -rf ${D}/bin
+ # Fix for bug #8578 (app-arch/rpm create dead symlink)
+ # Local RH 7.3 install has no such symlink anywhere
+ # ------
+ # UPDATE for 4.1!
+ # There is a /usr/lib/rpm/rpmpopt-4.1 now
+ # the symlink is still created incorrectly. ???
+ rm -f ${D}/usr/lib/rpmpopt
+ keepdir /var/lib/rpm
+ dodoc CHANGES COPYING CREDITS GROUPS README* RPM* TODO
+}
+
+pkg_postinst() {
+ if [ -f ${ROOT}/var/lib/rpm/Packages ]; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ ${ROOT}/usr/bin/rpm --rebuilddb --root=${ROOT}
+ else
+ einfo "No RPM database found... Creating database..."
+ ${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
+ fi
+}