summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/gnubiff/ChangeLog10
-rw-r--r--net-mail/gnubiff/files/gnubiff-2.2.13-fix-nls.patch14
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.13-r1.ebuild (renamed from net-mail/gnubiff/gnubiff-2.2.13.ebuild)9
3 files changed, 31 insertions, 2 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index fb7cd87c229c..321dda5dd76c 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/gnubiff
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.25 2010/08/29 21:33:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.26 2010/10/02 00:32:15 radhermit Exp $
+
+*gnubiff-2.2.13-r1 (02 Oct 2010)
+
+ 02 Oct 2010; Tim Harder <radhermit@gentoo.org> -gnubiff-2.2.13.ebuild,
+ +gnubiff-2.2.13-r1.ebuild, +files/gnubiff-2.2.13-fix-nls.patch:
+ Revision bump and remove old. Fix compile errors when the nls USE flag is
+ not enabled (fixes bug #339398) and add gnome-base/gnome-panel dependency
+ for GNOME support.
*gnubiff-2.2.13 (29 Aug 2010)
diff --git a/net-mail/gnubiff/files/gnubiff-2.2.13-fix-nls.patch b/net-mail/gnubiff/files/gnubiff-2.2.13-fix-nls.patch
new file mode 100644
index 000000000000..24fdfa7415ac
--- /dev/null
+++ b/net-mail/gnubiff/files/gnubiff-2.2.13-fix-nls.patch
@@ -0,0 +1,14 @@
+--- gnubiff-2.2.13.orig/src/nls.h 2009-01-01 16:45:39.000000000 -0800
++++ gnubiff-2.2.13/src/nls.h 2010-10-01 17:13:03.595458860 -0700
+@@ -49,11 +49,6 @@
+ #else
+ # define _(String) (String)
+ # define N_(String) (String)
+-# define textdomain(String) (String)
+-# define gettext(String) (String)
+-# define dgettext(Domain,String) (String)
+-# define dcgettext(Domain,String,Type) (String)
+-# define bindtextdomain(Domain,Directory) (Domain)
+ #endif
+
+ #endif
diff --git a/net-mail/gnubiff/gnubiff-2.2.13.ebuild b/net-mail/gnubiff/gnubiff-2.2.13-r1.ebuild
index 2c765f87df4b..d1f3d6771988 100644
--- a/net-mail/gnubiff/gnubiff-2.2.13.ebuild
+++ b/net-mail/gnubiff/gnubiff-2.2.13-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.13.ebuild,v 1.1 2010/08/29 21:33:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.13-r1.ebuild,v 1.1 2010/10/02 00:32:15 radhermit Exp $
EAPI=3
+inherit eutils
+
DESCRIPTION="A mail notification program"
HOMEPAGE="http://gnubiff.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -17,6 +19,7 @@ RDEPEND=">=x11-libs/gtk+-2.6
>=gnome-base/libglade-2.3
dev-libs/popt
gnome? (
+ gnome-base/gnome-panel
>=gnome-base/libgnome-2.2
>=gnome-base/libgnomeui-2.2 )
password? ( dev-libs/openssl )
@@ -25,6 +28,10 @@ RDEPEND=">=x11-libs/gtk+-2.6
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-nls.patch
+}
+
src_configure() {
econf \
$(use_enable debug) \