summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild33
-rw-r--r--net-libs/libfwbuilder/libfwbuilder-0.10.8-r1.ebuild7
-rw-r--r--net-libs/rpc2/rpc2-1.13.ebuild27
-rw-r--r--net-misc/bidwatcher/bidwatcher-1.3.3.ebuild27
-rw-r--r--net-p2p/mutella/mutella-0.3.3.ebuild26
5 files changed, 39 insertions, 81 deletions
diff --git a/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild b/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild
index 33e1d4b1d59a..0040526407ba 100644
--- a/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild
+++ b/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild
@@ -1,46 +1,31 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
-
-IUSE="ssl"
-
-S=${WORKDIR}/${PN}
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild,v 1.2 2002/11/12 06:47:01 vapier Exp $
DESCRIPTION="A remote security scanner for Linux (nessus-libraries)"
HOMEPAGE="http://www.nessus.org/"
SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
-RDEPEND=${DEPEND}
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc -sparc -sparc64"
+IUSE="ssl"
-src_compile() {
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf=""
use ssl && myconf="--with-ssl=/usr/lib" \
|| myconf="--without-ssl"
- econf \
- ${myconf} || die "configure failed"
-
-
+ econf ${myconf}
emake || die "emake failed"
-
}
src_install() {
-
- make \
- prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- mandir=${D}/usr/share/man \
- install || die "make install failed"
-
- cd ${S}
+ einstall
docinto nessus-libraries
dodoc README*
-
}
diff --git a/net-libs/libfwbuilder/libfwbuilder-0.10.8-r1.ebuild b/net-libs/libfwbuilder/libfwbuilder-0.10.8-r1.ebuild
index 53384deecbd4..8793a14ceef0 100644
--- a/net-libs/libfwbuilder/libfwbuilder-0.10.8-r1.ebuild
+++ b/net-libs/libfwbuilder/libfwbuilder-0.10.8-r1.ebuild
@@ -2,23 +2,20 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /home/cvsroot/gentoo-x86/net-libs/libfwbuilder/libfwbuilder-0.10.8.ebuild,v 1.0
-IUSE="ssl static"
-
MY_PN=${PN/lib/}
DESCRIPTION="A firewall GUI"
SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tar.gz"
HOMEPAGE="http://fwbuilder.sourceforge.net"
-S=${WORKDIR}/${P}
KEYWORDS="x86 sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
+IUSE="ssl static"
DEPEND=">=dev-libs/libsigc++-1.0
>=dev-libs/libxslt-1.0.7
>=net-analyzer/ucd-snmp-4.2.3
ssl? ( dev-libs/openssl )"
-RDEPEND=${DEPEND}
src_unpack() {
unpack ${A}
@@ -37,7 +34,7 @@ src_compile() {
--host=${CHOST} \
${myconf} || die "./configure failed"
- if [ "`use static`" ] ; then
+ if [ `use static` ] ; then
emake LDFLAGS="-static" || die "emake LDFLAGS failed"
else
emake || die "emake failed"
diff --git a/net-libs/rpc2/rpc2-1.13.ebuild b/net-libs/rpc2/rpc2-1.13.ebuild
index 094d56a760c5..c7e6744a6c98 100644
--- a/net-libs/rpc2/rpc2-1.13.ebuild
+++ b/net-libs/rpc2/rpc2-1.13.ebuild
@@ -1,37 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rpc2/rpc2-1.13.ebuild,v 1.3 2002/08/16 02:57:06 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rpc2/rpc2-1.13.ebuild,v 1.4 2002/11/12 06:49:30 vapier Exp $
DESCRIPTION="Remote procedure call package for IP/UDP (used by Coda)"
-
-# Appearantly maintained by the Coda people
-HOMEPAGE="http://www.coda.cs.cmu.edu"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.gz"
LICENSE="LGPL-2.1"
KEYWORDS="x86 sparc sparc64"
-
-SLOT=1
+SLOT="1"
# partly based on the deps suggested by Mandrake's RPM
DEPEND="virtual/glibc
>=sys-libs/lwp-1.9
>=sys-libs/ncurses-5
>=sys-libs/readline-4.1"
-RDEPEND=${DEPEND}
-
-SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.gz"
-
-S=${WORKDIR}/${P}
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
- emake || die
+ econf
+ emake || die "emake failed"
}
-src_install () {
- make DESTDIR=${D} install || die
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
}
diff --git a/net-misc/bidwatcher/bidwatcher-1.3.3.ebuild b/net-misc/bidwatcher/bidwatcher-1.3.3.ebuild
index 3fbaa7a441ad..2cbfce51ca7f 100644
--- a/net-misc/bidwatcher/bidwatcher-1.3.3.ebuild
+++ b/net-misc/bidwatcher/bidwatcher-1.3.3.ebuild
@@ -1,32 +1,25 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bidwatcher/bidwatcher-1.3.3.ebuild,v 1.4 2002/08/14 12:08:07 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bidwatcher/bidwatcher-1.3.3.ebuild,v 1.5 2002/11/12 06:50:17 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="eBay auction watcher and snipe agent"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://bidwatcher.sourceforge.net/"
-DEPEND="virtual/glibc
- =x11-libs/gtk+-1.2*
- =dev-libs/glib-1.2*"
-RDEPEND=${DEPEND}
-
KEYWORDS="x86 sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-src_compile() {
- ./configure \
- --build=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info || die "./configure failed"
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*"
- emake || die
+src_compile() {
+ econf
+ emake || die "emake failed"
}
-src_install () {
- make DESTDIR=${D} install || die
- dodoc quick_start.html README COPYING NEWS AUTHORS ChangeLog TODO
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc quick_start.html README COPYING NEWS AUTHORS ChangeLog TODO
}
diff --git a/net-p2p/mutella/mutella-0.3.3.ebuild b/net-p2p/mutella/mutella-0.3.3.ebuild
index f3a6e8e9bfcb..6a5a86106d3f 100644
--- a/net-p2p/mutella/mutella-0.3.3.ebuild
+++ b/net-p2p/mutella/mutella-0.3.3.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.3.3.ebuild,v 1.5 2002/11/03 17:38:25 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.3.3.ebuild,v 1.6 2002/11/12 06:51:26 vapier Exp $
+
+DESCRIPTION="Text-mode gnutella client"
+SRC_URI="mirror://sourceforge/mutella/${P}.tar.gz"
+HOMEPAGE="http://mutella.sourceforge.net/"
-S=${WORKDIR}/${P}
-DESCRIPTION="Text-mode gnutella client."
-SRC_URI="http://telia.dl.sourceforge.net/sourceforge/mutella/mutella-0.3.3.tar.gz"
-HOMEPAGE="http://mutella.sourceforge.net"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-DEPEND="virtual/glibc sys-libs/readline"
-RDEPEND=${DEPEND}
+DEPEND="virtual/glibc
+ sys-libs/readline"
src_unpack() {
unpack ${A}
@@ -19,17 +19,11 @@ src_unpack() {
}
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf
emake || die "compile problem"
}
-src_install () {
- make DESTDIR=${D} install || die
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
dodoc AUTHORS ChangeLog COPYING INSTALL KNOWN-BUGS README TODO
}
-
-