summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libselinux/ChangeLog7
-rw-r--r--sys-libs/libselinux/libselinux-2.1.9-r2.ebuild97
2 files changed, 103 insertions, 1 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index f3d0b6c7ac85..2fb4d2361b72 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libselinux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.83 2012/08/06 07:46:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.84 2012/09/08 18:44:22 swift Exp $
+
+*libselinux-2.1.9-r2 (08 Sep 2012)
+
+ 08 Sep 2012; <swift@gentoo.org> +libselinux-2.1.9-r2.ebuild:
+ Fix bugs #429456 and #417303
06 Aug 2012; Patrick Lauer <patrick@gentoo.org> libselinux-2.1.9-r1.ebuild:
Restricting python ABIs that don't work
diff --git a/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild b/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild
new file mode 100644
index 000000000000..55c92fa6ee30
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild,v 1.1 2012/09/08 18:44:22 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+USE_RUBY="ruby18"
+RUBY_OPTIONAL="yes"
+
+inherit multilib python toolchain-funcs eutils ruby-ng
+
+SEPOL_VER="2.1.4"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ ruby? ( $(ruby_implementations_depend) )"
+DEPEND="${RDEPEND}
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+
+ if use ruby; then
+ ruby-ng_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+ epatch "${FILESDIR}/${P}-mountsys.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ emake CC="$(tc-getCC)" rubywrap || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}