summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/molscript/ChangeLog6
-rw-r--r--sci-chemistry/molscript/files/2.1.2-prll.patch10
-rw-r--r--sci-chemistry/molscript/files/fix-makefile-shared.patch2
-rw-r--r--sci-chemistry/molscript/molscript-2.1.2-r1.ebuild10
4 files changed, 22 insertions, 6 deletions
diff --git a/sci-chemistry/molscript/ChangeLog b/sci-chemistry/molscript/ChangeLog
index 1c0aa5f044b9..b01866c8e2ab 100644
--- a/sci-chemistry/molscript/ChangeLog
+++ b/sci-chemistry/molscript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/molscript
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/ChangeLog,v 1.12 2010/11/08 17:16:15 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/ChangeLog,v 1.13 2010/11/15 22:44:29 jlec Exp $
+
+ 15 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/2.1.2-prll.patch,
+ molscript-2.1.2-r1.ebuild, files/fix-makefile-shared.patch:
+ Fix prll compilation
08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org>
-molscript-2.1.2.ebuild, molscript-2.1.2-r1.ebuild:
diff --git a/sci-chemistry/molscript/files/2.1.2-prll.patch b/sci-chemistry/molscript/files/2.1.2-prll.patch
new file mode 100644
index 000000000000..e4c972a10533
--- /dev/null
+++ b/sci-chemistry/molscript/files/2.1.2-prll.patch
@@ -0,0 +1,10 @@
+diff --git a/Makefile.complete b/Makefile.complete
+index 92ef20a..e3f68e3 100644
+--- a/Makefile.complete
++++ b/Makefile.complete
+@@ -153,4 +153,4 @@ molauto.o: molauto.c
+
+ #------------------------------------------------------------
+ clib/clib.a:
+- cd clib; make clib.a CFLAGS="-I. $(CFLAGS)" OPENGLCLIBOBJ="$(OPENGLCLIBOBJ)"
++ $(MAKE) -C clib clib.a CFLAGS="-I. $(CFLAGS)" OPENGLCLIBOBJ="$(OPENGLCLIBOBJ)"
diff --git a/sci-chemistry/molscript/files/fix-makefile-shared.patch b/sci-chemistry/molscript/files/fix-makefile-shared.patch
index b718b07bda5d..a9947a61a665 100644
--- a/sci-chemistry/molscript/files/fix-makefile-shared.patch
+++ b/sci-chemistry/molscript/files/fix-makefile-shared.patch
@@ -56,7 +56,7 @@ diff -urN molscript-2.1.2.orig/Makefile.complete molscript-2.1.2/Makefile.comple
# Correctness flags:
#CCHECK = -ansi -fullwarn -g -DSELECT_DEBUG
-CCHECK = -ansi -fullwarn
-+CCHECK = -ansi -Wall
++CCHECK = -ansi
#CCHECK = -ansi -fullwarn -DNDEBUG
# General cc compile flags.
diff --git a/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild b/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
index f6592f9bd59d..967ce690880d 100644
--- a/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
+++ b/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild,v 1.5 2010/11/08 17:16:15 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild,v 1.6 2010/11/15 22:44:29 jlec Exp $
EAPI="3"
@@ -33,15 +33,17 @@ pkg_nofetch() {
}
src_prepare() {
- epatch "${FILESDIR}"/fix-makefile-shared.patch
- epatch "${FILESDIR}"/${PV}-ldflags.patch
+ epatch \
+ "${FILESDIR}"/fix-makefile-shared.patch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-prll.patch
# Provide glutbitmap.h, because freeglut doesn't have it
cp "${FILESDIR}"/glutbitmap.h "${S}"/clib/
# Stop an incredibly hacky include
sed -i -e 's:<../lib/glut/glutbitmap.h>:"glutbitmap.h":g' \
- "${S}"/clib/ogl_bitmap_character.c
+ "${S}"/clib/ogl_bitmap_character.c || die
}
src_compile() {