summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/gtk+/ChangeLog12
-rw-r--r--x11-libs/gtk+/files/gtk+-3.2.4-fallback-theme.patch81
-rw-r--r--x11-libs/gtk+/gtk+-2.24.10-r1.ebuild6
-rw-r--r--x11-libs/gtk+/gtk+-2.24.10.ebuild239
-rw-r--r--x11-libs/gtk+/gtk+-3.2.4-r1.ebuild212
-rw-r--r--x11-libs/gtk+/gtk+-3.2.4.ebuild5
6 files changed, 313 insertions, 242 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 7914453bdbba..4b37ff93149d 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.571 2012/03/14 02:25:34 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.572 2012/03/15 15:00:27 tetromino Exp $
+
+*gtk+-3.2.4-r1 (15 Mar 2012)
+
+ 15 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -gtk+-2.24.10.ebuild, gtk+-2.24.10-r1.ebuild, gtk+-3.2.4.ebuild,
+ +gtk+-3.2.4-r1.ebuild, +files/gtk+-3.2.4-fallback-theme.patch:
+ For 3.2.4-r1, fall back to the theme in /etc/gtk-3.0/settings.ini if the
+ theme specified by gnome-settings-daemon does not support gtk3 (provides a
+ better gtk3 experience for gnome2 users). Regenerate marshalers code that had
+ been generated with glib-2.31 (fixes g_value_get_schar errors).
*gtk+-3.2.4 (14 Mar 2012)
diff --git a/x11-libs/gtk+/files/gtk+-3.2.4-fallback-theme.patch b/x11-libs/gtk+/files/gtk+-3.2.4-fallback-theme.patch
new file mode 100644
index 000000000000..d2ec99db477f
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.2.4-fallback-theme.patch
@@ -0,0 +1,81 @@
+From 65ba7fe4ae1ad96f69395fbc585c34fd577e5279 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 14 Mar 2012 23:08:53 -0400
+Subject: [PATCH] settings: fall back to settings.ini gtk theme if requested
+ theme fails
+
+If a gtk3 application is run in gnome2 and the settings daemon uses
+xsettings to request a gtk2 theme with no gtk3 version (which is the
+case by default), then instead of failing to load any theme, we should
+attempt to fall back to the theme specified in settings.ini files.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=654108
+---
+ gtk/gtksettings.c | 23 +++++++++++++++++++++++
+ 1 files changed, 23 insertions(+), 0 deletions(-)
+
+diff --git a/gtk/gtksettings.c b/gtk/gtksettings.c
+index 289006f..561cb56 100644
+--- a/gtk/gtksettings.c
++++ b/gtk/gtksettings.c
+@@ -99,6 +99,7 @@ struct _GtkSettingsPrivate
+ GdkScreen *screen;
+ GtkCssProvider *theme_provider;
+ GtkCssProvider *key_theme_provider;
++ gchar *fallback_gtk_theme_name;
+ };
+
+ typedef enum
+@@ -1420,6 +1421,8 @@ gtk_settings_finalize (GObject *object)
+ if (priv->key_theme_provider)
+ g_object_unref (priv->key_theme_provider);
+
++ g_free (priv->fallback_gtk_theme_name);
++
+ G_OBJECT_CLASS (gtk_settings_parent_class)->finalize (object);
+ }
+
+@@ -1769,6 +1772,12 @@ apply_queued_setting (GtkSettings *settings,
+ if (pspec->param_id == PROP_COLOR_SCHEME)
+ merge_color_scheme (settings, &tmp_value, qvalue->source);
+
++ if (!g_strcmp0 (pspec->name, "gtk-theme-name") && qvalue->source == GTK_SETTINGS_SOURCE_DEFAULT)
++ {
++ g_free (priv->fallback_gtk_theme_name);
++ priv->fallback_gtk_theme_name = g_value_dup_string (&tmp_value);
++ }
++
+ if (priv->property_values[pspec->param_id - 1].source <= qvalue->source)
+ {
+ g_value_copy (&tmp_value, &priv->property_values[pspec->param_id - 1].value);
+@@ -2474,6 +2483,10 @@ _gtk_settings_reset_rc_values (GtkSettings *settings)
+ }
+ i++;
+ }
++
++ g_free (priv->fallback_gtk_theme_name);
++ priv->fallback_gtk_theme_name = NULL;
++
+ g_object_thaw_notify (G_OBJECT (settings));
+ g_free (pspecs);
+ }
+@@ -2759,6 +2772,16 @@ settings_update_theme (GtkSettings *settings)
+
+ if (!provider)
+ provider = gtk_css_provider_get_named (theme_name, NULL);
++
++ /* If we failed, fall back to the theme from settings.ini */
++ if (!provider && priv->fallback_gtk_theme_name && *priv->fallback_gtk_theme_name
++ && g_strcmp0 (theme_name, priv->fallback_gtk_theme_name))
++ {
++ provider = gtk_css_provider_get_named (priv->fallback_gtk_theme_name, NULL);
++
++ if (!provider)
++ provider = gtk_css_provider_get_named (priv->fallback_gtk_theme_name, NULL);
++ }
+ }
+
+ settings_update_provider (priv->screen, &priv->theme_provider, provider);
+--
+1.7.8.5
+
diff --git a/x11-libs/gtk+/gtk+-2.24.10-r1.ebuild b/x11-libs/gtk+/gtk+-2.24.10-r1.ebuild
index 72b442620e1e..c676ffa51b31 100644
--- a/x11-libs/gtk+/gtk+-2.24.10-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.10-r1.ebuild,v 1.2 2012/02/14 00:11:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.10-r1.ebuild,v 1.3 2012/03/15 15:00:27 tetromino Exp $
EAPI="4"
@@ -90,6 +90,10 @@ src_prepare() {
# fix building with gir #372953, upstream bug #642085
epatch "${FILESDIR}"/${PN}-2.24.7-darwin-quartz-introspection.patch
+ # marshalers code was pre-generated with glib-2.31, upstream bug #671763
+ rm -v gdk/gdkmarshalers.c gtk/gtkmarshal.c gtk/gtkmarshalers.c \
+ perf/marshalers.c || die
+
# Stop trying to build unmaintained docs, bug #349754
strip_builddir SUBDIRS tutorial docs/Makefile.am docs/Makefile.in
strip_builddir SUBDIRS faq docs/Makefile.am docs/Makefile.in
diff --git a/x11-libs/gtk+/gtk+-2.24.10.ebuild b/x11-libs/gtk+/gtk+-2.24.10.ebuild
deleted file mode 100644
index 24e1aea32cd2..000000000000
--- a/x11-libs/gtk+/gtk+-2.24.10.ebuild
+++ /dev/null
@@ -1,239 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.10.ebuild,v 1.3 2012/02/13 23:09:27 tetromino Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.5"
-
-inherit eutils flag-o-matic gnome.org libtool python virtualx autotools
-
-DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
-SRC_URI="${SRC_URI} mirror://gentoo/introspection.m4.bz2"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="aqua cups debug doc examples +introspection test vim-syntax xinerama"
-
-# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
-COMMON_DEPEND="!aqua? (
- x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXt
- x11-libs/libXext
- >=x11-libs/libXrandr-1.3
- x11-libs/libXcursor
- x11-libs/libXfixes
- x11-libs/libXcomposite
- x11-libs/libXdamage
- >=x11-libs/cairo-1.6[X,svg]
- x11-libs/gdk-pixbuf:2[X,introspection?]
- )
- aqua? (
- >=x11-libs/cairo-1.6[aqua,svg]
- x11-libs/gdk-pixbuf:2[introspection?]
- )
- xinerama? ( x11-libs/libXinerama )
- >=dev-libs/glib-2.27.3:2
- >=x11-libs/pango-1.20[introspection?]
- >=dev-libs/atk-1.29.2[introspection?]
- media-libs/fontconfig
- x11-misc/shared-mime-info
- cups? ( net-print/cups )
- introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
- !dev-util/gtk-builder-convert
- !<gnome-base/gail-1000"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/pkgconfig-0.9
- !aqua? (
- x11-proto/xextproto
- x11-proto/xproto
- x11-proto/inputproto
- x11-proto/damageproto
- )
- xinerama? ( x11-proto/xineramaproto )
- >=dev-util/gtk-doc-am-1.11
- doc? (
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )
- test? (
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc )"
-# gtk+-2.24.8 breaks Alt key handling in <=x11-libs/vte-0.28.2:0
-# Remove blocker after >=vte-0.28.2-r201:0 is stable
-RDEPEND="${COMMON_DEPEND}
- !<x11-libs/vte-0.28.2-r201:0"
-PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
-
-strip_builddir() {
- local rule=$1
- shift
- local directory=$1
- shift
- sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
- || die "Could not strip director ${directory} from build."
-}
-
-set_gtk2_confdir() {
- # An arch specific config directory is used on multilib systems
- GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
-}
-
-src_prepare() {
- # use an arch-specific config directory so that 32bit and 64bit versions
- # dont clash on multilib systems
- epatch "${FILESDIR}/${PN}-2.21.3-multilib.patch"
-
- # Don't break inclusion of gtkclist.h, upstream bug 536767
- epatch "${FILESDIR}/${PN}-2.14.3-limit-gtksignal-includes.patch"
-
- # fix building with gir #372953, upstream bug #642085
- epatch "${FILESDIR}"/${PN}-2.24.7-darwin-quartz-introspection.patch
-
- # Stop trying to build unmaintained docs, bug #349754
- strip_builddir SUBDIRS tutorial docs/Makefile.am docs/Makefile.in
- strip_builddir SUBDIRS faq docs/Makefile.am docs/Makefile.in
-
- # -O3 and company cause random crashes in applications. Bug #133469
- replace-flags -O3 -O2
- strip-flags
-
- use ppc64 && append-flags -mminimal-toc
-
- if ! use test; then
- # don't waste time building tests
- strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
- strip_builddir SUBDIRS tests gdk/Makefile.{am,in} gtk/Makefile.{am,in}
- else
- # Non-working test in gentoo's env
- sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
- -i gtk/tests/testing.c || die "sed 1 failed"
-
- # Cannot work because glib is too clever to find real user's home
- # gentoo bug #285687, upstream bug #639832
- # XXX: /!\ Pay extra attention to second sed when bumping /!\
- sed '/TEST_PROGS.*recentmanager/d' -i gtk/tests/Makefile.am \
- || die "failed to disable recentmanager test (1)"
- sed '/^TEST_PROGS =/,+3 s/recentmanager//' -i gtk/tests/Makefile.in \
- || die "failed to disable recentmanager test (2)"
- sed 's:\({ "GtkFileChooserButton".*},\):/*\1*/:g' -i gtk/tests/object.c \
- || die "failed to disable recentmanager test (3)"
-
- # Skip tests known to fail
- # https://bugzilla.gnome.org/show_bug.cgi?id=646609
- sed -e '/g_test_add_func.*test_text_access/s:^://:' \
- -i "${S}/gtk/tests/testing.c" || die
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=617473
- sed -i -e 's:pltcheck.sh:$(NULL):g' \
- gtk/Makefile.am || die
- fi
-
- if ! use examples; then
- # don't waste time building demos
- strip_builddir SRC_SUBDIRS demos Makefile.am Makefile.in
- fi
-
- # http://bugs.gentoo.org/show_bug.cgi?id=371907
- mkdir -p "${S}/m4" || die
- mv "${WORKDIR}/introspection.m4" "${S}/m4macros" || die
- AT_M4DIR=m4macros eautoreconf
- # Use elibtoolize in place of eautoreconf when it will be dropped
- #elibtoolize
-}
-
-src_configure() {
- local myconf="$(use_enable doc gtk-doc)
- $(use_enable xinerama)
- $(use_enable cups cups auto)
- $(use_enable introspection)
- --disable-papi"
- if use aqua; then
- myconf="${myconf} --with-gdktarget=quartz"
- else
- myconf="${myconf} --with-gdktarget=x11 --with-xinput"
- fi
-
- # Passing --disable-debug is not recommended for production use
- use debug && myconf="${myconf} --enable-debug=yes"
-
- econf ${myconf}
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- # Exporting HOME fixes tests using XDG directories spec since all defaults
- # are based on $HOME. It is also backward compatible with functions not
- # yet ported to this spec.
- XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- set_gtk2_confdir
- dodir ${GTK2_CONFDIR}
- keepdir ${GTK2_CONFDIR}
-
- # see bug #133241
- echo 'gtk-fallback-icon-theme = "gnome"' > "${T}/gtkrc"
- insinto /etc/gtk-2.0
- doins "${T}"/gtkrc
-
- # Enable xft in environment as suggested by <utx@gentoo.org>
- echo "GDK_USE_XFT=1" > "${T}"/50gtk2
- doenvd "${T}"/50gtk2
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-
- # add -framework Carbon to the .pc files
- use aqua && for i in gtk+-2.0.pc gtk+-quartz-2.0.pc gtk+-unix-print-2.0.pc; do
- sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED%/}"/usr/lib/pkgconfig/$i || die "sed failed"
- done
-
- python_convert_shebangs 2 "${ED}"usr/bin/gtk-builder-convert
-
- find "${D}" -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- set_gtk2_confdir
-
- # gtk.immodules should be in their CHOST directories respectively.
- gtk-query-immodules-2.0 > "${EROOT%/}${GTK2_CONFDIR}/gtk.immodules" \
- || ewarn "Failed to run gtk-query-immodules-2.0"
-
- if [ -e "${EROOT%/}/etc/gtk-2.0/gtk.immodules" ]; then
- elog "File /etc/gtk-2.0/gtk.immodules has been moved to \$CHOST"
- elog "aware location. Removing deprecated file."
- rm -f ${EROOT%/}/etc/gtk-2.0/gtk.immodules
- fi
-
- # pixbufs are now handled by x11-libs/gdk-pixbuf
- if [ -e "${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders" ]; then
- elog "File ${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
- elog "Removing deprecated file."
- rm -f ${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders
- fi
-
- # two checks needed since we dropped multilib conditional
- if [ -e "${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders" ]; then
- elog "File ${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
- elog "Removing deprecated file."
- rm -f ${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders
- fi
-
- if [ -e "${EROOT%/}"/usr/lib/gtk-2.0/2.[^1]* ]; then
- elog "You need to rebuild ebuilds that installed into" "${EROOT%/}"/usr/lib/gtk-2.0/2.[^1]*
- elog "to do that you can use qfile from portage-utils:"
- elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.[^1]*)"
- fi
-
- if ! has_version "app-text/evince"; then
- elog "Please install app-text/evince for print preview functionality."
- elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
- elog "add it to your gtkrc."
- fi
-}
diff --git a/x11-libs/gtk+/gtk+-3.2.4-r1.ebuild b/x11-libs/gtk+/gtk+-3.2.4-r1.ebuild
new file mode 100644
index 000000000000..7d1a55bd6ac0
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.2.4-r1.ebuild
@@ -0,0 +1,212 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.2.4-r1.ebuild,v 1.1 2012/03/15 15:00:27 tetromino Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic gnome.org gnome2-utils libtool virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="3"
+# NOTE: This gtk+ has multi-gdk-backend support, see:
+# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
+# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
+# I tried this and got it all compiling, but the end result is unusable as it
+# horribly mixes up the backends -- grobian
+IUSE="aqua colord cups debug doc examples +introspection packagekit test vim-syntax xinerama"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# FIXME: introspection data is built against system installation of gtk+:3
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+# Use gtk+:2 for gtk-update-icon-cache and gtk-builder-convert
+# >=x11-libs/gtk+-2.24:2 is needed for bug 359555
+COMMON_DEPEND="!aqua? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ >=x11-libs/cairo-1.10.0[X,glib,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[X,introspection?]
+ )
+ aqua? (
+ >=x11-libs/cairo-1.10.0[aqua,glib,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[introspection?]
+ )
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.29.14
+ >=x11-libs/pango-1.29.0[introspection?]
+ >=dev-libs/atk-2.1.5[introspection?]
+ >=x11-libs/gtk+-2.24:2
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ colord? ( >=x11-misc/colord-0.1.9 )
+ cups? ( net-print/cups )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ !aqua? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ !<x11-libs/vte-0.30.1-r1:2.90
+ packagekit? ( app-admin/packagekit-base )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ # marshalers code was pre-generated with glib-2.31, upstream bug #671763
+ rm -v gdk/gdkmarshalers.c gtk/gtkmarshalers.c || die
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=654108
+ epatch "${FILESDIR}/${PN}-3.2.4-fallback-theme.patch"
+
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+ sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
+ -i gtk/tests/recentmanager.c || die "sed 2 failed"
+
+ # Missing file, required for tests; https://bugzilla.gnome.org/show_bug.cgi?id=662024
+ cp "${FILESDIR}/${PN}-3.2.1-selector.errors" \
+ tests/css/parser/selector.errors || die "cp failed"
+
+ # FIXME: multiple reftests fail when run from portage (but succeed when
+ # run from a manual compile in a temp directory)
+ sed -e 's:\(SUBDIRS.*\)reftests:\1:' \
+ -i tests/Makefile.* || die "sed 3 failed"
+
+ # Test results depend on the list of mounted filesystems!
+ rm -v tests/a11y/pickers.{ui,txt} || die "rm failed"
+
+ # Failing treeview scrolling tests; bug #384855,
+ # https://bugzilla.gnome.org/show_bug.cgi?id=660931
+ epatch "${FILESDIR}/${PN}-3.2.1-failing-tests.patch"
+
+ if ! use test; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS tests Makefile.am
+ strip_builddir SRC_SUBDIRS tests Makefile.in
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am
+ strip_builddir SRC_SUBDIRS demos Makefile.in
+ fi
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc)
+ $(use_enable xinerama)
+ $(use_enable packagekit)
+ $(use_enable cups cups auto)
+ $(use_enable colord)
+ $(use_enable introspection)
+ --disable-papi
+ --enable-gtk2-dependency"
+
+ # XXX: Maybe with multi-backend we should enable x11 all the time?
+ if use aqua; then
+ myconf="${myconf} --enable-quartz-backend --disable-xinput"
+ else
+ myconf="${myconf} --enable-x11-backend --enable-xinput"
+ fi
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" ${myconf}
+}
+
+src_test() {
+ # Tests require a new gnome-themes-standard, but adding it to DEPEND
+ # would result in circular dependencies.
+ # bug #398789, https://bugzilla.gnome.org/show_bug.cgi?id=669562
+ if ! has_version '=x11-themes/gnome-themes-standard-3.2*'; then
+ ewarn "Tests will be skipped beecause =gnome-themes-standard-3.2*"
+ ewarn "is not installed. Please re-run tests after installing the"
+ ewarn "required version of gnome-themes-standard."
+ return 0
+ fi
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Exporting HOME fixes tests using XDG directories spec since all defaults
+ # are based on $HOME. It is also backward compatible with functions not
+ # yet ported to this spec.
+ XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+
+ # Remove unneeded *.la files
+ find "${D}" -name '*.la' -exec rm -f {} +
+
+ # add -framework Carbon to the .pc files
+ use aqua && for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
+ sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+ done
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ local GTK3_MODDIR="${EROOT}usr/$(get_libdir)/gtk-3.0/3.0.0"
+ gtk-query-immodules-3.0 > "${GTK3_MODDIR}/immodules.cache" \
+ || ewarn "Failed to run gtk-query-immodules-3.0"
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/x11-libs/gtk+/gtk+-3.2.4.ebuild b/x11-libs/gtk+/gtk+-3.2.4.ebuild
index c1b448d95e74..f8c3ef6308aa 100644
--- a/x11-libs/gtk+/gtk+-3.2.4.ebuild
+++ b/x11-libs/gtk+/gtk+-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.2.4.ebuild,v 1.1 2012/03/14 02:25:34 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.2.4.ebuild,v 1.2 2012/03/15 15:00:27 tetromino Exp $
EAPI="4"
@@ -84,6 +84,9 @@ strip_builddir() {
}
src_prepare() {
+ # marshalers code was pre-generated with glib-2.31, upstream bug #671763
+ rm -v gdk/gdkmarshalers.c gtk/gtkmarshalers.c || die
+
# -O3 and company cause random crashes in applications. Bug #133469
replace-flags -O3 -O2
strip-flags