summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-0.7.2.ebuild7
-rw-r--r--dev-python/cffi/cffi-0.8.1.ebuild7
-rw-r--r--dev-python/cffi/cffi-0.8.ebuild7
4 files changed, 15 insertions, 13 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index 1b2fa276b81f..34b93f497c63 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.24 2014/03/16 16:30:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.25 2014/03/17 01:52:38 floppym Exp $
+
+ 17 Mar 2014; Mike Gilbert <floppym@gentoo.org> cffi-0.7.2.ebuild,
+ cffi-0.8.1.ebuild, cffi-0.8.ebuild:
+ We don't run test_zintegration, so don't need virtualenv. Thanks to Arfrever
+ for pointing this out.
16 Mar 2014; Mike Gilbert <floppym@gentoo.org> cffi-0.7.2.ebuild,
cffi-0.8.1.ebuild, cffi-0.8.ebuild:
diff --git a/dev-python/cffi/cffi-0.7.2.ebuild b/dev-python/cffi/cffi-0.7.2.ebuild
index 942d38bd1863..44d173e91503 100644
--- a/dev-python/cffi/cffi-0.7.2.ebuild
+++ b/dev-python/cffi/cffi-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.7.2.ebuild,v 1.7 2014/03/16 16:30:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.7.2.ebuild,v 1.8 2014/03/17 01:52:38 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
@@ -14,13 +14,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="doc test"
+IUSE="doc"
RDEPEND="virtual/libffi
dev-python/pycparser[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="$REDEPEND
- test? ( dev-python/virtualenv )"
+DEPEND="${RDEPEND}"
python_compile_all() {
use doc && emake -C doc html
diff --git a/dev-python/cffi/cffi-0.8.1.ebuild b/dev-python/cffi/cffi-0.8.1.ebuild
index df10133f8aa3..7a4ed461d645 100644
--- a/dev-python/cffi/cffi-0.8.1.ebuild
+++ b/dev-python/cffi/cffi-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.6 2014/03/16 16:30:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.7 2014/03/17 01:52:38 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
@@ -14,13 +14,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa x86 ~x86-fbsd"
-IUSE="doc test"
+IUSE="doc"
RDEPEND="virtual/libffi
dev-python/pycparser[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="$REDEPEND
- test? ( dev-python/virtualenv )"
+DEPEND="${RDEPEND}"
python_compile_all() {
use doc && emake -C doc html
diff --git a/dev-python/cffi/cffi-0.8.ebuild b/dev-python/cffi/cffi-0.8.ebuild
index ac8b2c2040ef..fc06049a2d32 100644
--- a/dev-python/cffi/cffi-0.8.ebuild
+++ b/dev-python/cffi/cffi-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.ebuild,v 1.4 2014/03/16 16:30:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.ebuild,v 1.5 2014/03/17 01:52:38 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
@@ -14,13 +14,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc test"
+IUSE="doc"
RDEPEND="virtual/libffi
dev-python/pycparser[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="$REDEPEND
- test? ( dev-python/virtualenv )"
+DEPEND="${RDEPEND}"
python_compile_all() {
use doc && emake -C doc html