summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog8
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild59
2 files changed, 59 insertions, 8 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index f788911c5ae6..fb4b6c0a3f7a 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/speech-dispatcher
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.70 2010/11/10 20:09:53 williamh Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.71 2011/03/06 00:36:23 arfrever Exp $
+
+ 06 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ speech-dispatcher-0.7.1-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #308263).
*speech-dispatcher-0.7.1-r1 (10 Nov 2010)
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild
index 307b5ef53f88..86a273625fd9 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild,v 1.1 2010/11/10 20:09:53 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r1.ebuild,v 1.2 2011/03/06 00:36:23 arfrever Exp $
EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit eutils
+inherit autotools python
DESCRIPTION="speech-dispatcher speech synthesis interface"
HOMEPAGE="http://www.freebsoft.org/speechd"
@@ -22,11 +25,24 @@ RDEPEND="dev-libs/dotconf
espeak? ( app-accessibility/espeak )
flite? ( app-accessibility/flite )
nas? ( media-libs/nas )
- pulseaudio? ( media-sound/pulseaudio )
- python? ( dev-lang/python )"
+ pulseaudio? ( media-sound/pulseaudio )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS += python/d" -i src/Makefile.am
+
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable python) \
@@ -40,17 +56,44 @@ src_configure() {
src_compile() {
emake all || die
+
+ if use python; then
+ python_copy_sources src/python
+
+ building() {
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir src/python building
+ fi
}
src_install() {
emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir src/python installation
+ fi
+
dodoc AUTHORS NEWS TODO
+ local f
for f in clibrary clibrary2 connection_recovery long_message run_test; do
rm "${D}"/usr/bin/${f}
done
}
pkg_postinst() {
+ use python && python_mod_optimize speechd speechd_config
+
+ local editconfig="n"
if ! use espeak; then
ewarn "You have disabled espeak, which is speech-dispatcher's"
ewarn "default speech synthesizer."
@@ -63,7 +106,7 @@ pkg_postinst() {
ewarn
editconfig="y"
fi
- if [ -n "$editconfig" ]; then
+ if [[ "${editconfig}" == "y" ]]; then
ewarn "You must edit ${EROOT}etc/speech-dispatcher/speechd.conf"
ewarn "and make sure the settings there match your system."
ewarn
@@ -74,3 +117,7 @@ pkg_postinst() {
elog "For festival support, you need to"
elog "install app-accessibility/festival-freebsoft-utils."
}
+
+pkg_postrm() {
+ use python && python_mod_cleanup speechd speechd_config
+}