summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/ee/ee-0.3.12-r1.ebuild18
-rw-r--r--media-gfx/eog/eog-0.6-r1.ebuild15
2 files changed, 15 insertions, 18 deletions
diff --git a/media-gfx/ee/ee-0.3.12-r1.ebuild b/media-gfx/ee/ee-0.3.12-r1.ebuild
index 7865941c3e7a..e2f9c2918fd5 100644
--- a/media-gfx/ee/ee-0.3.12-r1.ebuild
+++ b/media-gfx/ee/ee-0.3.12-r1.ebuild
@@ -1,27 +1,29 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/ee/ee-0.3.12-r1.ebuild,v 1.3 2001/10/06 23:13:13 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ee"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/"
DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1"
-src_compile() {
+
+src_compile() {
+
./configure --host=${CHOST} \
- --prefix=/usr
- assert
+ --prefix=/usr || die
emake || die
}
-src_install() {
+src_install() {
+
# .mo-files doesn't work with DESTDIR, *grr*
- make DESTDIR=${D} prefix=${D}/usr install || die
+ make DESTDIR=${D} \
+ prefix=${D}/usr \
+ install || die
dodoc AUTHORS COPYING ChangeLog NEWS README
}
diff --git a/media-gfx/eog/eog-0.6-r1.ebuild b/media-gfx/eog/eog-0.6-r1.ebuild
index 5e989d941a68..06a86a525417 100644
--- a/media-gfx/eog/eog-0.6-r1.ebuild
+++ b/media-gfx/eog/eog-0.6-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-0.6-r1.ebuild,v 1.3 2001/10/22 10:01:55 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Eye of GNOME"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/"${A}
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/gnome-office/eog.shtml"
RDEPEND="virtual/glibc
@@ -18,7 +16,9 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
>=dev-util/intltool-0.11"
+
src_compile() {
+
local myconf
if [ -z "`use nls`" ] ; then
@@ -28,12 +28,13 @@ src_compile() {
./configure --host=${CHOST} \
--prefix=/usr \
--sysconfdir=/etc \
- $myconf || die
+ ${myconf} || die
emake || die
}
src_install() {
+
make DESTDIR=${D} \
GCONG_CONFIG_SOURCE=xml=${D}/etc/gconf/gconf.xml.defaults \
install || die
@@ -42,9 +43,3 @@ src_install() {
TODO MAINTAINERS
}
-
-
-
-
-
-