summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmmsg/ChangeLog8
-rw-r--r--x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch43
-rw-r--r--x11-plugins/wmmsg/wmmsg-1.0.1.ebuild35
3 files changed, 85 insertions, 1 deletions
diff --git a/x11-plugins/wmmsg/ChangeLog b/x11-plugins/wmmsg/ChangeLog
index ef26be205307..49b010e35999 100644
--- a/x11-plugins/wmmsg/ChangeLog
+++ b/x11-plugins/wmmsg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmmsg
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsg/ChangeLog,v 1.12 2008/02/01 14:07:58 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsg/ChangeLog,v 1.13 2008/03/12 15:56:50 drac Exp $
+
+*wmmsg-1.0.1 (12 Mar 2008)
+
+ 12 Mar 2008; Samuli Suominen <drac@gentoo.org>
+ +files/wmmsg-1.0.1-use_gtk2.patch, +wmmsg-1.0.1.ebuild:
+ Version bump.
01 Feb 2008; Michele Noberasco <s4t4n@gentoo.org> wmmsg-1.0.ebuild:
Removed RDEPEND as it is equal to DEPEND.
diff --git a/x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch b/x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch
new file mode 100644
index 000000000000..eba1ae4fc1eb
--- /dev/null
+++ b/x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch
@@ -0,0 +1,43 @@
+diff -ur wmmsg-1.0.1.orig/configure.in wmmsg-1.0.1/configure.in
+--- wmmsg-1.0.1.orig/configure.in 2004-10-04 19:57:13.000000000 +0300
++++ wmmsg-1.0.1/configure.in 2008-03-12 17:45:29.000000000 +0200
+@@ -17,11 +17,6 @@
+ AM_MAINTAINER_MODE
+
+ # get options
+-AC_ARG_WITH(gtk,
+- [ --with-gtk=DIR use gtk in <DIR>],
+- [CFLAGS="$CFLAGS -I$withval/include"
+- LIBS="-L$withval/lib $LIBS"])
+-
+ AC_ARG_WITH(imlib2,
+ [ --with-imlib2=DIR use imlib2 in <DIR>],
+ [CFLAGS="$CFLAGS -I$withval/include"
+@@ -32,10 +27,9 @@
+ AC_CHECK_LIB([m], [sin])
+
+ # Check for glib/gtk stuff
+-AM_PATH_GLIB(1.2.2,,AC_MSG_ERROR([*** GLIB >= 1.2.2 not installed - please insta
+-ll first ***]))
+-AM_PATH_GTK(1.2.2,,AC_MSG_ERROR([*** GTK+ >= 1.2.2 not installed - please instal
+-l first ***]),gthread)
++PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0])
++AC_SUBST(GTK_CFLAGS)
++AC_SUBST(GTK_LIBS)
+
+ # check for Imlib2
+ AC_PATH_GENERIC(imlib2, 1.0.0, [
+diff -ur wmmsg-1.0.1.orig/Makefile.am wmmsg-1.0.1/Makefile.am
+--- wmmsg-1.0.1.orig/Makefile.am 2003-03-26 09:08:21.000000000 +0200
++++ wmmsg-1.0.1/Makefile.am 2008-03-12 17:42:48.000000000 +0200
+@@ -3,8 +3,8 @@
+ bin_PROGRAMS = wmmsg wmmsg_notify
+ wmmsg_SOURCES = src/wmmsg/wmconfig.c src/wmmsg/wmmsg.c src/wmmsg/getopt.c src/wmgeneral/wmgeneral.c src/wmgeneral/misc.c src/wmgeneral/list.c
+ wmmsg_notify_SOURCES = src/wmmsg/wmmsg_notify.c src/wmmsg/getopt.c
+-INCLUDES = -I/usr/X11R6/include -I$(prefix)/include -I$(includedir) -I. `glib-config --cflags` `gtk-config --cflags` `imlib2-config --cflags`
+-AM_LDFLAGS = -lX11 -lXext -lXpm -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib `glib-config --libs` `gtk-config --libs` `imlib2-config --libs`
++INCLUDES = -I$(prefix)/include -I$(includedir) -I. `pkg-config --cflags gtk+-2.0` `imlib2-config --cflags`
++AM_LDFLAGS = -lX11 -lXext -lXpm -L/usr/lib -L/usr/local/lib `pkg-config --libs gtk+-2.0` `imlib2-config --libs`
+
+ man1_MANS = man/wmmsg.1 man/wmmsg_notify.1
+ man_MANS =
diff --git a/x11-plugins/wmmsg/wmmsg-1.0.1.ebuild b/x11-plugins/wmmsg/wmmsg-1.0.1.ebuild
new file mode 100644
index 000000000000..997bbd7048b1
--- /dev/null
+++ b/x11-plugins/wmmsg/wmmsg-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsg/wmmsg-1.0.1.ebuild,v 1.1 2008/03/12 15:56:50 drac Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="a dockapp that informs of new events, such as incoming chat messages, by displaying related icons and arrival times"
+HOMEPAGE="http://swapspace.net/~matt/wmmsg"
+SRC_URI="http://swapspace.net/~matt/wmmsg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ media-libs/imlib2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-use_gtk2.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README wmmsgrc
+}