summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/ppl/ChangeLog7
-rw-r--r--dev-libs/ppl/ppl-0.11.1.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-libs/ppl/ChangeLog b/dev-libs/ppl/ChangeLog
index ded2fc77a7d5..b36290130880 100644
--- a/dev-libs/ppl/ChangeLog
+++ b/dev-libs/ppl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ppl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.32 2011/01/23 20:03:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.33 2011/02/21 02:38:15 dirtyepic Exp $
+
+*ppl-0.11.1 (21 Feb 2011)
+
+ 21 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> +ppl-0.11.1.ebuild:
+ Version bump.
23 Jan 2011; Mike Frysinger <vapier@gentoo.org> ppl-0.11.ebuild:
Inherit eutils for epause #352519 by Diego Elio Pettenò.
diff --git a/dev-libs/ppl/ppl-0.11.1.ebuild b/dev-libs/ppl/ppl-0.11.1.ebuild
new file mode 100644
index 000000000000..926d2a312b65
--- /dev/null
+++ b/dev-libs/ppl/ppl-0.11.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.11.1.ebuild,v 1.1 2011/02/21 02:38:15 dirtyepic Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
+HOMEPAGE="http://www.cs.unipr.it/ppl/"
+SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="doc lpsol pch test watchdog"
+
+RDEPEND=">=dev-libs/gmp-4.1.3[-nocxx]
+ lpsol? ( sci-mathematics/glpk )
+ !<dev-libs/cloog-ppl-0.15.10"
+DEPEND="${RDEPEND}
+ sys-devel/m4"
+
+pkg_setup() {
+ if use test; then
+ ewarn "The PPL testsuite will be run."
+ ewarn "Note that this can take several hours to complete on a fast machine."
+ epause 3
+ fi
+}
+
+src_configure() {
+ # --disable-check doesn't work
+ use test && want_check="--enable-check=quick"
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-debugging \
+ --disable-optimization \
+ $(use_enable lpsol ppl_lpsol) \
+ $(use_enable pch) \
+ $(use_enable watchdog) \
+ --enable-interfaces="c cxx" \
+ ${want_check} \
+ || die "configure failed"
+}
+
+src_test() {
+ # default src_test runs with -j1, overriding it here saves about
+ # 30 minutes and is recommended by upstream
+ if emake -j1 check -n &> /dev/null; then
+ emake check || die "tests failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed install"
+
+ local docsdir="${ED}/usr/share/doc/${PF}"
+ rm "${docsdir}"/gpl* "${docsdir}"/fdl* || die "Failed removing licenses"
+
+ if ! use doc; then
+ rm -r "${docsdir}"/*-html/ || die "Failed removing docs"
+ fi
+
+ dodoc NEWS README* STANDARDS TODO
+}
+
+pkg_postinst() {
+ echo
+ ewarn "After an upgrade of PPL it is important that you rebuild"
+ ewarn "dev-libs/cloog-ppl."
+ ewarn
+ ewarn "If you use gcc-config to switch to an older compiler version than"
+ ewarn "the one PPL was built with, PPL must be rebuilt with that version."
+ ewarn
+ ewarn "In both cases failure to do this will get you this error when"
+ ewarn "graphite flags are used:"
+ ewarn
+ ewarn " sorry, unimplemented: Graphite loop optimizations cannot be used"
+ ewarn
+ echo
+}