summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/xml-security-c/ChangeLog7
-rw-r--r--dev-libs/xml-security-c/files/1.5.1-parallel_build.patch21
-rw-r--r--dev-libs/xml-security-c/files/1.5.1-xalan-c-1.11-compat.patch122
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.5.1.ebuild48
4 files changed, 6 insertions, 192 deletions
diff --git a/dev-libs/xml-security-c/ChangeLog b/dev-libs/xml-security-c/ChangeLog
index f1ab44448584..4f09f3c37da2 100644
--- a/dev-libs/xml-security-c/ChangeLog
+++ b/dev-libs/xml-security-c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xml-security-c
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xml-security-c/ChangeLog,v 1.3 2011/08/04 13:53:11 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xml-security-c/ChangeLog,v 1.4 2011/10/09 07:21:16 dev-zero Exp $
+
+ 09 Oct 2011; Tiziano Müller <dev-zero@gentoo.org>
+ -files/1.5.1-parallel_build.patch, -xml-security-c-1.5.1.ebuild,
+ -files/1.5.1-xalan-c-1.11-compat.patch:
+ Dropped vulnerable versions (bug #386359).
*xml-security-c-1.6.1 (04 Aug 2011)
diff --git a/dev-libs/xml-security-c/files/1.5.1-parallel_build.patch b/dev-libs/xml-security-c/files/1.5.1-parallel_build.patch
deleted file mode 100644
index 57109f978613..000000000000
--- a/dev-libs/xml-security-c/files/1.5.1-parallel_build.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur xml-security-c-1.5.0_pre20090310.orig/include/Makefile.am xml-security-c-1.5.0_pre20090310/include/Makefile.am
---- xml-security-c-1.5.0_pre20090310.orig/include/Makefile.am 2009-03-10 08:23:06.552988680 +0100
-+++ xml-security-c-1.5.0_pre20090310/include/Makefile.am 2009-03-10 08:24:06.360010865 +0100
-@@ -14,7 +14,7 @@
- # limitations under the License.
- #
-
--BUILT_SOURCES = xsec ${lib_includes}
-+BUILT_SOURCES = ${lib_includes}
- nobase_include_HEADERS = ${lib_includes}
-
- lib_includes =
-@@ -213,7 +213,7 @@
-
- SUFFIXES = .hpp
-
--xsec/%.hpp: ../src/%.hpp
-+xsec/%.hpp: xsec ../src/%.hpp
- cp ../src/$*.hpp $@
-
- xsec:
diff --git a/dev-libs/xml-security-c/files/1.5.1-xalan-c-1.11-compat.patch b/dev-libs/xml-security-c/files/1.5.1-xalan-c-1.11-compat.patch
deleted file mode 100644
index b5d142415845..000000000000
--- a/dev-libs/xml-security-c/files/1.5.1-xalan-c-1.11-compat.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-diff -Naur xml-security-c-1.5.1.orig/src/canon/XSECC14n20010315.cpp xml-security-c-1.5.1/src/canon/XSECC14n20010315.cpp
---- xml-security-c-1.5.1.orig/src/canon/XSECC14n20010315.cpp 2009-07-27 09:23:51.228693118 +0200
-+++ xml-security-c-1.5.1/src/canon/XSECC14n20010315.cpp 2009-07-27 11:37:12.697101082 +0200
-@@ -36,6 +36,7 @@
- // Xerces includes
- #include <xercesc/dom/DOMNamedNodeMap.hpp>
- #include <xercesc/util/XMLUniDefs.hpp>
-+#include <xercesc/dom/DOMElement.hpp>
-
- XERCES_CPP_NAMESPACE_USE
-
-@@ -61,7 +62,7 @@
- XALAN_USING_XALAN(NodeRefList)
- XALAN_USING_XALAN(XercesDocumentWrapper)
- XALAN_USING_XALAN(XercesWrapperNavigator)
--
-+XALAN_USING_XALAN(c_wstr)
-
- #endif
-
-@@ -450,21 +451,27 @@
-
- // We use Xalan to process the Xerces DOM tree and get the XPath nodes
-
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+ XercesParserLiaison theParserLiaison;
-+ XercesDOMSupport theDOMSupport(theParserLiaison);
-+#else
- XercesDOMSupport theDOMSupport;
- #if defined XSEC_XERCESPARSERLIAISON_REQS_DOMSUPPORT
- XercesParserLiaison theParserLiaison(theDOMSupport);
- #else
- XercesParserLiaison theParserLiaison;
- #endif
-+#endif // XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-
- if (mp_doc == 0) {
- throw XSECException(XSECException::UnsupportedFunction,
- "XPath selection only supported in C14n for full documents");
- }
-- XalanDocument* theDoc = theParserLiaison.createDocument(mp_doc);
-
-- XalanElement * xe = theDoc->createElement(XalanDOMString("ns"));
-- xe->setAttribute(/*XalanDOMString(""), */XalanDOMString("xmlns:ietf"), XalanDOMString("http://www.ietf.org"));
-+ DOMElement* theXercesNode = mp_doc->createElement(c_wstr(XalanDOMString("ns")));
-+ theXercesNode->setAttribute(c_wstr(XalanDOMString("xmlns:ietf")), c_wstr(XalanDOMString("http://www.ietf.org")));
-+
-+ XalanDocument* theDoc = theParserLiaison.createDocument(mp_doc);
-
- // Set up the XPath evaluator
-
-@@ -505,7 +512,7 @@
- theDOMSupport,
- theContextNode,
- expr,
-- xe));
-+ theDoc->getElementById(XalanDOMString("ns"))));
-
- #else
-
-@@ -514,7 +521,7 @@
- theDOMSupport,
- theContextNode,
- expr,
-- xe));
-+ theDoc->getElementById(XalanDOMString("ns"))));
- //theDoc->getDocumentElement()));
- #endif
-
-diff -Naur xml-security-c-1.5.1.orig/src/transformers/TXFMXPath.cpp xml-security-c-1.5.1/src/transformers/TXFMXPath.cpp
---- xml-security-c-1.5.1.orig/src/transformers/TXFMXPath.cpp 2009-07-27 09:23:51.254551633 +0200
-+++ xml-security-c-1.5.1/src/transformers/TXFMXPath.cpp 2009-07-27 11:40:30.923733630 +0200
-@@ -283,8 +283,12 @@
- setXPathNS(document, XPathAtts, addedNodes, formatter, mp_nse);
-
- XPathProcessorImpl xppi; // The processor
-- XercesDOMSupport xds;
- XercesParserLiaison xpl;
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+ XercesDOMSupport xds(xpl);
-+#else
-+ XercesDOMSupport xds;
-+#endif
- XPathEvaluator xpe;
- XPathFactoryDefault xpf;
- XPathConstructionContextDefault xpcc;
-diff -Naur xml-security-c-1.5.1.orig/src/transformers/TXFMXPathFilter.cpp xml-security-c-1.5.1/src/transformers/TXFMXPathFilter.cpp
---- xml-security-c-1.5.1.orig/src/transformers/TXFMXPathFilter.cpp 2009-07-27 09:23:51.254551633 +0200
-+++ xml-security-c-1.5.1/src/transformers/TXFMXPathFilter.cpp 2009-07-27 11:39:11.073713584 +0200
-@@ -183,8 +183,12 @@
- setXPathNS(document, expr->mp_NSMap, addedNodes, mp_formatter, mp_nse);
-
- XPathProcessorImpl xppi; // The processor
-- XercesDOMSupport xds;
- XercesParserLiaison xpl;
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+ XercesDOMSupport xds(xpl);
-+#else
-+ XercesDOMSupport xds;
-+#endif
- XPathEvaluator xpe;
- XPathFactoryDefault xpf;
- XPathConstructionContextDefault xpcc;
-diff -Naur xml-security-c-1.5.1.orig/src/transformers/TXFMXSL.cpp xml-security-c-1.5.1/src/transformers/TXFMXSL.cpp
---- xml-security-c-1.5.1.orig/src/transformers/TXFMXSL.cpp 2009-07-27 09:23:51.257885228 +0200
-+++ xml-security-c-1.5.1/src/transformers/TXFMXSL.cpp 2009-07-27 11:42:31.867031516 +0200
-@@ -102,11 +102,15 @@
-
- TXFMXSL::TXFMXSL(DOMDocument *doc) :
- TXFMBase(doc),
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+xds(xpl)
-+#else
- #if defined XSEC_XERCESPARSERLIAISON_REQS_DOMSUPPORT
- xpl(xds)
- #else
- xpl()
- #endif
-+#endif
- {
-
- // Zeroise all the pointers
diff --git a/dev-libs/xml-security-c/xml-security-c-1.5.1.ebuild b/dev-libs/xml-security-c/xml-security-c-1.5.1.ebuild
deleted file mode 100644
index 1eacba471651..000000000000
--- a/dev-libs/xml-security-c/xml-security-c-1.5.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xml-security-c/xml-security-c-1.5.1.ebuild,v 1.2 2009/07/27 09:54:18 dev-zero Exp $
-
-EAPI="2"
-
-inherit autotools eutils
-
-DESCRIPTION="Apache C++ XML security libraries."
-HOMEPAGE="http://santuario.apache.org/"
-SRC_URI="http://santuario.apache.org/dist/c-library/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug examples xalan"
-
-RDEPEND="dev-libs/xerces-c
- xalan? ( dev-libs/xalan-c )
- dev-libs/openssl"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${PV}-parallel_build.patch" \
- "${FILESDIR}/${PV}-xalan-c-1.11-compat.patch"
-
- # script checks for autoconf for no reason
- sed -i \
- -e '/AUTOCONF/d' configure.ac || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_with xalan)
-}
-
-src_install(){
- emake DESTDIR="${D}" install || die "emake failed"
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins src/samples/*.cpp
- fi
-}