summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/euler/ChangeLog8
-rw-r--r--sci-mathematics/euler/euler-1.61.0.ebuild5
-rw-r--r--sci-mathematics/euler/files/euler-fortify.patch36
3 files changed, 45 insertions, 4 deletions
diff --git a/sci-mathematics/euler/ChangeLog b/sci-mathematics/euler/ChangeLog
index 25783f513f70..b5f7e543586e 100644
--- a/sci-mathematics/euler/ChangeLog
+++ b/sci-mathematics/euler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/euler
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/ChangeLog,v 1.16 2008/01/07 23:44:34 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/ChangeLog,v 1.17 2010/11/19 18:33:25 bicatali Exp $
+
+ 19 Nov 2010; Sébastien Fabbro <bicatali@gentoo.org> euler-1.61.0.ebuild,
+ +files/euler-fortify.patch:
+ Added a patch to help on x86_64 pointers, closing bug #343587
07 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+files/euler-xdg.patch, euler-1.61.0.ebuild:
diff --git a/sci-mathematics/euler/euler-1.61.0.ebuild b/sci-mathematics/euler/euler-1.61.0.ebuild
index 047c2c8ac02b..129841be726a 100644
--- a/sci-mathematics/euler/euler-1.61.0.ebuild
+++ b/sci-mathematics/euler/euler-1.61.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/euler-1.61.0.ebuild,v 1.7 2008/01/07 23:44:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/euler-1.61.0.ebuild,v 1.8 2010/11/19 18:33:25 bicatali Exp $
inherit autotools eutils
@@ -26,6 +26,7 @@ src_unpack() {
epatch "${FILESDIR}"/command-gcc4-gentoo.patch
epatch "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
epatch "${FILESDIR}"/${PN}-xdg.patch
+ epatch "${FILESDIR}"/${PN}-fortify.patch
# gentoo specific stuff
sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am
sed -i \
diff --git a/sci-mathematics/euler/files/euler-fortify.patch b/sci-mathematics/euler/files/euler-fortify.patch
new file mode 100644
index 000000000000..efb366e2cc04
--- /dev/null
+++ b/sci-mathematics/euler/files/euler-fortify.patch
@@ -0,0 +1,36 @@
+diff -Nur euler-1.61.0.orig/src/command.c euler-1.61.0/src/command.c
+--- euler-1.61.0.orig/src/command.c 2010-11-19 17:50:54.000000000 +0000
++++ euler-1.61.0/src/command.c 2010-11-19 18:23:11.000000000 +0000
+@@ -606,7 +606,7 @@
+ void do_help (void)
+ { char name[256];
+ header *hd;
+- int count,i,defaults;
++ size_t count,i,defaults;
+ char *p,*end,*pnote;
+ builtintyp *b;
+ scan_space();
+diff -Nur euler-1.61.0.orig/src/stack.h euler-1.61.0/src/stack.h
+--- euler-1.61.0.orig/src/stack.h 2010-11-19 17:50:54.000000000 +0000
++++ euler-1.61.0/src/stack.h 2010-11-19 18:19:23.000000000 +0000
+@@ -63,7 +63,7 @@
+ #endif
+ } dims;
+
+-typedef struct { unsigned long s; } inttyp;
++typedef struct { size_t s; } inttyp;
+
+ typedef struct { header hd; double val; } realtyp;
+
+diff -Nur euler-1.61.0.orig/src/udf.c euler-1.61.0/src/udf.c
+--- euler-1.61.0.orig/src/udf.c 2010-11-19 17:50:54.000000000 +0000
++++ euler-1.61.0/src/udf.c 2010-11-19 18:21:20.000000000 +0000
+@@ -334,7 +334,7 @@
+ { char name[16];
+ header *hd;
+ char *p,*pnote;
+- int i,count,defaults;
++ size_t i,count,defaults;
+ builtintyp *b;
+ scan_space();
+ scan_name(name); hd=searchudf(name);