summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/netcat6/ChangeLog8
-rw-r--r--net-analyzer/netcat6/files/netcat6-1.0-automake-1.14.patch4
-rw-r--r--net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch42
-rw-r--r--net-analyzer/netcat6/netcat6-1.0-r2.ebuild19
4 files changed, 37 insertions, 36 deletions
diff --git a/net-analyzer/netcat6/ChangeLog b/net-analyzer/netcat6/ChangeLog
index ed8adee9fd7a..bdca2cad22f4 100644
--- a/net-analyzer/netcat6/ChangeLog
+++ b/net-analyzer/netcat6/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/netcat6
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/ChangeLog,v 1.33 2013/12/04 03:21:59 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/ChangeLog,v 1.34 2014/07/14 21:39:15 jer Exp $
+
+ 14 Jul 2014; Jeroen Roovers <jer@gentoo.org> netcat6-1.0-r2.ebuild,
+ files/netcat6-1.0-automake-1.14.patch, files/netcat6-1.0-unix-sockets.patch:
+ Set RDEPEND (not DEPEND) blocker. Clean up patches.
04 Dec 2013; Tim Harder <radhermit@gentoo.org> netcat6-1.0-r2.ebuild,
+files/netcat6-1.0-automake-1.14.patch:
diff --git a/net-analyzer/netcat6/files/netcat6-1.0-automake-1.14.patch b/net-analyzer/netcat6/files/netcat6-1.0-automake-1.14.patch
index 2e7dcb6b0849..f7c128590be8 100644
--- a/net-analyzer/netcat6/files/netcat6-1.0-automake-1.14.patch
+++ b/net-analyzer/netcat6/files/netcat6-1.0-automake-1.14.patch
@@ -1,5 +1,5 @@
---- nc6-1.0/configure.ac
-+++ nc6-1.0/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -2,9 +2,9 @@
AC_INIT(nc6, 1.0, [ds6-devel@deepspace6.net])
AC_CONFIG_AUX_DIR(config)
diff --git a/net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch b/net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch
index d5cb90bd1ec9..8eae2c6e0af8 100644
--- a/net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch
+++ b/net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch
@@ -1,6 +1,5 @@
-=== modified file 'docs/nc6.1.in'
---- docs/nc6.1.in 2008-10-25 14:16:55 +0000
-+++ docs/nc6.1.in 2008-10-25 14:17:11 +0000
+--- a/docs/nc6.1.in
++++ b/docs/nc6.1.in
@@ -160,6 +160,10 @@
With this option set, netcat6 will use UDP as the transport protocol (TCP is
the default).
@@ -13,9 +12,8 @@
Enable verbose mode. This gives some basic information about what netcat6
is doing. Use it twice for extra verbosity.
-=== modified file 'src/Makefile.am'
---- src/Makefile.am 2008-10-25 14:16:55 +0000
-+++ src/Makefile.am 2008-10-25 14:17:09 +0000
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -6,6 +6,7 @@
network.h \
afindep.h \
@@ -33,9 +31,8 @@
io_stream.c \
connection.c
-=== modified file 'src/connection.c'
---- src/connection.c 2008-10-25 14:16:55 +0000
-+++ src/connection.c 2008-10-25 14:17:09 +0000
+--- a/src/connection.c
++++ b/src/connection.c
@@ -109,6 +109,9 @@
fatal_internal("unavailable bluez support required");
#endif
@@ -58,9 +55,8 @@
fatal_internal("unknown socket type");
}
-=== modified file 'src/connection.h'
---- src/connection.h 2008-10-25 14:16:55 +0000
-+++ src/connection.h 2008-10-25 14:17:09 +0000
+--- a/src/connection.h
++++ b/src/connection.h 2008-10-25 14:17:09 +0000
@@ -31,12 +31,14 @@
PROTO_UNSPECIFIED,
PROTO_IPv6,
@@ -77,9 +73,8 @@
L2CAP_PROTOCOL
} sock_protocol_t;
-=== modified file 'src/network.c'
---- src/network.c 2008-10-25 14:16:55 +0000
-+++ src/network.c 2008-10-25 14:17:09 +0000
+--- a/src/network.c
++++ b/src/network.c
@@ -23,6 +23,7 @@
#include "network.h"
#include "connection.h"
@@ -101,9 +96,8 @@
case PROTO_BLUEZ:
fd = bluez_connect(&hints,
-=== modified file 'src/parser.c'
---- src/parser.c 2008-10-25 14:16:55 +0000
-+++ src/parser.c 2008-10-25 14:17:09 +0000
+--- a/src/parser.c
++++ b/src/parser.c
@@ -109,7 +109,9 @@
{"bluetooth", no_argument, NULL, 'b'},
#define OPT_SCO 24
@@ -209,9 +203,8 @@
fprintf(fp, " --continuous %s\n",
_("Continuously accept connections\n"
-=== added file 'src/unixsocket.c'
---- src/unixsocket.c 1970-01-01 00:00:00 +0000
-+++ src/unixsocket.c 2008-10-25 14:17:09 +0000
+--- a/src/unixsocket.c
++++ b/src/unixsocket.c
@@ -0,0 +1,78 @@
+/*
+ * unixsocket.c - address family independant networking functions
@@ -232,7 +225,7 @@
+#include <unistd.h>
+#include <limits.h>
+
-+RCSID("@(#) $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch,v 1.1 2008/10/25 15:33:22 pva Exp $");
++RCSID("@(#) $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/files/netcat6-1.0-unix-sockets.patch,v 1.2 2014/07/14 21:39:15 jer Exp $");
+
+
+int unixsocket_connect(const struct addrinfo *hints,
@@ -292,9 +285,8 @@
+}
+
-=== added file 'src/unixsocket.h'
---- src/unixsocket.h 1970-01-01 00:00:00 +0000
-+++ src/unixsocket.h 2008-10-25 14:17:09 +0000
+--- a/src/unixsocket.h
++++ b/src/unixsocket.h
@@ -0,0 +1,12 @@
+#ifndef UNIXSOCKET_H
+#define UNIXSOCKET_H
diff --git a/net-analyzer/netcat6/netcat6-1.0-r2.ebuild b/net-analyzer/netcat6/netcat6-1.0-r2.ebuild
index 99725a2ba968..99956a5fc1f6 100644
--- a/net-analyzer/netcat6/netcat6-1.0-r2.ebuild
+++ b/net-analyzer/netcat6/netcat6-1.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/netcat6-1.0-r2.ebuild,v 1.13 2013/12/04 03:21:59 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/netcat6-1.0-r2.ebuild,v 1.14 2014/07/14 21:39:15 jer Exp $
EAPI=5
inherit eutils autotools toolchain-funcs
@@ -15,17 +15,22 @@ KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ~ppc64 s390 sh sparc x86 ~amd
IUSE="ipv6 nls bluetooth"
# need to block netcat as we provide the "nc" file now too
-DEPEND="bluetooth? ( net-wireless/bluez )
- !net-analyzer/netcat"
-RDEPEND="${DEPEND}"
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+"
+RDEPEND="
+ ${DEPEND}
+ !net-analyzer/netcat
+"
S=${WORKDIR}/nc6-${PV}
DOCS=( AUTHORS BUGS README NEWS TODO CREDITS ChangeLog )
src_prepare() {
- epatch "${FILESDIR}"/netcat6-1.0-unix-sockets.patch
- epatch "${FILESDIR}"/${P}-automake-1.14.patch
+ epatch \
+ "${FILESDIR}"/${P}-unix-sockets.patch \
+ "${FILESDIR}"/${P}-automake-1.14.patch
AM_OPTS="--force-missing" eautoreconf
}