summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-tv/ivtv/ChangeLog5
-rw-r--r--media-tv/ivtv/ivtv-0.4.2.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index e153b079fc49..2cdf1c36249e 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.44 2006/06/11 15:41:08 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.45 2006/06/13 07:07:27 cardoe Exp $
+
+ 13 Jun 2006; Doug Goldstein <cardoe@gentoo.org> ivtv-0.4.2.ebuild:
+ Added message about kernel versions in 0.4.2 and marked stable on ppc.
11 Jun 2006; Doug Goldstein <cardoe@gentoo.org> ivtv-0.4.5.ebuild,
ivtv-0.6.2.ebuild:
diff --git a/media-tv/ivtv/ivtv-0.4.2.ebuild b/media-tv/ivtv/ivtv-0.4.2.ebuild
index 39840503ea44..6535583720ad 100644
--- a/media-tv/ivtv/ivtv-0.4.2.ebuild
+++ b/media-tv/ivtv/ivtv-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.2.ebuild,v 1.2 2006/02/14 04:36:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.2.ebuild,v 1.3 2006/06/13 07:07:27 cardoe Exp $
inherit eutils linux-mod
@@ -18,7 +18,7 @@ SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/0.4.x/${P}.tar.gz
RESTRICT="nomirror"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~ppc"
+KEYWORDS="~amd64 ~x86 ppc"
IUSE=""
@@ -30,10 +30,16 @@ RDEPEND="sys-apps/hotplug"
DEPEND="app-arch/unzip"
pkg_setup() {
- linux-mod_pkg_setup
MODULE_NAMES="ivtv(extra:${S}/driver)"
- if [ ${KV_PATCH} -le 14 ]; then
+ if kernel_is gt 2 6 15; then
+ ewarn "You must use 0.6.x with a 2.6.16 kernel. However the kernel is broken"
+ ewarn "with IVTV for a great number of people. Including the maintainer of"
+ ewarn "IVTV in Gentoo. Your best bet is to use a 2.6.15 kernel"
+ die "This does not work with kernel versions higher then 2.6.15"
+ fi
+
+ if kernel_is le 2 6 14; then
MODULE_NAMES="${MODULE_NAMES}
msp3400(extra:${S}/driver)
saa7115(extra:${S}/driver)