summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gvfs/ChangeLog8
-rw-r--r--gnome-base/gvfs/files/gvfs-1.0.3-posixtest.patch85
-rw-r--r--gnome-base/gvfs/gvfs-0.2.5-r1.ebuild63
-rw-r--r--gnome-base/gvfs/gvfs-0.2.5.ebuild58
-rw-r--r--gnome-base/gvfs/gvfs-1.0.1.ebuild76
-rw-r--r--gnome-base/gvfs/gvfs-1.0.2.ebuild76
-rw-r--r--gnome-base/gvfs/gvfs-1.0.3-r10.ebuild12
-rw-r--r--gnome-base/gvfs/gvfs-1.0.3.ebuild16
8 files changed, 114 insertions, 280 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index 86b6a84da293..ef9cc8bed738 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.44 2009/01/27 10:30:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.45 2009/01/29 22:07:22 eva Exp $
+
+ 29 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gvfs-1.0.3-posixtest.patch, -gvfs-0.2.5.ebuild,
+ -gvfs-0.2.5-r1.ebuild, -gvfs-1.0.1.ebuild, -gvfs-1.0.2.ebuild,
+ gvfs-1.0.3.ebuild, gvfs-1.0.3-r10.ebuild:
+ Use posix tests in configure.ac, bug #256305. Clean up old revisions.
27 Jan 2009; Raúl Porcel <armin76@gentoo.org> gvfs-1.0.3-r10.ebuild:
Re-add ~arm/~sh
diff --git a/gnome-base/gvfs/files/gvfs-1.0.3-posixtest.patch b/gnome-base/gvfs/files/gvfs-1.0.3-posixtest.patch
new file mode 100644
index 000000000000..8504b53f4a84
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.0.3-posixtest.patch
@@ -0,0 +1,85 @@
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -127,7 +127,7 @@ HTTP_LIBS=
+ if test "x$enable_http" != "xno"; then
+ PKG_CHECK_EXISTS(libsoup-2.4 >= 2.23.91, msg_http=yes)
+
+- if test "x$msg_http" == "xyes"; then
++ if test "x$msg_http" = "xyes"; then
+ PKG_CHECK_MODULES(HTTP, libsoup-2.4 libxml-2.0)
+ AC_DEFINE(HAVE_HTTP, 1, [Define to 1 if http/dav is going to be built])
+ fi
+@@ -165,7 +165,7 @@ FUSE_CFLAGS=
+ if test "x$enable_fuse" != "xno"; then
+ PKG_CHECK_EXISTS(fuse, msg_fuse=yes)
+
+- if test "x$msg_fuse" == "xyes"; then
++ if test "x$msg_fuse" = "xyes"; then
+ PKG_CHECK_MODULES(FUSE, fuse)
+ AC_DEFINE(HAVE_FUSE, 1, [Define to 1 if FUSE is available])
+ fi
+@@ -187,7 +187,7 @@ GCONF_CFLAGS=
+ if test "x$enable_gconf" != "xno"; then
+ PKG_CHECK_EXISTS(gconf-2.0, msg_gconf=yes)
+
+- if test "x$msg_gconf" == "xyes"; then
++ if test "x$msg_gconf" = "xyes"; then
+ PKG_CHECK_MODULES(GCONF, gconf-2.0)
+ AC_DEFINE(HAVE_GCONF, 1, [Define to 1 if GConf is available])
+ fi
+@@ -211,13 +211,13 @@ HAL_REQUIRED=0.5.10
+ if test "x$enable_hal" != "xno"; then
+ PKG_CHECK_EXISTS([hal >= $HAL_REQUIRED], msg_hal=yes)
+
+- if test "x$msg_hal" == "xyes"; then
++ if test "x$msg_hal" = "xyes"; then
+ PKG_CHECK_MODULES([HAL],[hal >= $HAL_REQUIRED])
+ AC_DEFINE(HAVE_HAL, 1, [Define to 1 if HAL is available])
+ save_libs="$LIBS"
+ LIBS="$HAL_LIBS"
+ AC_CHECK_LIB(hal, libhal_get_all_devices_with_properties, have_hal_fast_init=yes)
+- if test "x$have_hal_fast_init" == "xyes"; then
++ if test "x$have_hal_fast_init" = "xyes"; then
+ AC_DEFINE(HAVE_HAL_FAST_INIT, 1, [Define to 1 if libhal_get_all_devices_with_properties is available])
+ fi
+ LIBS="$save_libs"
+@@ -240,7 +240,7 @@ CDDA_CFLAGS=
+ if test "x$enable_cdda" != "xno"; then
+ PKG_CHECK_EXISTS(libcdio_paranoia >= 0.78.2 hal >= $HAL_REQUIRED, msg_cdda=yes)
+
+- if test "x$msg_cdda" == "xyes"; then
++ if test "x$msg_cdda" = "xyes"; then
+ PKG_CHECK_MODULES(CDDA, libcdio_paranoia hal >= $HAL_REQUIRED)
+ AC_DEFINE(HAVE_CDDA, 1, [Define to 1 if CDDA is going to be built])
+ fi
+@@ -267,7 +267,7 @@ if test "x$enable_obexftp" != "xno"; the
+ [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
+ have_expat=false)
+
+- if test "x$msg_obexftp" == "xyes" -a "x$have_expat" == "xtrue"; then
++ if test "x$msg_obexftp" = "xyes" -a "x$have_expat" = "xtrue"; then
+ PKG_CHECK_MODULES(OBEXFTP, dbus-glib-1 bluez >= 3.12)
+ AC_SUBST(OBEXFTP_LIBS)
+ AC_SUBST(OBEXFTP_CFLAGS)
+@@ -307,8 +307,8 @@ if test "x$enable_gphoto2" != "xno" -a "
+ ;;
+ esac
+
+- if test "x$msg_gphoto2" == "xyes"; then
+- if test "x$use_gphoto2" == "xyes"; then
++ if test "x$msg_gphoto2" = "xyes"; then
++ if test "x$use_gphoto2" = "xyes"; then
+ PKG_CHECK_MODULES(GPHOTO2, libgphoto2 >= 2.4.0)
+ AC_DEFINE(HAVE_GPHOTO2, 1, [Define to 1 if gphoto2 is available])
+ else
+@@ -334,7 +334,7 @@ KEYRING_CFLAGS=
+ if test "x$enable_keyring" != "xno"; then
+ PKG_CHECK_EXISTS(gnome-keyring-1, msg_keyring=yes)
+
+- if test "x$msg_keyring" == "xyes"; then
++ if test "x$msg_keyring" = "xyes"; then
+ PKG_CHECK_MODULES(KEYRING, gnome-keyring-1)
+ AC_DEFINE(HAVE_KEYRING, 1, [Define to 1 if GNOME Keyring is available])
+ fi
diff --git a/gnome-base/gvfs/gvfs-0.2.5-r1.ebuild b/gnome-base/gvfs/gvfs-0.2.5-r1.ebuild
deleted file mode 100644
index 53cbb9bc0c19..000000000000
--- a/gnome-base/gvfs/gvfs-0.2.5-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-0.2.5-r1.ebuild,v 1.4 2008/09/07 22:46:33 eva Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="GNOME Virtual Filesystem Layer"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ppc ~ppc64 ~sparc ~x86"
-IUSE="avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
-
-RDEPEND=">=dev-libs/glib-2.16
- >=sys-apps/dbus-1.0
- >=net-libs/libsoup-2.4
- dev-libs/libxml2
- net-misc/openssh
- avahi? ( >=net-dns/avahi-0.6 )
- cdda? (
- >=sys-apps/hal-0.5.10
- >=dev-libs/libcdio-0.78.2
- )
- fuse? ( sys-fs/fuse )
- gnome? ( >=gnome-base/gconf-2.0 )
- hal? ( >=sys-apps/hal-0.5.10 )
- bluetooth? (
- dev-libs/dbus-glib
- >=net-wireless/bluez-libs-3.12
- dev-libs/expat
- )
- gphoto2? ( >=media-libs/libgphoto2-2.4 )
- gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
- samba? ( >=net-fs/samba-3 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --enable-http
- --disable-archive
- $(use_enable avahi)
- $(use_enable bluetooth obexftp)
- $(use_enable cdda)
- $(use_enable fuse)
- $(use_enable gnome gconf)
- $(use_enable gphoto2)
- $(use_enable hal)
- $(use_enable gnome-keyring keyring)
- $(use_enable samba)"
-
- if use cdda && built_with_use dev-libs/libcdio minimal; then
- ewarn
- ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
- ewarn "without the minimal USE flag."
- die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
- fi
-}
diff --git a/gnome-base/gvfs/gvfs-0.2.5.ebuild b/gnome-base/gvfs/gvfs-0.2.5.ebuild
deleted file mode 100644
index e45864ab7973..000000000000
--- a/gnome-base/gvfs/gvfs-0.2.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-0.2.5.ebuild,v 1.8 2008/11/13 19:06:04 ranger Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="GNOME Virtual Filesystem Layer"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc64 sparc x86"
-IUSE="avahi cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
-
-RDEPEND=">=dev-libs/glib-2.16
- >=sys-apps/dbus-1.0
- >=net-libs/libsoup-2.4
- dev-libs/libxml2
- net-misc/openssh
- avahi? ( >=net-dns/avahi-0.6 )
- cdda? (
- >=sys-apps/hal-0.5.10
- >=dev-libs/libcdio-0.78.2
- )
- fuse? ( sys-fs/fuse )
- gnome? ( >=gnome-base/gconf-2.0 )
- hal? ( >=sys-apps/hal-0.5.10 )
- gphoto2? ( >=media-libs/libgphoto2-2.4 )
- gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
- samba? ( >=net-fs/samba-3 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --enable-http
- --disable-obexftp
- --disable-archive
- $(use_enable avahi)
- $(use_enable cdda)
- $(use_enable fuse)
- $(use_enable gnome gconf)
- $(use_enable gphoto2)
- $(use_enable hal)
- $(use_enable gnome-keyring keyring)
- $(use_enable samba)"
-
- if use cdda && built_with_use dev-libs/libcdio minimal; then
- ewarn
- ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
- ewarn "without the minimal USE flag."
- die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
- fi
-}
diff --git a/gnome-base/gvfs/gvfs-1.0.1.ebuild b/gnome-base/gvfs/gvfs-1.0.1.ebuild
deleted file mode 100644
index b4e7f008d303..000000000000
--- a/gnome-base/gvfs/gvfs-1.0.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.1.ebuild,v 1.1 2008/10/12 21:55:50 eva Exp $
-
-inherit bash-completion gnome2 eutils
-
-DESCRIPTION="GNOME Virtual Filesystem Layer"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="archive avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
-
-RDEPEND=">=dev-libs/glib-2.17.6
- >=sys-apps/dbus-1.0
- >=net-libs/libsoup-2.23.91
- dev-libs/libxml2
- net-misc/openssh
- archive? ( app-arch/libarchive )
- avahi? ( >=net-dns/avahi-0.6 )
- cdda? (
- >=sys-apps/hal-0.5.10
- >=dev-libs/libcdio-0.78.2
- )
- fuse? ( sys-fs/fuse )
- gnome? ( >=gnome-base/gconf-2.0 )
- hal? ( >=sys-apps/hal-0.5.10 )
- bluetooth? (
- dev-libs/dbus-glib
- >=net-wireless/bluez-libs-3.12
- dev-libs/expat
- )
- gphoto2? ( >=media-libs/libgphoto2-2.4 )
- gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
- samba? ( >=net-fs/samba-3 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- >=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --enable-http
- --disable-bash-completion
- $(use_enable archive)
- $(use_enable avahi)
- $(use_enable bluetooth obexftp)
- $(use_enable cdda)
- $(use_enable fuse)
- $(use_enable gnome gconf)
- $(use_enable gphoto2)
- $(use_enable hal)
- $(use_enable gnome-keyring keyring)
- $(use_enable samba)"
-
- if use cdda && built_with_use dev-libs/libcdio minimal; then
- ewarn
- ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
- ewarn "without the minimal USE flag."
- die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
- fi
-}
-
-src_install() {
- gnome2_src_install
- use bash-completion && \
- dobashcompletion programs/gvfs-bash-completion.sh ${PN}
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- use bash-completion && bash-completion_pkg_postinst
-}
diff --git a/gnome-base/gvfs/gvfs-1.0.2.ebuild b/gnome-base/gvfs/gvfs-1.0.2.ebuild
deleted file mode 100644
index ec7ed49da246..000000000000
--- a/gnome-base/gvfs/gvfs-1.0.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.2.ebuild,v 1.1 2008/10/23 20:29:21 eva Exp $
-
-inherit bash-completion gnome2 eutils
-
-DESCRIPTION="GNOME Virtual Filesystem Layer"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="archive avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
-
-RDEPEND=">=dev-libs/glib-2.17.6
- >=sys-apps/dbus-1.0
- >=net-libs/libsoup-2.23.91
- dev-libs/libxml2
- net-misc/openssh
- archive? ( app-arch/libarchive )
- avahi? ( >=net-dns/avahi-0.6 )
- cdda? (
- >=sys-apps/hal-0.5.10
- >=dev-libs/libcdio-0.78.2
- )
- fuse? ( sys-fs/fuse )
- gnome? ( >=gnome-base/gconf-2.0 )
- hal? ( >=sys-apps/hal-0.5.10 )
- bluetooth? (
- dev-libs/dbus-glib
- >=net-wireless/bluez-libs-3.12
- dev-libs/expat
- )
- gphoto2? ( >=media-libs/libgphoto2-2.4 )
- gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
- samba? ( >=net-fs/samba-3 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- >=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --enable-http
- --disable-bash-completion
- $(use_enable archive)
- $(use_enable avahi)
- $(use_enable bluetooth obexftp)
- $(use_enable cdda)
- $(use_enable fuse)
- $(use_enable gnome gconf)
- $(use_enable gphoto2)
- $(use_enable hal)
- $(use_enable gnome-keyring keyring)
- $(use_enable samba)"
-
- if use cdda && built_with_use dev-libs/libcdio minimal; then
- ewarn
- ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
- ewarn "without the minimal USE flag."
- die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
- fi
-}
-
-src_install() {
- gnome2_src_install
- use bash-completion && \
- dobashcompletion programs/gvfs-bash-completion.sh ${PN}
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- use bash-completion && bash-completion_pkg_postinst
-}
diff --git a/gnome-base/gvfs/gvfs-1.0.3-r10.ebuild b/gnome-base/gvfs/gvfs-1.0.3-r10.ebuild
index 3753fa3211b8..b96231aa10f9 100644
--- a/gnome-base/gvfs/gvfs-1.0.3-r10.ebuild
+++ b/gnome-base/gvfs/gvfs-1.0.3-r10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3-r10.ebuild,v 1.2 2009/01/27 10:30:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3-r10.ebuild,v 1.3 2009/01/29 22:07:22 eva Exp $
-inherit bash-completion gnome2 eutils
+inherit autotools bash-completion gnome2 eutils
DESCRIPTION="GNOME Virtual Filesystem Layer"
HOMEPAGE="http://www.gnome.org"
@@ -35,7 +35,8 @@ RDEPEND=">=dev-libs/glib-2.17.6
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
>=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
+ doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/gtk-doc-am"
DOCS="AUTHORS ChangeLog NEWS README TODO"
@@ -67,6 +68,11 @@ src_unpack() {
# Add support for bluez 4, bug #250615
epatch "${FILESDIR}/${P}-bluez4.patch"
+
+ # Fix non posixy tests, bug #256305
+ epatch "${FILESDIR}/${P}-posixtest.patch"
+
+ eautoreconf
}
src_install() {
diff --git a/gnome-base/gvfs/gvfs-1.0.3.ebuild b/gnome-base/gvfs/gvfs-1.0.3.ebuild
index ce5a25d3dbf9..3700f8e1a9ea 100644
--- a/gnome-base/gvfs/gvfs-1.0.3.ebuild
+++ b/gnome-base/gvfs/gvfs-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3.ebuild,v 1.2 2009/01/20 11:13:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3.ebuild,v 1.3 2009/01/29 22:07:22 eva Exp $
-inherit bash-completion gnome2 eutils
+inherit autotools bash-completion gnome2 eutils
DESCRIPTION="GNOME Virtual Filesystem Layer"
HOMEPAGE="http://www.gnome.org"
@@ -37,7 +37,8 @@ RDEPEND=">=dev-libs/glib-2.17.6
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
>=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
+ doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/gtk-doc-am"
DOCS="AUTHORS ChangeLog NEWS README TODO"
@@ -64,6 +65,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix non posixy tests, bug #256305
+ epatch "${FILESDIR}/${P}-posixtest.patch"
+
+ eautoreconf
+}
+
src_install() {
gnome2_src_install
use bash-completion && \