summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/posix-spawn/ChangeLog7
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/posix-spawn/ChangeLog b/dev-ruby/posix-spawn/ChangeLog
index 811ab2093c1e..5f568437febe 100644
--- a/dev-ruby/posix-spawn/ChangeLog
+++ b/dev-ruby/posix-spawn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/posix-spawn
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.10 2015/01/30 07:06:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.11 2015/02/18 07:10:53 graaff Exp $
+
+*posix-spawn-0.3.10 (18 Feb 2015)
+
+ 18 Feb 2015; Hans de Graaff <graaff@gentoo.org> +posix-spawn-0.3.10.ebuild:
+ Version bump.
30 Jan 2015; Hans de Graaff <graaff@gentoo.org> posix-spawn-0.3.9.ebuild:
Add ruby22.
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild
new file mode 100644
index 000000000000..c8fa69deca86
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild,v 1.1 2015/02/18 07:10:53 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+KEYWORDS="~amd64"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}