summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/uulib/ChangeLog5
-rw-r--r--dev-libs/uulib/uulib-0.5.20.ebuild12
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-libs/uulib/ChangeLog b/dev-libs/uulib/ChangeLog
index cb6def8d4644..fd095aacf7ae 100644
--- a/dev-libs/uulib/ChangeLog
+++ b/dev-libs/uulib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/uulib
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uulib/ChangeLog,v 1.17 2008/01/25 21:11:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uulib/ChangeLog,v 1.18 2008/09/21 02:23:57 solar Exp $
+
+ 21 Sep 2008; <solar@gentoo.org> uulib-0.5.20.ebuild:
+ - make cross compile aware
25 Jan 2008; Fabian Groffen <grobian@gentoo.org> uulib-0.5.20.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/dev-libs/uulib/uulib-0.5.20.ebuild b/dev-libs/uulib/uulib-0.5.20.ebuild
index 6e3b73231294..5f07644d6b66 100644
--- a/dev-libs/uulib/uulib-0.5.20.ebuild
+++ b/dev-libs/uulib/uulib-0.5.20.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uulib/uulib-0.5.20.ebuild,v 1.19 2008/01/25 21:11:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uulib/uulib-0.5.20.ebuild,v 1.20 2008/09/21 02:23:57 solar Exp $
+
+inherit toolchain-funcs
MY_P=uudeview-${PV}
-DESCRIPTION="library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
+DESCRIPTION="Library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${MY_P}.tar.gz"
@@ -17,6 +19,12 @@ DEPEND=""
S=${WORKDIR}/${MY_P}/${PN}
+src_compile() {
+ tc-export CC
+ econf || die
+ emake || die
+}
+
src_install() {
dolib.a libuu.a
insinto /usr/include