summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/gloox/ChangeLog13
-rw-r--r--net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch12
-rw-r--r--net-libs/gloox/files/gloox-0.9.9.5-gcc44.patch31
-rw-r--r--net-libs/gloox/files/gloox-res_query-check.patch11
-rw-r--r--net-libs/gloox/gloox-0.9.8.ebuild34
-rw-r--r--net-libs/gloox/gloox-0.9.9.5.ebuild41
-rw-r--r--net-libs/gloox/gloox-1.0.6.ebuild37
7 files changed, 47 insertions, 132 deletions
diff --git a/net-libs/gloox/ChangeLog b/net-libs/gloox/ChangeLog
index cfa5c9a343c5..d45836e449ec 100644
--- a/net-libs/gloox/ChangeLog
+++ b/net-libs/gloox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/gloox
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.17 2012/09/03 00:20:41 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.18 2013/09/05 13:10:04 mrueg Exp $
+
+*gloox-1.0.6 (05 Sep 2013)
+
+ 05 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +gloox-1.0.6.ebuild,
+ -files/gloox-0.9.9.5-gcc43.patch, -files/gloox-0.9.9.5-gcc44.patch,
+ -files/gloox-res_query-check.patch, -gloox-0.9.8.ebuild,
+ -gloox-0.9.9.5.ebuild:
+ Version bump. Cleanup old. Fix bug #483572
03 Sep 2012; Anthony G. Basile <blueness@gentoo.org> gloox-1.0.ebuild:
Keyword ~arm, bug #343515
@@ -76,4 +84,3 @@
22 Oct 2007; Markus Ullmann <jokey@gentoo.org> +metadata.xml,
+gloox-0.8.4.ebuild:
Initial import for dep of climm
-
diff --git a/net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch b/net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch
deleted file mode 100644
index 0fa4fd465121..000000000000
--- a/net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- gloox-0.9.9.5b/src/tlsopenssl.cpp 2009-01-21 22:43:06.000000000 -0400
-+++ gloox-0.9.9.5/src/tlsopenssl.cpp 2009-01-22 00:42:53.000000000 -0400
-@@ -223,7 +223,8 @@
- m_certInfo.date_to = openSSLTime2UnixTime( (char*)(peer->cert_info->validity->notAfter->data) );
- std::string p;
- p.assign( peer_CN );
-- std::transform( p.begin(), p.end(), p.begin(), std::tolower );
-+ /* http://lists.debian.org/debian-gcc/2002/04/msg00092.html */
-+ std::transform( p.begin(), p.end(), p.begin(), (int(*)(int))std::tolower );
- if( p != m_server )
- m_certInfo.status |= CertWrongPeer;
-
diff --git a/net-libs/gloox/files/gloox-0.9.9.5-gcc44.patch b/net-libs/gloox/files/gloox-0.9.9.5-gcc44.patch
deleted file mode 100644
index 27541033d85b..000000000000
--- a/net-libs/gloox/files/gloox-0.9.9.5-gcc44.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -NrU5 gloox-0.9.9.5.original/src/md5.cpp gloox-0.9.9.5/src/md5.cpp
---- gloox-0.9.9.5.original/src/md5.cpp 2009-06-18 15:19:28.000000000 -0600
-+++ gloox-0.9.9.5/src/md5.cpp 2009-06-18 15:22:11.000000000 -0600
-@@ -70,10 +70,11 @@
- */
-
- #include "md5.h"
-
- #include <string.h>
-+#include <cstdio>
-
- namespace gloox
- {
- // #undef BYTE_ORDER /* 1 = big-endian, -1 = little-endian, 0 = unknown */
- // #ifdef ARCH_IS_BIG_ENDIAN
-diff -NrU5 gloox-0.9.9.5.original/src/sha.cpp gloox-0.9.9.5/src/sha.cpp
---- gloox-0.9.9.5.original/src/sha.cpp 2009-06-18 15:19:28.000000000 -0600
-+++ gloox-0.9.9.5/src/sha.cpp 2009-06-18 15:31:29.000000000 -0600
-@@ -10,10 +10,12 @@
- This software is distributed without any warranty.
- */
-
- #include "sha.h"
-
-+#include <cstdio>
-+
- namespace gloox
- {
-
- SHA::SHA()
- {
diff --git a/net-libs/gloox/files/gloox-res_query-check.patch b/net-libs/gloox/files/gloox-res_query-check.patch
deleted file mode 100644
index 91dcfebd2ecd..000000000000
--- a/net-libs/gloox/files/gloox-res_query-check.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac~ 2008-02-18 21:30:35.000000000 +0100
-+++ configure.ac 2008-02-18 21:31:21.000000000 +0100
-@@ -248,7 +248,7 @@
- AC_MSG_CHECKING([for res_query in -lresolv (alternate version)])
- save_libs="$LIBS"
- LIBS="-lresolv $LIBS"
-- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0)]])],
-+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0,0,0,0)]])],
- [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_RES_QUERY)
- have_res_query=yes],
diff --git a/net-libs/gloox/gloox-0.9.8.ebuild b/net-libs/gloox/gloox-0.9.8.ebuild
deleted file mode 100644
index 70d9a000b8f3..000000000000
--- a/net-libs/gloox/gloox-0.9.8.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.8.ebuild,v 1.4 2008/03/10 15:02:10 beandog Exp $
-
-DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
-HOMEPAGE="http://camaya.net/gloox"
-SRC_URI="http://camaya.net/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug gnutls idn ssl zlib"
-
-DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
- gnutls? ( >=net-libs/gnutls-1.2.0 )
- ssl? ( >=dev-libs/openssl-0.9.7 )
- zlib? ( sys-libs/zlib )"
-
-RDEPEND="${DEPEND}"
-
-src_compile() {
- econf \
- $(use_enable debug debug) \
- $(use_with idn libidn) \
- $(use_with gnutls gnutls) \
- $(use_with ssl openssl) \
- $(use_with zlib zlib) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-libs/gloox/gloox-0.9.9.5.ebuild b/net-libs/gloox/gloox-0.9.9.5.ebuild
deleted file mode 100644
index 97f968d79964..000000000000
--- a/net-libs/gloox/gloox-0.9.9.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.5.ebuild,v 1.4 2009/07/30 21:12:39 maekke Exp $
-
-EAPI=2
-
-inherit autotools eutils
-
-DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
-HOMEPAGE="http://camaya.net/gloox"
-SRC_URI="http://camaya.net/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug gnutls idn ssl zlib"
-
-RDEPEND="idn? ( >=net-dns/libidn-0.5.0 )
- gnutls? ( >=net-libs/gnutls-1.2.0 )
- ssl? ( >=dev-libs/openssl-0.9.8 )
- zlib? ( >=sys-libs/zlib-1.2.3 )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-gcc44.patch
-}
-
-src_configure() {
- econf \
- $(use_enable debug debug) \
- $(use_with idn libidn) \
- $(use_with gnutls gnutls) \
- $(use_with ssl openssl) \
- $(use_with zlib zlib) \
- || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-libs/gloox/gloox-1.0.6.ebuild b/net-libs/gloox/gloox-1.0.6.ebuild
new file mode 100644
index 000000000000..c93518dafc67
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.6.ebuild,v 1.1 2013/09/05 13:10:04 mrueg Exp $
+
+EAPI=5
+
+MY_P=${P/_/-}
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}