summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8.ebuild14
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild9
-rw-r--r--app-pda/synce-rra/synce-rra-0.8.9.ebuild9
-rw-r--r--app-portage/lintool/lintool-0.2.3-r1.ebuild13
4 files changed, 20 insertions, 25 deletions
diff --git a/app-pda/pilot-link/pilot-link-0.11.8.ebuild b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
index 7c8907229091..f04971bb3741 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.6 2003/12/14 01:11:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.7 2004/04/07 19:23:34 vapier Exp $
-inherit perl-module
+inherit perl-module eutils
DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
-SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
HOMEPAGE="http://www.pilot-link.org/"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
IUSE="perl java tcltk python png readline"
@@ -56,7 +56,7 @@ src_compile() {
# java fails w/emake
make || die
- if [ `use perl` ] ; then
+ if use perl ; then
cd ${S}/bindings/Perl
perl-module_src_prep
perl-module_src_compile
@@ -68,7 +68,7 @@ src_install() {
dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
- if [ `use perl` ] ; then
+ if use perl ; then
cd ${S}/bindings/Perl
perl-module_src_install
fi
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
index ddadaac3bcf2..b682298e859c 100644
--- a/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
+++ b/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild,v 1.2 2004/03/30 12:10:58 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild,v 1.3 2004/04/07 19:27:47 vapier Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -18,11 +20,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${P}-gcc33.patch
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
make DESTDIR=${D} install || die
dodoc README
diff --git a/app-pda/synce-rra/synce-rra-0.8.9.ebuild b/app-pda/synce-rra/synce-rra-0.8.9.ebuild
index 7fb2c9fd879d..4245923f98b4 100644
--- a/app-pda/synce-rra/synce-rra-0.8.9.ebuild
+++ b/app-pda/synce-rra/synce-rra-0.8.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.8.9.ebuild,v 1.1 2004/03/26 12:34:10 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.8.9.ebuild,v 1.2 2004/04/07 19:28:00 vapier Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -22,11 +24,6 @@ src_unpack() {
epatch ${DISTDIR}/librra-synce-kde-0.7.diff
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
make DESTDIR="${D%/}" install || die
}
diff --git a/app-portage/lintool/lintool-0.2.3-r1.ebuild b/app-portage/lintool/lintool-0.2.3-r1.ebuild
index f7e292346074..ab6aa8a839d1 100644
--- a/app-portage/lintool/lintool-0.2.3-r1.ebuild
+++ b/app-portage/lintool/lintool-0.2.3-r1.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/lintool/lintool-0.2.3-r1.ebuild,v 1.2 2004/01/23 00:31:24 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/lintool/lintool-0.2.3-r1.ebuild,v 1.3 2004/04/07 19:28:33 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="Gentoo Linux \"lint\" utility"
HOMEPAGE="http://www.gentoo.org/"
SRC_URI="mirror://gentoo/${P}.tar.bz2
mirror://gentoo/lintool-copyright-patch.diff"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc hppa alpha mips"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa"
DEPEND=">=sys-apps/portage-2.0.47-r10
>=dev-lang/python-2.2"
@@ -25,7 +26,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc README NEWS ChangeLog COPYING AUTHORS
+ dodoc README NEWS ChangeLog AUTHORS
}