summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/pomap/ChangeLog7
-rw-r--r--dev-ml/pomap/pomap-2.9.9.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ml/pomap/ChangeLog b/dev-ml/pomap/ChangeLog
index 8d46216f7d09..1f919bd80bb7 100644
--- a/dev-ml/pomap/ChangeLog
+++ b/dev-ml/pomap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pomap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/ChangeLog,v 1.17 2009/06/21 12:51:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/ChangeLog,v 1.18 2009/06/21 12:56:19 aballier Exp $
+
+*pomap-2.9.9 (21 Jun 2009)
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org> +pomap-2.9.9.ebuild:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org> pomap-2.9.8.ebuild:
define eapi before inherit and assign rdepend explicitly
diff --git a/dev-ml/pomap/pomap-2.9.9.ebuild b/dev-ml/pomap/pomap-2.9.9.ebuild
new file mode 100644
index 000000000000..c4f589a298a0
--- /dev/null
+++ b/dev-ml/pomap/pomap-2.9.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/pomap-2.9.9.ebuild,v 1.1 2009/06/21 12:56:19 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples +ocamlopt"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changes
+
+ #install examples
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}