summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/cob/ChangeLog8
-rw-r--r--games-arcade/cob/cob-0.9.ebuild19
-rw-r--r--games-arcade/cob/files/cob-0.9-gcc44.patch30
3 files changed, 43 insertions, 14 deletions
diff --git a/games-arcade/cob/ChangeLog b/games-arcade/cob/ChangeLog
index eac8a4aa3514..27e6476bb2b4 100644
--- a/games-arcade/cob/ChangeLog
+++ b/games-arcade/cob/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/cob
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/ChangeLog,v 1.9 2008/04/30 21:48:15 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/ChangeLog,v 1.10 2009/06/18 01:31:16 nyhm Exp $
+
+ 18 Jun 2009; Tristan Heaven <nyhm@gentoo.org> cob-0.9.ebuild,
+ +files/cob-0.9-gcc44.patch:
+ Fix building with gcc-4.4, bug #273520
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org> +files/cob-0.9-gcc43.patch,
cob-0.9.ebuild:
diff --git a/games-arcade/cob/cob-0.9.ebuild b/games-arcade/cob/cob-0.9.ebuild
index 4403fa846381..7a755eea8b53 100644
--- a/games-arcade/cob/cob-0.9.ebuild
+++ b/games-arcade/cob/cob-0.9.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/cob-0.9.ebuild,v 1.12 2008/04/30 21:48:15 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/cob-0.9.ebuild,v 1.13 2009/06/18 01:31:16 nyhm Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Cruising on Broadway: a painting-type game"
@@ -15,16 +16,10 @@ IUSE=""
DEPEND="media-libs/libsdl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- # gcc34 compile fix (bug #119061)
- sed -i \
- -e '195 s/;//' \
- cob/sdw.hxx \
- || die "sed failed"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
diff --git a/games-arcade/cob/files/cob-0.9-gcc44.patch b/games-arcade/cob/files/cob-0.9-gcc44.patch
new file mode 100644
index 000000000000..dd90b388e6d8
--- /dev/null
+++ b/games-arcade/cob/files/cob-0.9-gcc44.patch
@@ -0,0 +1,30 @@
+--- cob/game.cpp
++++ cob/game.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "cob.hxx"
+
+ // **************************************************************************************************************************
+--- cob/main.cpp
++++ cob/main.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "cob.hxx"
+
+ // **************************************************************************************************************************
+--- cob/map.cpp
++++ cob/map.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "cob.hxx"
+
+ // **************************************************************************************************************************