summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/when/ChangeLog7
-rw-r--r--app-misc/when/when-1.1.27.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-misc/when/ChangeLog b/app-misc/when/ChangeLog
index 7d0884c87641..da83192ec0bb 100644
--- a/app-misc/when/ChangeLog
+++ b/app-misc/when/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/when
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/when/ChangeLog,v 1.44 2011/02/12 18:35:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/when/ChangeLog,v 1.45 2011/03/02 08:39:38 radhermit Exp $
+
+*when-1.1.27 (02 Mar 2011)
+
+ 02 Mar 2011; Tim Harder <radhermit@gentoo.org> +when-1.1.27.ebuild:
+ Version bump and update to EAPI 4.
12 Feb 2011; Raúl Porcel <armin76@gentoo.org> when-1.1.22.ebuild:
sparc stable wrt #350709
diff --git a/app-misc/when/when-1.1.27.ebuild b/app-misc/when/when-1.1.27.ebuild
new file mode 100644
index 000000000000..6812c17f453f
--- /dev/null
+++ b/app-misc/when/when-1.1.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/when/when-1.1.27.ebuild,v 1.1 2011/03/02 08:39:38 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Extremely simple personal calendar program aimed at the Unix geek who wants something minimalistic"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="http://www.lightandmatter.com/when/when.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/when_dist
+
+src_prepare() {
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile
+}
+
+src_compile() { :; }
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when
+ touch "${HOME}"/.when/{calendar,preferences}
+ emake test
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README
+}