summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libnice/ChangeLog12
-rw-r--r--net-libs/libnice/files/libnice-0.0.13-darwin.patch17
-rw-r--r--net-libs/libnice/libnice-0.1.0.ebuild43
-rw-r--r--net-libs/libnice/libnice-0.1.2.ebuild5
-rw-r--r--net-libs/libnice/libnice-0.1.3-r1.ebuild (renamed from net-libs/libnice/libnice-0.1.3.ebuild)24
5 files changed, 26 insertions, 75 deletions
diff --git a/net-libs/libnice/ChangeLog b/net-libs/libnice/ChangeLog
index 544dddefdfbe..e1f8a5c7f223 100644
--- a/net-libs/libnice/ChangeLog
+++ b/net-libs/libnice/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-libs/libnice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.42 2012/10/28 16:24:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.43 2012/12/08 00:57:58 tetromino Exp $
+
+*libnice-0.1.3-r1 (08 Dec 2012)
+
+ 08 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -files/libnice-0.0.13-darwin.patch, -libnice-0.1.0.ebuild,
+ libnice-0.1.2.ebuild, -libnice-0.1.3.ebuild, +libnice-0.1.3-r1.ebuild:
+ Split gstreamer plugin out into a separate package,
+ media-plugins/gst-plugins-libnice, to allow clean optional support for
+ gst-0.10 and/or gst-1.0. Remove 0.1.3 ebuild due to automagic gst-1.0
+ detection. Remove old. Update license.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> libnice-0.1.2.ebuild:
ia64/sparc stable wrt #427544
diff --git a/net-libs/libnice/files/libnice-0.0.13-darwin.patch b/net-libs/libnice/files/libnice-0.0.13-darwin.patch
deleted file mode 100644
index 901a6c047b22..000000000000
--- a/net-libs/libnice/files/libnice-0.0.13-darwin.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://trac.macports.org/browser/trunk/dports/net/libnice/files/patch-agent-interfaces.c.diff
-
-http://bugs.gentoo.org/show_bug.cgi?id=343611
-
-fix compilation error due to anonymous struct
-
---- agent/interfaces.c
-+++ agent/interfaces.c
-@@ -198,7 +198,7 @@
- struct sockaddr_in6 *sa6 = (struct sockaddr_in6 *)ifa->ifa_addr;
-
- /* Skip link-local addresses, they require a scope */
-- if (IN6_IS_ADDR_LINKLOCAL (sa6->sin6_addr.s6_addr))
-+ if (IN6_IS_ADDR_LINKLOCAL ((struct in6_addr *)sa6->sin6_addr.s6_addr))
- continue;
-
- if (inet_ntop (AF_INET6, &sa6->sin6_addr, addr_as_string,
diff --git a/net-libs/libnice/libnice-0.1.0.ebuild b/net-libs/libnice/libnice-0.1.0.ebuild
deleted file mode 100644
index 8710bbd3bdc5..000000000000
--- a/net-libs/libnice/libnice-0.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.0.ebuild,v 1.7 2012/05/05 02:54:24 jdhore Exp $
-
-EAPI="3"
-
-inherit eutils libtool
-
-DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
-HOMEPAGE="http://nice.freedesktop.org/wiki/"
-SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="+gstreamer upnp"
-
-RDEPEND=">=dev-libs/glib-2.10
- gstreamer? (
- media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10 )
- upnp? ( >=net-libs/gupnp-igd-0.1.3 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.0.13-darwin.patch
- elibtoolize # for .bundle on Darwin
-}
-
-src_configure() {
- econf --disable-static \
- $(use_with gstreamer) \
- $(use_enable upnp gupnp)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS COPYING* README NEWS || die "dodoc failed."
-
- # Remove .la files since static libs are no longer being installed
- find "${D}" -name '*.la' -exec rm -f '{}' + || die
-}
diff --git a/net-libs/libnice/libnice-0.1.2.ebuild b/net-libs/libnice/libnice-0.1.2.ebuild
index e11148753224..3dad37623e18 100644
--- a/net-libs/libnice/libnice-0.1.2.ebuild
+++ b/net-libs/libnice/libnice-0.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.2.ebuild,v 1.9 2012/10/28 16:24:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.2.ebuild,v 1.10 2012/12/08 00:57:58 tetromino Exp $
EAPI="4"
@@ -8,7 +8,7 @@ DESCRIPTION="An implementation of the Interactice Connectivity Establishment sta
HOMEPAGE="http://nice.freedesktop.org/wiki/"
SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
-LICENSE="LGPL-2.1 MPL-1.1"
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="+gstreamer upnp"
@@ -19,6 +19,7 @@ RDEPEND=">=dev-libs/glib-2.13:2
media-libs/gst-plugins-base:0.10 )
upnp? ( >=net-libs/gupnp-igd-0.1.3 )"
DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
virtual/pkgconfig"
src_configure() {
diff --git a/net-libs/libnice/libnice-0.1.3.ebuild b/net-libs/libnice/libnice-0.1.3-r1.ebuild
index 6ee7aa17e5c4..b5728d02adf9 100644
--- a/net-libs/libnice/libnice-0.1.3.ebuild
+++ b/net-libs/libnice/libnice-0.1.3-r1.ebuild
@@ -1,35 +1,35 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.3.ebuild,v 1.1 2012/09/22 10:34:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.3-r1.ebuild,v 1.1 2012/12/08 00:57:58 tetromino Exp $
-EAPI="4"
+EAPI="5"
+
+inherit eutils
DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
HOMEPAGE="http://nice.freedesktop.org/wiki/"
SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
-LICENSE="LGPL-2.1 MPL-1.1"
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="+gstreamer upnp"
+IUSE="+upnp"
RDEPEND=">=dev-libs/glib-2.13:2
- gstreamer? (
- media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10 )
- upnp? ( >=net-libs/gupnp-igd-0.1.3 )"
+ upnp? ( >=net-libs/gupnp-igd-0.1.3:= )"
DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
virtual/pkgconfig"
src_configure() {
+ # gstreamer plugin split off into media-plugins/gst-plugins-libnice
econf --disable-static \
- $(use_with gstreamer gstreamer-0.10) \
+ --without-gstreamer \
+ --without-gstreamer-0.10 \
$(use_enable upnp gupnp)
}
src_install() {
default
-
- # Remove .la files since static libs are no longer being installed
- find "${D}" -name '*.la' -exec rm -f '{}' + || die
+ prune_libtool_files --modules
}