summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/last/ChangeLog7
-rw-r--r--sci-biology/last/last-146.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 5ea45c4e4961..882d5a50c317 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.7 2010/09/15 20:51:44 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.8 2010/11/29 16:27:46 weaver Exp $
+
+*last-146 (29 Nov 2010)
+
+ 29 Nov 2010; Andrey Kislyuk <weaver@gentoo.org> +last-146.ebuild:
+ Version bump
*last-128-r1 (15 Sep 2010)
diff --git a/sci-biology/last/last-146.ebuild b/sci-biology/last/last-146.ebuild
new file mode 100644
index 000000000000..ae9c26505e70
--- /dev/null
+++ b/sci-biology/last/last-146.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-146.ebuild,v 1.1 2010/11/29 16:27:46 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ emake -e -C src CXX="$(tc-getCXX)" \
+ STRICT="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin src/last{al,db} || die
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/* || die
+ dodoc doc/*.txt ChangeLog.txt README.txt || die
+}