summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/dante/ChangeLog8
-rw-r--r--net-proxy/dante/dante-1.4.0-r1.ebuild95
-rw-r--r--net-proxy/dante/files/dante-sockd.service9
3 files changed, 111 insertions, 1 deletions
diff --git a/net-proxy/dante/ChangeLog b/net-proxy/dante/ChangeLog
index 918ef9a80a3b..06a0d21cea3f 100644
--- a/net-proxy/dante/ChangeLog
+++ b/net-proxy/dante/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/dante
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.70 2014/01/08 06:24:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.71 2014/02/15 13:03:39 pacho Exp $
+
+*dante-1.4.0-r1 (15 Feb 2014)
+
+ 15 Feb 2014; Pacho Ramos <pacho@gentoo.org> +dante-1.4.0-r1.ebuild,
+ +files/dante-sockd.service:
+ Add unit file (#500500)
08 Jan 2014; Mike Frysinger <vapier@gentoo.org> dante-1.1.19-r4.ebuild,
dante-1.3.2-r1.ebuild, dante-1.3.2.ebuild, dante-1.4.0.ebuild,
diff --git a/net-proxy/dante/dante-1.4.0-r1.ebuild b/net-proxy/dante/dante-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..7af97074f280
--- /dev/null
+++ b/net-proxy/dante/dante-1.4.0-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/dante-1.4.0-r1.ebuild,v 1.1 2014/02/15 13:03:39 pacho Exp $
+
+EAPI="5"
+
+inherit autotools eutils systemd user
+
+DESCRIPTION="A free socks4,5 and msproxy implementation"
+HOMEPAGE="http://www.inet.no/dante/"
+MY_P="${P/_/-}"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug kerberos pam selinux static-libs tcpd upnp"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( sec-policy/selinux-dante )
+ tcpd? ( sys-apps/tcp-wrappers )
+ userland_GNU? ( virtual/shadow )
+ upnp? ( net-libs/miniupnpc )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+DOCS="BUGS CREDITS NEWS README SUPPORT doc/README* doc/*.txt doc/SOCKS4.protocol"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.4.0-socksify.patch \
+ "${FILESDIR}"/${PN}-1.4.0-osdep-format-macro.patch \
+ "${FILESDIR}"/${PN}-1.4.0-cflags.patch
+
+ sed -i \
+ -e 's:/etc/socks\.conf:"${EPREFIX}"/etc/socks/socks.conf:' \
+ -e 's:/etc/sockd\.conf:"${EPREFIX}"/etc/socks/sockd.conf:' \
+ doc/{socksify.1,socks.conf.5,sockd.conf.5,sockd.8} \
+ || die
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # hardcoded the libc name otherwise the scan on a amd64 multilib system
+ # ends up finding /usr/lib32/libc.so.5. That cascades and causes the
+ # preload/libdsocks to not be built.
+ econf \
+ --with-socks-conf="${EPREFIX}"/etc/socks/socks.conf \
+ --with-sockd-conf="${EPREFIX}"/etc/socks/sockd.conf \
+ --enable-preload \
+ --enable-clientdl \
+ --enable-serverdl \
+ --with-libc=libc.so.6 \
+ $(use_enable debug) \
+ $(use_with kerberos gssapi) \
+ $(use_with pam) \
+ $(use_with upnp) \
+ $(use_enable static-libs static) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ # default configuration files
+ insinto /etc/socks
+ doins "${FILESDIR}"/sock?.conf
+ pushd "${ED}/etc/socks" > /dev/null
+ use pam && epatch "${FILESDIR}/sockd.conf-with-pam.patch"
+ use tcpd && epatch "${FILESDIR}/sockd.conf-with-libwrap.patch"
+ popd > /dev/null
+
+ # init script
+ newinitd "${FILESDIR}/${PN}-1.3.2-sockd-init" dante-sockd
+ newconfd "${FILESDIR}/dante-sockd-conf" dante-sockd
+
+ systemd_dounit "${FILESDIR}/dante-sockd.service"
+
+ # example configuration files
+ docinto examples
+ dodoc example/*.conf
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm '{}' +
+}
+
+pkg_postinst() {
+ enewuser sockd -1 -1 /etc/socks daemon
+}
diff --git a/net-proxy/dante/files/dante-sockd.service b/net-proxy/dante/files/dante-sockd.service
new file mode 100644
index 000000000000..647a2dcc8cd8
--- /dev/null
+++ b/net-proxy/dante/files/dante-sockd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=SOCKS v4 and v5 compatible proxy server and client
+After=network.target
+
+[Service]
+ExecStart=/usr/sbin/sockd
+
+[Install]
+WantedBy=multi-user.target