summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/stunnel/files/stunnel-3.22-gentoo.diff38
-rw-r--r--profiles/default-1.0_rc6/packages2
-rw-r--r--profiles/package.mask7
-rw-r--r--sys-apps/shadow/files/digest-shadow-4.0.1-r21
-rw-r--r--sys-apps/shadow/shadow-4.0.1-r2.ebuild61
5 files changed, 108 insertions, 1 deletions
diff --git a/net-misc/stunnel/files/stunnel-3.22-gentoo.diff b/net-misc/stunnel/files/stunnel-3.22-gentoo.diff
new file mode 100644
index 000000000000..bddbde5fd72a
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel-3.22-gentoo.diff
@@ -0,0 +1,38 @@
+--- Makefile.in Sun Dec 23 12:03:25 2001
++++ Makefile.in Thu Jan 17 12:28:22 2002
+@@ -9,7 +9,7 @@
+ sbindir=@sbindir@
+ libdir=@libdir@
+ man8dir=@mandir@/man8
+-piddir=@localstatedir@/stunnel/
++piddir=/var/run
+ ssldir=@ssldir@
+ openssl=$(ssldir)/bin/openssl
+ PEM_DIR=@PEM_DIR@
+@@ -24,7 +24,7 @@
+ LIBS=@LIBS@
+ HEADERS=common.h prototypes.h client.h
+ OBJS=client.o stunnel.o ssl.o protocol.o sthreads.o pty.o log.o options.o
+-DESTFILES=$(sbindir)/stunnel $(libdir)/stunnel.so $(man8dir)/stunnel.8 $(PEM_DIR)/stunnel.pem
++DESTFILES=$(sbindir)/stunnel $(libdir)/stunnel.so $(man8dir)/stunnel.8
+
+ WINGCC=i386-mingw32msvc-gcc
+ WINCFLAGS=-O2 -Wall -DUSE_WIN32=1 -DHAVE_OPENSSL=1 -DFD_SETSIZE=4096 -DVERSION=\"@VERSION@\" -I../openssl-0.9.6b/outinc
+@@ -33,7 +33,7 @@
+
+ # standard external rules
+
+-all: stunnel stunnel.8 stunnel.html stunnel.so stunnel.pem
++all: stunnel stunnel.8 stunnel.html stunnel.so
+
+ install: all installdirs $(DESTFILES)
+
+@@ -47,7 +47,7 @@
+ rm -f stunnel stunnel.so $(OBJS) core config.log stunnel.log
+
+ distclean: clean
+- rm -f config.cache config.status Makefile stunnel.pem
++ rm -f config.cache config.status Makefile
+
+ mostlyclean: distclean
+
diff --git a/profiles/default-1.0_rc6/packages b/profiles/default-1.0_rc6/packages
index bbdb27a420b2..74e102d3ace9 100644
--- a/profiles/default-1.0_rc6/packages
+++ b/profiles/default-1.0_rc6/packages
@@ -84,7 +84,7 @@
*sys-apps/sed
*sys-apps/setserial
*sys-apps/sh-utils
-*=sys-apps/shadow-4*
+>sys-apps/shadow-5
*sys-apps/sharutils
*sys-apps/tar
#only needed by xinetd, and it's out. So tcp-wrappers is out too
diff --git a/profiles/package.mask b/profiles/package.mask
index c3b60c11a9dd..0b403b5dd51b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,3 +1,10 @@
+#When you add an entry to this file, add your name, the date, and an
+#explanation of why something is getting masked
+
+# We are masking out the 4.x series shadow until we remove dependencies
+# on libshadow from other ebuilds. (drobbins, 19 Jan 2002)
+<=sys-apps/shadow-5
+
# 19 Jan 2002 -- until at has a security fix, we need this:
sys-apps/at
diff --git a/sys-apps/shadow/files/digest-shadow-4.0.1-r2 b/sys-apps/shadow/files/digest-shadow-4.0.1-r2
new file mode 100644
index 000000000000..9f758695f192
--- /dev/null
+++ b/sys-apps/shadow/files/digest-shadow-4.0.1-r2
@@ -0,0 +1 @@
+MD5 0d81d40d11ff7d1e0b061e4ab7976a9e shadow-4.0.1.tar.gz 962560
diff --git a/sys-apps/shadow/shadow-4.0.1-r2.ebuild b/sys-apps/shadow/shadow-4.0.1-r2.ebuild
new file mode 100644
index 000000000000..86ae67a89cde
--- /dev/null
+++ b/sys-apps/shadow/shadow-4.0.1-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.1-r2.ebuild,v 1.1 2002/01/19 22:48:33 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utilities to deal with user accounts"
+SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
+DEPEND=">=sys-libs/pam-0.73 sys-devel/gettext"
+RDEPEND=">=sys-libs/pam-0.73"
+
+src_compile() {
+ ./configure \
+ --disable-desrpc \
+ --with-libcrypt \
+ --with-libcrack \
+ --with-libpam \
+ --enable-shared=yes \
+ --enable-static=yes \
+ --host=${CHOST} || die "bad configure"
+ # Parallel make fails sometimes
+ make LDFLAGS="" || die "compile problem"
+}
+
+src_install() {
+ dodir /etc/default /etc/skel
+
+ make \
+ prefix=${D}/usr \
+ exec_prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die "install problem"
+
+ mv ${D}/lib ${D}/usr
+ dosed -e "s:/lib:/usr/lib:" -e "s: libshadow.so':':" /usr/lib/libshadow.la
+ dosym /usr/bin/newgrp /usr/bin/sg
+ dosym /usr/sbin/useradd /usr/sbin/adduser
+ dosym /usr/sbin/vipw /usr/sbin/vigr
+ # remove dead links
+ rm -f ${D}/bin/{sg,vipw}
+
+ insinto /etc
+ # Using a securetty with devfs device names added
+ # (compat names kept for non-devfs compatibility)
+ insopts -m0600 ; doins ${FILESDIR}/securetty
+ insopts -m0600 ; doins ${S}/etc/login.access
+ insopts -m0644 ; doins ${S}/etc/limits
+ insopts -m0644 ; doins ${FILESDIR}/login.defs
+ insinto /etc/pam.d ; insopts -m0644
+ doins ${FILESDIR}/shadow
+ newins ${FILESDIR}/shadow groupadd
+ newins ${FILESDIR}/shadow useradd
+ doins ${FILESDIR}/chage chage
+ cd ${S}/doc
+ dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
+ docinto txt
+ dodoc HOWTO LSM README.* *.txt
+
+ # install missing manpages
+ doman ${S}/man/{shadow.3,shadowconfig.8}
+}