summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/live/ChangeLog6
-rw-r--r--media-plugins/live/files/config.gentoo-so17
-rw-r--r--media-plugins/live/live-2009.06.02.ebuild81
3 files changed, 5 insertions, 99 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index 79befa4a0034..dc40f0fd1a60 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/live
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.151 2012/04/01 18:20:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.152 2012/04/05 11:54:04 aballier Exp $
+
+ 05 Apr 2012; Alexis Ballier <aballier@gentoo.org> -live-2009.06.02.ebuild,
+ -files/config.gentoo-so:
+ remove old
01 Apr 2012; Raúl Porcel <armin76@gentoo.org> live-2012.01.07.ebuild:
alpha/ia64/sparc stable wrt #408983
diff --git a/media-plugins/live/files/config.gentoo-so b/media-plugins/live/files/config.gentoo-so
deleted file mode 100644
index 4835fcbe35b2..000000000000
--- a/media-plugins/live/files/config.gentoo-so
+++ /dev/null
@@ -1,17 +0,0 @@
-COMPILE_OPTS = $(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
-C = c
-C_COMPILER = $(CC)
-C_FLAGS = $(COMPILE_OPTS) -fPIC $(CFLAGS)
-CPP = cpp
-CPLUSPLUS_COMPILER = $(CXX)
-CPLUSPLUS_FLAGS = $(COMPILE_OPTS) -fPIC $(CXXFLAGS)
-OBJ = o
-LINK = $(CXX) -o
-LINK_OPTS = -L.
-CONSOLE_LINK_OPTS = $(LINK_OPTS)
-LIBRARY_LINK = $(CC) -o
-LIBRARY_LINK_OPTS = $(LINK_OPTS) -shared -Wl,-soname,$@
-LIB_SUFFIX = so
-LIBS_FOR_CONSOLE_APPLICATION =
-LIBS_FOR_GUI_APPLICATION =
-EXE =
diff --git a/media-plugins/live/live-2009.06.02.ebuild b/media-plugins/live/live-2009.06.02.ebuild
deleted file mode 100644
index a9802e3f4103..000000000000
--- a/media-plugins/live/live-2009.06.02.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2009.06.02.ebuild,v 1.8 2010/01/06 16:55:17 ranger Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-S="${WORKDIR}"
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=3
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"
-
- cp -pPR live live-shared
- mv live live-static
-
- cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so" live-shared
-}
-
-src_compile() {
- tc-export CC CXX LD
-
- cd "${WORKDIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" TESTPROGS_APP="" MEDIA_SERVER_APP="" || die "failed to build static libraries"
-
- einfo "Beginning programs build"
- cd "${WORKDIR}/live-static/testProgs"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- cd "${WORKDIR}/live-static/mediaServer"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build the mediaserver"
-
- cd "${WORKDIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="so.${LIVE_ABI_VERSION}" TESTPROGS_APP="" MEDIA_SERVER_APP="" || die "failed to build shared libraries"
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}.so.${LIVE_ABI_VERSION}
- dosym lib${library}.so.${LIVE_ABI_VERSION} /usr/$(get_libdir)/lib${library}.so
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- # Should we really install these?
- find live-static/testProgs -type f -perm +111 -print0 | \
- xargs -0 dobin
-
- #install included live555MediaServer aplication
- dobin live-static/mediaServer/live555MediaServer
-
- # install docs
- dodoc live-static/README
-}
-
-pkg_postinst() {
- ewarn "If you are upgrading from a version prior to live-2008.02.08"
- ewarn "Please make sure to rebuild applications built against ${PN}"
- ewarn "like vlc or mplayer. ${PN} may have had ABI changes and ${PN}"
- ewarn "support might be broken."
-}