summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kdepim-l10n/ChangeLog6
-rw-r--r--kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild8
2 files changed, 10 insertions, 4 deletions
diff --git a/kde-base/kdepim-l10n/ChangeLog b/kde-base/kdepim-l10n/ChangeLog
index 691d2afc491e..fefc2d8ddb00 100644
--- a/kde-base/kdepim-l10n/ChangeLog
+++ b/kde-base/kdepim-l10n/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdepim-l10n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.1 2011/04/05 22:17:51 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.2 2011/04/05 23:32:48 dilfridge Exp $
+
+ 05 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ kdepim-l10n-4.4.10.ebuild:
+ Fix case where subdirs dont exist, bug 362245
*kdepim-l10n-4.4.10 (05 Apr 2011)
diff --git a/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild b/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild
index 2d8d97c8ecb8..49b7cb921a93 100644
--- a/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild
+++ b/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild,v 1.1 2011/04/05 22:17:51 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild,v 1.2 2011/04/05 23:32:48 dilfridge Exp $
EAPI=3
@@ -63,8 +63,10 @@ src_unpack() {
# remove everything except kdepim
for SUBDIR in data docs messages scripts ; do
- echo > "${S}/${DIR}/${SUBDIR}/CMakeLists.txt"
- [[ -d "${S}/${DIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${S}/${DIR}/${SUBDIR}/CMakeLists.txt" )
+ if [[ -d "${S}/${DIR}/${SUBDIR}" ]] ; then
+ echo > "${S}/${DIR}/${SUBDIR}/CMakeLists.txt"
+ [[ -d "${S}/${DIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${S}/${DIR}/${SUBDIR}/CMakeLists.txt" )
+ fi
done
done
fi