summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/galib/ChangeLog6
-rw-r--r--sci-libs/galib/files/digest-galib-2.4.51
-rw-r--r--sci-libs/galib/files/galib-2.4.5-gcc3.3.patch12
-rw-r--r--sci-libs/galib/galib-2.4.5.ebuild40
-rw-r--r--sci-libs/galib/galib-2.4.6.ebuild4
5 files changed, 7 insertions, 56 deletions
diff --git a/sci-libs/galib/ChangeLog b/sci-libs/galib/ChangeLog
index e622e011ff60..71bed58dfb65 100644
--- a/sci-libs/galib/ChangeLog
+++ b/sci-libs/galib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/galib
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.3 2005/04/25 12:25:59 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.4 2005/09/21 15:30:17 phosphan Exp $
+
+ 21 Sep 2005; Patrick Kursawe <phosphan@gentoo.org>
+ -files/galib-2.4.5-gcc3.3.patch, -galib-2.4.5.ebuild, galib-2.4.6.ebuild:
+ 2.4.6 stable for x86, cleanup
*galib-2.4.6 (25 Apr 2005)
diff --git a/sci-libs/galib/files/digest-galib-2.4.5 b/sci-libs/galib/files/digest-galib-2.4.5
deleted file mode 100644
index 8d869281d50a..000000000000
--- a/sci-libs/galib/files/digest-galib-2.4.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5a19b7692c3c18741cc0a120d36de165 galib245.tar.gz 385224
diff --git a/sci-libs/galib/files/galib-2.4.5-gcc3.3.patch b/sci-libs/galib/files/galib-2.4.5-gcc3.3.patch
deleted file mode 100644
index bba1dc122c90..000000000000
--- a/sci-libs/galib/files/galib-2.4.5-gcc3.3.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- ga/GARealGenome.h 2004-05-27 14:51:05.239072957 +0200
-+++ ga/GARealGenome.h 2004-05-27 15:02:21.824011198 +0200
-@@ -18,6 +18,9 @@
- typedef GAAlleleSet<float> GARealAlleleSet;
- typedef GAAlleleSetArray<float> GARealAlleleSetArray;
-
-+float GAAlleleSet<float>::allele() const;
-+float GAAlleleSet<float>::allele(unsigned) const;
-+
- typedef GA1DArrayAlleleGenome<float> GARealGenome;
-
- inline void GARealUniformInitializer(GAGenome& g){
diff --git a/sci-libs/galib/galib-2.4.5.ebuild b/sci-libs/galib/galib-2.4.5.ebuild
deleted file mode 100644
index 60aab8517faa..000000000000
--- a/sci-libs/galib/galib-2.4.5.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.5.ebuild,v 1.2 2005/04/25 12:25:59 phosphan Exp $
-
-inherit eutils
-
-DESCRIPTION="library for using genetic algorithms in C++ programs"
-
-HOMEPAGE="http://lancet.mit.edu/ga/"
-SRC_URI="ftp://lancet.mit.edu/pub/ga/galib245.tar.gz"
-LICENSE="GAlib"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-DEPEND=">=sys-apps/sed-4"
-
-S=${WORKDIR}/galib245
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc3.3.patch
- for file in examples/*.C ga/gaconfig.h; do
- for thing in iostream fstream; do
- sed -e "s:${thing}.h:${thing}:" -i ${file};
- done
- done
-}
-
-src_compile() {
- make CXXFLAGS="${CXXFLAGS}" || die "make failed"
-}
-
-src_install() {
- dodir /usr/lib /usr/include
- make LIB_DEST_DIR=${D}/usr/lib/ HDR_DEST_DIR=${D}/usr/include/ install || die
- dohtml -r doc/*
- dodoc RELEASE-NOTES README
- cp -r examples ${D}/usr/share/doc/${PF}/
-}
diff --git a/sci-libs/galib/galib-2.4.6.ebuild b/sci-libs/galib/galib-2.4.6.ebuild
index 6e02c9de693c..beb8a90bb510 100644
--- a/sci-libs/galib/galib-2.4.6.ebuild
+++ b/sci-libs/galib/galib-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.1 2005/04/25 12:25:59 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.2 2005/09/21 15:30:17 phosphan Exp $
inherit eutils
@@ -12,7 +12,7 @@ HOMEPAGE="http://lancet.mit.edu/ga/"
SRC_URI="http://lancet.mit.edu/ga/dist/galib${MYPV}.tgz"
LICENSE="GAlib"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND=""