summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/emacspeak/ChangeLog7
-rw-r--r--app-accessibility/emacspeak/emacspeak-27.0.ebuild3
-rw-r--r--app-accessibility/emacspeak/files/emacspeak-27.0-espeak.patch11
-rw-r--r--app-accessibility/emacspeak/files/emacspeak-27.0-tcl84.patch85
4 files changed, 58 insertions, 48 deletions
diff --git a/app-accessibility/emacspeak/ChangeLog b/app-accessibility/emacspeak/ChangeLog
index 0911d7fe2b33..6c8867587d58 100644
--- a/app-accessibility/emacspeak/ChangeLog
+++ b/app-accessibility/emacspeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/emacspeak
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.25 2008/01/13 16:18:11 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.26 2008/01/19 21:30:56 williamh Exp $
+
+ 19 Jan 2008; William Hubbs <williamh@gentoo.org>
+ +files/emacspeak-27.0-espeak.patch, files/emacspeak-27.0-tcl84.patch,
+ emacspeak-27.0.ebuild:
+ Added a patch for the espeak driver and fixed the tcl84 patch.
*emacspeak-27.0 (13 Jan 2008)
diff --git a/app-accessibility/emacspeak/emacspeak-27.0.ebuild b/app-accessibility/emacspeak/emacspeak-27.0.ebuild
index b5afb0acce6a..d3cbb0ead4a9 100644
--- a/app-accessibility/emacspeak/emacspeak-27.0.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-27.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-27.0.ebuild,v 1.1 2008/01/13 16:18:11 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-27.0.ebuild,v 1.2 2008/01/19 21:30:56 williamh Exp $
inherit eutils
@@ -18,6 +18,7 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack "${A}"
+ epatch "${FILESDIR}"/${P}-espeak.patch
epatch "${FILESDIR}"/${P}-makefile.patch
epatch "${FILESDIR}"/${P}-tcl84.patch
}
diff --git a/app-accessibility/emacspeak/files/emacspeak-27.0-espeak.patch b/app-accessibility/emacspeak/files/emacspeak-27.0-espeak.patch
new file mode 100644
index 000000000000..4fb8e48f4020
--- /dev/null
+++ b/app-accessibility/emacspeak/files/emacspeak-27.0-espeak.patch
@@ -0,0 +1,11 @@
+--- emacspeak-27.0.orig/servers/linux-espeak/tclespeak.cpp 2007-06-29 23:44:51.000000000 -0500
++++ emacspeak-27.0/servers/linux-espeak/tclespeak.cpp 2008-01-19 11:57:16.000000000 -0600
+@@ -593,7 +593,7 @@
+ continue;
+ }
+
+- char* aLangCode = 1 + voices[i]->languages;
++ const char* aLangCode = 1 + voices[i]->languages;
+
+ snprintf(buffer_i, 3, "%d", aLang);
+ snprintf(buffer_j, 3, "%d", j++);
diff --git a/app-accessibility/emacspeak/files/emacspeak-27.0-tcl84.patch b/app-accessibility/emacspeak/files/emacspeak-27.0-tcl84.patch
index bd11f039df7e..5c35c47db075 100644
--- a/app-accessibility/emacspeak/files/emacspeak-27.0-tcl84.patch
+++ b/app-accessibility/emacspeak/files/emacspeak-27.0-tcl84.patch
@@ -1,20 +1,12 @@
--- emacspeak-27.0.orig/servers/dtk-exp 2007-07-25 20:15:16.000000000 -0500
-+++ emacspeak-27.0/servers/dtk-exp 2008-01-12 20:39:54.000000000 -0600
++++ emacspeak-27.0/servers/dtk-exp 2008-01-19 12:38:15.000000000 -0600
@@ -1,4 +1,4 @@
-#!/usr/bin/tcl
+#!/usr/bin/tclsh
- # $Id: emacspeak-27.0-tcl84.patch,v 1.1 2008/01/13 16:18:12 williamh Exp $
+ # $Id: emacspeak-27.0-tcl84.patch,v 1.2 2008/01/19 21:30:57 williamh Exp $
# Description: Interfacing to a Dectalk via TCL.
# Keywords: Emacspeak, Dectalk, TCL
-@@ -58,6 +58,7 @@
- # }}}
- # {{{source common code
-
-+package require Tclx
- set wd [file dirname $argv0]
- source $wd/tts-lib.tcl
- # }}}
-@@ -363,7 +364,7 @@
+@@ -363,7 +363,7 @@
set tts(speech_rate) 225
set tts(say_rate) [round \
[expr $tts(speech_rate) * $tts(char_factor)]]
@@ -23,39 +15,31 @@
if {[info exists server_p]} {
set tts(input) sock0
}
+--- emacspeak-27.0.orig/servers/dtk-soft 2007-06-23 23:12:04.000000000 -0500
++++ emacspeak-27.0/servers/dtk-soft 2008-01-19 12:38:44.000000000 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ # Keywords: Emacspeak, Software Dectalk , TCL
+ # {{{ LCD Entry:
+
--- emacspeak-27.0.orig/servers/espeak 2007-07-01 21:10:31.000000000 -0500
-+++ emacspeak-27.0/servers/espeak 2008-01-12 20:40:53.000000000 -0600
++++ emacspeak-27.0/servers/espeak 2008-01-19 12:39:25.000000000 -0600
@@ -1,4 +1,4 @@
-#!/usr/bin/tcl
+#!/usr/bin/tclsh
# Keywords: Emacspeak, eSpeak , TCL
# {{{ LCD Entry:
-@@ -34,6 +34,7 @@
- # }}}
- # {{{source common code
-
-+package require Tclx
- set wd [file dirname $argv0]
- source $wd/tts-lib.tcl
-
--- emacspeak-27.0.orig/servers/outloud 2007-06-23 23:12:04.000000000 -0500
-+++ emacspeak-27.0/servers/outloud 2008-01-12 20:42:33.000000000 -0600
++++ emacspeak-27.0/servers/outloud 2008-01-19 12:40:14.000000000 -0600
@@ -1,4 +1,4 @@
-#!/usr/bin/tcl
+#!/usr/bin/tclsh
# Keywords: Emacspeak, ViaVoice Outloud , TCL
# {{{ LCD Entry:
-@@ -34,6 +34,7 @@
- # }}}
- # {{{source common code
-
-+package require Tclx
- set wd [file dirname $argv0]
- source $wd/tts-lib.tcl
-
-@@ -472,7 +473,7 @@
+@@ -472,7 +472,7 @@
tts_initialize
set tts(speech_rate) 75
beep_initialize
@@ -65,71 +49,80 @@
set tts(input) sock0
}
--- emacspeak-27.0.orig/servers/speech-server 2007-07-01 21:12:27.000000000 -0500
-+++ emacspeak-27.0/servers/speech-server 2008-01-12 20:49:29.000000000 -0600
++++ emacspeak-27.0/servers/speech-server 2008-01-19 12:49:01.000000000 -0600
@@ -1,4 +1,4 @@
-#!/usr/bin/tcl
+#!/usr/bin/tclsh
- # $Id: emacspeak-27.0-tcl84.patch,v 1.1 2008/01/13 16:18:12 williamh Exp $
+ # $Id: emacspeak-27.0-tcl84.patch,v 1.2 2008/01/19 21:30:57 williamh Exp $
# Description: Speech server
#Usage: tcl speech-server port device-specific-script
-@@ -39,6 +39,8 @@
+@@ -39,6 +39,7 @@
# }}}
# {{{Initialize and get ready
+package require Tclx
-+
set port [lindex $argv 0]
#start up the server
set server [server_create -myport $port -reuseaddr]
--- emacspeak-27.0.orig/servers/ssh-dtk-exp 2007-06-23 22:00:40.000000000 -0500
-+++ emacspeak-27.0/servers/ssh-dtk-exp 2008-01-12 20:51:57.000000000 -0600
++++ emacspeak-27.0/servers/ssh-dtk-exp 2008-01-19 12:46:57.000000000 -0600
@@ -1,4 +1,4 @@
-#!/usr/bin/tcl
+#!/usr/bin/tclsh
- #$Id: emacspeak-27.0-tcl84.patch,v 1.1 2008/01/13 16:18:12 williamh Exp $
+ #$Id: emacspeak-27.0-tcl84.patch,v 1.2 2008/01/19 21:30:57 williamh Exp $
#Description: Launch a TTS server on a remote host.
#Copyright (C) 1995 -- 2007, T. V. Raman
-@@ -18,6 +18,8 @@
+@@ -18,6 +18,7 @@
#"do you want to continue connecting" question.
# }}}
+package require Tclx
-+
set localhost [exec hostname]
puts stderr "running on host <$localhost>"
if [expr $argc == 0] {
-@@ -35,7 +37,7 @@
+@@ -35,7 +36,7 @@
set user [lindex $user_host 0]
set host [lindex $user_host 1]
if {$user == ""} {set user env($USER)}
-set tcl /usr/bin/tcl
-+set tcl /usr/bin/tcl sh
++set tcl /usr/bin/tclsh
regsub {/ssh-} $argv0 {/} tts
puts stderr "Running <ssh $host -l $user -p $port $tcl $tts>"
exec ssh -o StrictHostKeyChecking=no $host \
--- emacspeak-27.0.orig/servers/ssh-outloud 2007-06-23 22:00:42.000000000 -0500
-+++ emacspeak-27.0/servers/ssh-outloud 2008-01-12 20:53:46.000000000 -0600
++++ emacspeak-27.0/servers/ssh-outloud 2008-01-19 12:48:18.000000000 -0600
@@ -1,4 +1,4 @@
-#!/usr/bin/tcl
+#!/usr/bin/tclsh
- #$Id: emacspeak-27.0-tcl84.patch,v 1.1 2008/01/13 16:18:12 williamh Exp $
+ #$Id: emacspeak-27.0-tcl84.patch,v 1.2 2008/01/19 21:30:57 williamh Exp $
#Description: Launch a TTS server on a remote host.
#Copyright (C) 1995 -- 2007, T. V. Raman
-@@ -18,6 +18,8 @@
+@@ -18,6 +18,7 @@
#"do you want to continue connecting" question.
# }}}
+package require Tclx
-+
set localhost [exec hostname]
puts stderr "running on host <$localhost>"
if [expr $argc == 0] {
-@@ -35,7 +37,7 @@
+@@ -35,7 +36,7 @@
set user [lindex $user_host 0]
set host [lindex $user_host 1]
if {$user == ""} {set user env($USER)}
-set tcl /usr/bin/tcl
-+set tcl /usr/bin/tclsh
++set tcl /usr/bin/tclsh
regsub {/ssh-} $argv0 {/} tts
puts stderr "Running <ssh $host -l $user -p $port $tcl $tts>"
exec ssh -o StrictHostKeyChecking=no $host \
+--- emacspeak-27.0.orig/servers/tts-lib.tcl 2007-06-23 23:12:04.000000000 -0500
++++ emacspeak-27.0/servers/tts-lib.tcl 2008-01-19 12:37:39.000000000 -0600
+@@ -36,6 +36,9 @@
+ #
+
+ # }}}
++
++package require Tclx
++
+ # {{{ sync state
+ proc tts_sync_state {punct capitalize allcaps splitcaps rate} {
+ tts_set_punctuations $punct