summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/antimicro/ChangeLog8
-rw-r--r--games-util/antimicro/antimicro-2.2.ebuild38
-rw-r--r--games-util/antimicro/files/antimicro-2.2-build.patch19
3 files changed, 64 insertions, 1 deletions
diff --git a/games-util/antimicro/ChangeLog b/games-util/antimicro/ChangeLog
index 944913aef2c3..154fde7d6131 100644
--- a/games-util/antimicro/ChangeLog
+++ b/games-util/antimicro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/antimicro
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/ChangeLog,v 1.9 2014/03/01 14:49:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/ChangeLog,v 1.10 2014/04/22 12:15:46 hasufell Exp $
+
+*antimicro-2.2 (22 Apr 2014)
+
+ 22 Apr 2014; Julian Ospald <hasufell@gentoo.org> +antimicro-2.2.ebuild,
+ +files/antimicro-2.2-build.patch:
+ version bump
*antimicro-2.1 (01 Mar 2014)
diff --git a/games-util/antimicro/antimicro-2.2.ebuild b/games-util/antimicro/antimicro-2.2.ebuild
new file mode 100644
index 000000000000..3625272a8506
--- /dev/null
+++ b/games-util/antimicro/antimicro-2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/antimicro-2.2.ebuild,v 1.1 2014/04/22 12:15:46 hasufell Exp $
+
+EAPI=5
+inherit eutils qmake-utils
+
+DESCRIPTION="Map keyboard and mouse buttons to gamepad buttons"
+HOMEPAGE="https://github.com/Ryochan7/antimicro"
+SRC_URI="https://github.com/Ryochan7/antimicro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/libsdl2[joystick]
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ eqmake4 INSTALL_PREFIX="${D%/}"/usr antimicro.pro
+}
+
+src_compile() {
+ emake
+ emake updateqm
+}
diff --git a/games-util/antimicro/files/antimicro-2.2-build.patch b/games-util/antimicro/files/antimicro-2.2-build.patch
new file mode 100644
index 000000000000..434887c2be67
--- /dev/null
+++ b/games-util/antimicro/files/antimicro-2.2-build.patch
@@ -0,0 +1,19 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Apr 22 12:10:46 UTC 2014
+Subject: fix build failure
+
+--- a/src/antimicro.pro
++++ b/src/antimicro.pro
+@@ -11,8 +11,12 @@
+ packagesExist(sdl2) {
+ USE_SDL_2 = 1
+ FOUND_SDL = 1
++ CONFIG+=link_pkgconfig
++ PKGCONFIG+=sdl2
+ } else:packageExist(sdl) {
+ FOUND_SDL = 1
++ CONFIG+=link_pkgconfig
++ PKGCONFIG+=sdl
+ } else {
+ error("SDL library was not found")
+ }