summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/snort/ChangeLog7
-rw-r--r--net-analyzer/snort/files/snort-2.6.1.2-react.patch25
-rw-r--r--net-analyzer/snort/snort-2.6.1.2.ebuild8
3 files changed, 36 insertions, 4 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index 842d22347f27..d2020479f050 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/snort
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.115 2007/01/31 19:00:47 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.116 2007/02/01 16:04:30 jokey Exp $
+
+ 01 Feb 2007; Markus Ullmann <jokey@gentoo.org>
+ +files/snort-2.6.1.2-react.patch, snort-2.6.1.2.ebuild:
+ Add patch for react failure, see bug #162598 for details, thanks to
+ perry@csk.pl
31 Jan 2007; Tobias Scherbaum <dertobi123@gentoo.org>
snort-2.6.1.2.ebuild:
diff --git a/net-analyzer/snort/files/snort-2.6.1.2-react.patch b/net-analyzer/snort/files/snort-2.6.1.2-react.patch
new file mode 100644
index 000000000000..c03f1daf6bc2
--- /dev/null
+++ b/net-analyzer/snort/files/snort-2.6.1.2-react.patch
@@ -0,0 +1,25 @@
+diff -urN ./snort-2.6.1.2-orig/configure.in ./snort-2.6.1.2/configure.in
+--- ./snort-2.6.1.2-orig/configure.in 2007-02-01 16:09:42.000000000 +0100
++++ ./snort-2.6.1.2/configure.in 2007-02-01 16:59:55.000000000 +0100
+@@ -963,7 +963,7 @@
+ AC_MSG_WARN(are using a precompiled package please notify the)
+ AC_MSG_WARN(maintainer.)
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/sw/lib"
+- LIBS="${LIBS} -lnet"
++ LIBS="${LIBS} -lnet-1.0"
+ fi
+
+ LNET=""
+@@ -1011,10 +1011,10 @@
+ fi
+
+ LNET=""
+- AC_CHECK_LIB(net, libnet_build_ip,, LNET="no")
++ AC_CHECK_LIB(net-1.0, libnet_build_ip,, LNET="no")
+ if test "$LNET" = "no"; then
+ echo
+- echo " ERROR! Libnet library not found, go get it from"
++ echo " ERROR! Libnet-1.0 library not found, go get it from"
+ echo " http://www.packetfactory.net/projects/libnet/"
+ echo " or use the --with-libnet-* options, if you have it installed"
+ echo " in unusual place"
diff --git a/net-analyzer/snort/snort-2.6.1.2.ebuild b/net-analyzer/snort/snort-2.6.1.2.ebuild
index 159ead76d4cb..e5bff0c3bb9e 100644
--- a/net-analyzer/snort/snort-2.6.1.2.ebuild
+++ b/net-analyzer/snort/snort-2.6.1.2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.6.1.2.ebuild,v 1.4 2007/01/31 19:00:47 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.6.1.2.ebuild,v 1.5 2007/02/01 16:04:30 jokey Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
+AT_M4DIR=m4
+
inherit eutils autotools
DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
@@ -60,7 +62,7 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-2.6.1.1-libnet.patch"
use gre && epatch "${FILESDIR}/${PN}-2.6.1.1-gre.patch"
-
+ use react && epatch "${FILESDIR}/${P}-react.patch"
sed -i "s:var RULE_PATH ../rules:var RULE_PATH /etc/snort/rules:" \
etc/snort.conf
@@ -77,7 +79,7 @@ src_unpack() {
fi
einfo "Regenerating autoconf/automake files"
- AT_M4DIR=m4 eautoreconf
+ eautoreconf
}
src_compile() {