summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/ipmitool/ChangeLog10
-rw-r--r--sys-apps/ipmitool/files/digest-ipmitool-1.8.93
-rw-r--r--sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.confd23
-rw-r--r--sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.initd25
-rw-r--r--sys-apps/ipmitool/ipmitool-1.8.9.ebuild46
5 files changed, 106 insertions, 1 deletions
diff --git a/sys-apps/ipmitool/ChangeLog b/sys-apps/ipmitool/ChangeLog
index 1b75dcd790b4..bd14b0aa4969 100644
--- a/sys-apps/ipmitool/ChangeLog
+++ b/sys-apps/ipmitool/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/ipmitool
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/ChangeLog,v 1.8 2007/02/22 01:12:28 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/ChangeLog,v 1.9 2007/09/23 06:03:41 robbat2 Exp $
+
+*ipmitool-1.8.9 (23 Sep 2007)
+
+ 23 Sep 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/ipmitool-1.8.9-ipmievd.confd, +files/ipmitool-1.8.9-ipmievd.initd,
+ +ipmitool-1.8.9.ebuild:
+ Version bump, bugs #185665 and #175007. Includes init scripts for ipmievd
+ thanks to Tais M. Hansen <tais.hansen@osd.dk>.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-apps/ipmitool/files/digest-ipmitool-1.8.9 b/sys-apps/ipmitool/files/digest-ipmitool-1.8.9
new file mode 100644
index 000000000000..75e0b7beb73a
--- /dev/null
+++ b/sys-apps/ipmitool/files/digest-ipmitool-1.8.9
@@ -0,0 +1,3 @@
+MD5 f122ea1171f8950306b49ddeb4d12f7e ipmitool-1.8.9.tar.gz 682029
+RMD160 3c776919e33ba7e73b6c8913f95086d258e6cc53 ipmitool-1.8.9.tar.gz 682029
+SHA256 1d6bf2595d1fd0dbef206c300cc666d3d079548ba97f727077d61c4736a7e63a ipmitool-1.8.9.tar.gz 682029
diff --git a/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.confd b/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.confd
new file mode 100644
index 000000000000..ee4dd6745e3d
--- /dev/null
+++ b/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.confd
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.confd,v 1.1 2007/09/23 06:03:42 robbat2 Exp $
+# /etc/conf.d/ipmievd
+
+# Interfaces:
+# open Linux OpenIPMI Interface
+# imb Intel IMB Interface
+# bmc IPMI v2.0 BMC interface
+# lan IPMI v1.5 LAN Interface
+# lanplus IPMI v2.0 RMCP+ LAN Interface
+
+INTERFACE="open"
+
+# Commands:
+# open Use OpenIPMI for asyncronous notification of events
+# sel Poll SEL for notification of events
+
+COMMAND="open"
+
+# Options.
+
+OPTIONS=""
diff --git a/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.initd b/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.initd
new file mode 100644
index 000000000000..5dd4ef12ba82
--- /dev/null
+++ b/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/files/ipmitool-1.8.9-ipmievd.initd,v 1.1 2007/09/23 06:03:42 robbat2 Exp $
+# /etc/init.d/ipmievd
+
+depend() {
+ use logger
+}
+PN="ipmievd"
+
+start() {
+ /sbin/modprobe -sq ipmi_msghandler
+ /sbin/modprobe -sq ipmi_devintf
+ /sbin/modprobe -sq ipmi_si
+ ebegin "Starting ${PN}"
+ start-stop-daemon --start --pidfile /var/run/${PN}.pid0 --exec /usr/sbin/${PN} -- -I ${INTERFACE} ${OPTIONS} ${COMMAND}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${PN}"
+ start-stop-daemon --stop --pidfile /var/run/${PN}.pid0
+ eend $?
+}
diff --git a/sys-apps/ipmitool/ipmitool-1.8.9.ebuild b/sys-apps/ipmitool/ipmitool-1.8.9.ebuild
new file mode 100644
index 000000000000..762ef2ff60c0
--- /dev/null
+++ b/sys-apps/ipmitool/ipmitool-1.8.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/ipmitool-1.8.9.ebuild,v 1.1 2007/09/23 06:03:41 robbat2 Exp $
+
+DESCRIPTION="Utility for controlling IPMI enabled devices."
+HOMEPAGE="http://ipmitool.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="BSD"
+
+RDEPEND="virtual/libc
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ sys-libs/openipmi
+ virtual/os-headers"
+
+src_compile() {
+ # LIPMI and BMC are the Solaris libs
+ # FreeIPMI is not included at the moment, as ipmitool does not use the
+ # correct number of arguments for functions in recent versions.
+ econf \
+ --enable-ipmievd --enable-ipmishell \
+ --enable-intf-lan --enable-intf-lanplus \
+ --enable-intf-open --disable-intf-free --enable-intf-imb \
+ --disable-intf-lipmi --disable-intf-lipmi \
+ --with-kerneldir=/usr --bindir=/usr/sbin \
+ || die "econf failed"
+ # Fix linux/ipmi.h to compile properly. This is a hack since it doesn't
+ # include the below file to define some things.
+ echo "#include <asm/byteorder.h>" >>config.h
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install || die "emake install failed"
+
+ into /usr
+ dosbin contrib/bmclanconf
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+ prepalldocs
+
+ newinitd "${FILESDIR}"/${PN}-1.8.9-ipmievd.initd ipmievd
+ newconfd "${FILESDIR}"/${PN}-1.8.9-ipmievd.confd ipmievd
+}