summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/pkgcore-checks/ChangeLog6
-rw-r--r--dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-util/pkgcore-checks/ChangeLog b/dev-util/pkgcore-checks/ChangeLog
index 6d13f14ece8b..20f385652dd0 100644
--- a/dev-util/pkgcore-checks/ChangeLog
+++ b/dev-util/pkgcore-checks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/pkgcore-checks
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/ChangeLog,v 1.54 2014/06/08 10:21:26 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/ChangeLog,v 1.55 2014/06/08 10:26:07 radhermit Exp $
+
+ 08 Jun 2014; Tim Harder <radhermit@gentoo.org> pkgcore-checks-9999.ebuild:
+ Drop python3* support until support is finalized for pkgcore and fix python
+ deps.
08 Jun 2014; Tim Harder <radhermit@gentoo.org> pkgcore-checks-9999.ebuild:
Drop python2_6 support.
diff --git a/dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild b/dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild
index 7fd7093510d2..90cd364ff725 100644
--- a/dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild
+++ b/dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild,v 1.4 2014/06/08 10:21:26 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/pkgcore-checks-9999.ebuild,v 1.5 2014/06/08 10:26:07 radhermit Exp $
EAPI=4
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -20,8 +20,8 @@ HOMEPAGE="http://www.pkgcore.org/"
LICENSE="GPL-2"
SLOT="0"
-RDEPEND="=sys-apps/pkgcore-9999
- =dev-python/snakeoil-9999"
+RDEPEND="=sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
+ =dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
pkg_setup() {