summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/pciutils/ChangeLog9
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.4-r23
-rw-r--r--sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch34
-rw-r--r--sys-apps/pciutils/pciutils-2.2.4-r2.ebuild43
4 files changed, 81 insertions, 8 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 2ef60381b48b..098703904bb3 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.94 2007/02/14 07:14:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.95 2007/02/14 22:45:12 vapier Exp $
+
+*pciutils-2.2.4-r2 (14 Feb 2007)
+
+ 14 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ files/pciutils-2.2.4-update-pciids.patch, +pciutils-2.2.4-r2.ebuild:
+ Improve update-pciids some more in quiet mode and in cleaning up after
+ itself #164800 by Horst Prote.
14 Feb 2007; Mike Frysinger <vapier@gentoo.org> pciutils-2.2.4.ebuild,
pciutils-2.2.4-r1.ebuild:
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.4-r2 b/sys-apps/pciutils/files/digest-pciutils-2.2.4-r2
new file mode 100644
index 000000000000..1ce68229c366
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.4-r2
@@ -0,0 +1,3 @@
+MD5 5629fdb049f189fb853e7021f85553d2 pciutils-2.2.4.tar.gz 210706
+RMD160 27db4b23a07a02b28b64e01fbe1c74cefa887cc0 pciutils-2.2.4.tar.gz 210706
+SHA256 62fc07f688c6d17f0cf8baa540e42be6117530360c2df491ec02031973506a9f pciutils-2.2.4.tar.gz 210706
diff --git a/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch b/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch
index f875f8a825c0..b37309c8e7a3 100644
--- a/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch
+++ b/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch
@@ -1,6 +1,6 @@
--- update-pciids.sh
+++ update-pciids.sh
-@@ -1,5 +1,7 @@
+@@ -1,30 +1,41 @@
#!/bin/sh
+[ "$1" = "-q" ] && quiet="true" || quiet="false"
@@ -8,7 +8,6 @@
set -e
SRC="http://pciids.sourceforge.net/v2.2/pci.ids"
DEST=pci.ids
-@@ -8,6 +8,13 @@
PCI_COMPRESSED_IDS=
GREP=grep
@@ -22,20 +21,41 @@
if [ -n "$PCI_COMPRESSED_IDS" ] ; then
DECOMP="cat"
SRC="$SRC.gz"
-@@ -22,8 +24,10 @@
+ GREP=zgrep
+-elif which bzip2 >/dev/null ; then
++elif which bzip2 >&2 >/dev/null ; then
+ DECOMP="bzip2 -d"
+ SRC="$SRC.bz2"
+-elif which gzip >/dev/null ; then
++elif which gzip >&2 >/dev/null ; then
+ DECOMP="gzip -d"
+ SRC="$SRC.gz"
+ else
+ DECOMP="cat"
+ fi
- if which curl >/dev/null ; then
+-if which curl >/dev/null ; then
++if which curl >&2 >/dev/null ; then
DL="curl -o $DEST.new $SRC"
+-elif which wget >/dev/null ; then
+ ${quiet} && DL="$DL -s -S"
- elif which wget >/dev/null ; then
++elif which wget >&2 >/dev/null ; then
DL="wget -O $DEST.new $SRC"
+-elif which lynx >/dev/null ; then
+ ${quiet} && DL="$DL -q"
- elif which lynx >/dev/null ; then
++elif which lynx >&2 >/dev/null ; then
DL="eval lynx -source $SRC >$DEST.new"
else
-@@ -59,4 +66,4 @@
+ echo >&2 "update-pciids: cannot find curl, wget or lynx"
+@@ -55,4 +66,10 @@
mv $DEST.neww $DEST
rm $DEST.new
-echo "Done."
++# Older versions did not compress the ids file, so let's make sure we
++# clean that up.
++if [ ${DEST%.gz} != ${DEST} ] ; then
++ rm -f ${DEST%.gz} ${DEST%.gz}.old
++fi
++
+${quiet} || echo "Done."
diff --git a/sys-apps/pciutils/pciutils-2.2.4-r2.ebuild b/sys-apps/pciutils/pciutils-2.2.4-r2.ebuild
new file mode 100644
index 000000000000..4aa5e334d9b8
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4-r2.ebuild,v 1.1 2007/02/14 22:45:12 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.3-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.4.patch
+ epatch "${FILESDIR}"/${P}-link.patch #160421
+ cp update-pciids.sh update-pciids.sh.orig
+ epatch "${FILESDIR}"/${P}-update-pciids.patch
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dolib lib/libpci.* || die "libpci failed"
+ insinto /usr/include/pci
+ doins lib/{config,header,pci,types}.h || die "headers failed"
+
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids || die
+}