summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/xen-tools/ChangeLog7
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.0.2--as-needed.patch10
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2.ebuild37
3 files changed, 36 insertions, 18 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index f83addb74099..4bdb29370805 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.10 2006/04/26 16:45:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.11 2006/06/02 09:23:34 uberlord Exp $
+
+ 02 Jun 2006; Roy Marples <uberlord@gentoo.org>
+ +files/xen-tools-3.0.2--as-needed.patch, -xen-tools-3.0.1.ebuild,
+ -xen-tools-3.0.1_p9029.ebuild, xen-tools-3.0.2.ebuild:
+ Add patch to enable --as-needed LDFLAG, #135145
26 Apr 2006; Aron Griffis <agriffis@gentoo.org> xen-tools-3.0.1.ebuild,
xen-tools-3.0.1_p9029.ebuild, xen-tools-3.0.2.ebuild:
diff --git a/app-emulation/xen-tools/files/xen-tools-3.0.2--as-needed.patch b/app-emulation/xen-tools/files/xen-tools-3.0.2--as-needed.patch
new file mode 100644
index 000000000000..362e49580dfa
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.0.2--as-needed.patch
@@ -0,0 +1,10 @@
+--- xen-3.0.2/tools/xenmon/Makefile 2006-06-01 13:40:40.468687762 +0100
++++ xen-3.0.2/tools/xenmon/Makefile 2006-06-01 13:41:04.000000000 +0100
+@@ -43,6 +43,6 @@
+
+
+ %: %.c Makefile
+- $(CC) $(CFLAGS) $(LDFLAGS) -lxenctrl -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< -lxenctrl
+
+
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2.ebuild
index e6a5020ce97d..4ebcfada1037 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.2.ebuild,v 1.7 2006/04/26 16:45:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.2.ebuild,v 1.8 2006/06/02 09:23:34 uberlord Exp $
inherit mount-boot flag-o-matic eutils
@@ -9,10 +9,10 @@ HOMEPAGE="http://xen.sourceforge.net"
if [[ ${PV} == *_p* ]]; then
XEN_UNSTABLE="xen-unstable-${PV#*_p}"
SRC_URI="mirror://gentoo/${XEN_UNSTABLE}.tar.bz2"
- S=${WORKDIR}/${XEN_UNSTABLE}
+ S="${WORKDIR}/${XEN_UNSTABLE}"
else
SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-${PV}-src.tgz"
- S=${WORKDIR}/xen-${PV}
+ S="${WORKDIR}/xen-${PV}"
fi
LICENSE="GPL-2"
@@ -44,7 +44,7 @@ src_unpack() {
if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"
# try and remove all the default custom-cflags
- find ${S} -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
-e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
@@ -56,11 +56,14 @@ src_unpack() {
if use hardened; then
HARDFLAGS="-nopie -fno-stack-protector -fno-stack-protector-all"
sed -e "s/CFLAGS :=/CFLAGS := ${HARDFLAGS}/" \
- -i ${S}/tools/firmware/hvmloader/Makefile \
- ${S}/tools/firmware/vmxassist/Makefile
- cd ${S}
- epatch ${FILESDIR}/hardened-bx-clobber.patch
+ -i "${S}"/tools/firmware/hvmloader/Makefile \
+ "${S}"/tools/firmware/vmxassist/Makefile
+ cd "${S}"
+ epatch "${FILESDIR}"/hardened-bx-clobber.patch
fi
+
+ # Allow --as-needed LDFLAGS
+ epatch "${FILESDIR}/${P}"--as-needed.patch
}
src_compile() {
@@ -73,7 +76,7 @@ src_compile() {
if use doc; then
sh ./docs/check_pkgs || die "package check failed"
- make -C docs || die "compiling docs failed"
+ emake -C docs || die "compiling docs failed"
fi
emake -C docs man-pages || die "make man-pages failed"
@@ -86,20 +89,20 @@ src_install() {
|| die "install failed"
if use doc; then
- make DESTDIR=${D} -C docs install || die "install docs failed"
+ make DESTDIR="${D}" -C docs install || die "install docs failed"
# Rename doc/xen to the Gentoo-style doc/xen-x.y
- mv ${D}/usr/share/doc/{${PN},${PF}}
+ mv "${D}"/usr/share/doc/{${PN},${PF}}
fi
doman docs/man?/*
- newinitd ${FILESDIR}/xend-init xend
- newconfd ${FILESDIR}/xend-conf xend
- newconfd ${FILESDIR}/xendomains-conf xendomains
- newinitd ${FILESDIR}/xendomains-init xendomains
+ newinitd "${FILESDIR}"/xend-init xend
+ newconfd "${FILESDIR}"/xend-conf xend
+ newconfd "${FILESDIR}"/xendomains-conf xendomains
+ newinitd "${FILESDIR}"/xendomains-init xendomains
if use screen; then
- sed -i -e 's/SCREEN="no"/SCREEN="yes"/' ${D}/etc/init.d/xendomains
+ sed -i -e 's/SCREEN="no"/SCREEN="yes"/' "${D}"/etc/init.d/xendomains
fi
# xend expects these to exist
@@ -107,7 +110,7 @@ src_install() {
# for upstream change tracking
if [[ -n ${XEN_UNSTABLE} ]]; then
- dodoc ${S}/XEN-VERSION
+ dodoc "${S}"/XEN-VERSION
fi
}