summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/basc/ChangeLog9
-rw-r--r--app-portage/basc/Manifest2
-rw-r--r--app-portage/basc/basc-1.5.7.ebuild85
-rw-r--r--app-portage/basc/files/digest-basc-1.5.71
4 files changed, 95 insertions, 2 deletions
diff --git a/app-portage/basc/ChangeLog b/app-portage/basc/ChangeLog
index ab996c5b5d50..5171fa5c4811 100644
--- a/app-portage/basc/ChangeLog
+++ b/app-portage/basc/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for app-portage/basc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.18 2005/01/12 17:43:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.19 2005/01/18 15:46:43 pvdabeel Exp $
+
+
+*basc-1.5.7 (18 Jan 2005)
+
+ 18 Jan 2005; Pieter Van den Abeele <pvdabeel@gentoo.org> basc-1.5.7.ebuild :
+ New version with improvements suggested in 77736, 77737 and 78103
*basc-1.5.6 (12 Jan 2005)
12 Jan 2005; Pieter Van den Abeele <pvdabeel@gentoo.org> basc-1.5.6.ebuild :
Made X an optional dependency. Fixed bug 77198 , 77245
-
*basc-1.5.4 (09 Jan 2005)
12 Jan comment about the policy violation ciaranm is ranting about:
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index 07f432f6dece..772be81463c8 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -5,8 +5,10 @@ MD5 afcfbf8a59eb5ba519d8c1aa6d70b730 basc-1.5.4.ebuild 2149
MD5 36441a3af28aa17a592a5c409239a278 metadata.xml 616
MD5 609049c30808cae3ab6dddb68c8df75f basc-1.5.6.ebuild 2152
MD5 3c6c7d2b9f3954b2f84785403d52a0a7 basc-1.5.5.ebuild 2137
+MD5 75bb1f264ea87ca8b06e81efc375559b basc-1.5.7.ebuild 2096
MD5 fad108ecff3fcfbf2987a555420c92cc files/digest-basc-1.5.2 61
MD5 74753ac6d1c6ab7f0dbf6c43d17045b4 files/digest-basc-1.5.3 61
MD5 0d0e5ae721dc3402d7b52269750aa9b7 files/digest-basc-1.5.4 61
MD5 144c814e142b0b00a52220a4114f4af3 files/digest-basc-1.5.5 61
MD5 c5c7d0367c00009c8b8151101fe7755f files/digest-basc-1.5.6 61
+MD5 e0738699ce03f1a0b4212f2662d714e0 files/digest-basc-1.5.7 61
diff --git a/app-portage/basc/basc-1.5.7.ebuild b/app-portage/basc/basc-1.5.7.ebuild
new file mode 100644
index 000000000000..0b3f61e4f7b1
--- /dev/null
+++ b/app-portage/basc/basc-1.5.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.5.7.ebuild,v 1.1 2005/01/18 15:46:43 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+KEYWORDS="x86 ppc ~sparc amd64 ~ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="screenshot"
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ sys-apps/diffutils
+ >=sys-apps/uhinv-0.4
+ screenshot? (media-gfx/scrot)"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc client/hgenlop
+ useq x86 && $(tc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c >/dev/null 2>&1
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/urandom.sh
+
+ useq x86 && doexe client/smt-detect
+
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+}
+
+pkg_postinst() {
+
+ cp /var/log/emerge* /etc/basc
+
+ chown -R root:stats /etc/basc
+ chmod -R ug+rw /etc/basc
+
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc\""
+ einfo ""
+ einfo "Note:"
+ einfo ""
+ einfo "You have to be in the stats group to use the client!"
+ einfo "A user can be added to the stats group by executing:"
+ einfo ""
+ einfo " \"usermod -G \$(groups <ME> | sed -e 's/ /,/g'),stats <ME>\""
+ einfo ""
+ einfo "Replace <ME> with your username on the system."
+ einfo "After a login, you are ready to use the client."
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q -y >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ ebeep
+}
+
diff --git a/app-portage/basc/files/digest-basc-1.5.7 b/app-portage/basc/files/digest-basc-1.5.7
new file mode 100644
index 000000000000..8fc87780237e
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.5.7
@@ -0,0 +1 @@
+MD5 1ba97877d78cfbf9585137633b725272 basc-1.5.7.tar.gz 23332