summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/multimon-ng/ChangeLog10
-rw-r--r--net-analyzer/multimon-ng/metadata.xml12
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-1.0.0.ebuild31
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-9999.ebuild31
4 files changed, 84 insertions, 0 deletions
diff --git a/net-analyzer/multimon-ng/ChangeLog b/net-analyzer/multimon-ng/ChangeLog
new file mode 100644
index 000000000000..936369433942
--- /dev/null
+++ b/net-analyzer/multimon-ng/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/multimon-ng
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/multimon-ng/ChangeLog,v 1.1 2013/06/26 23:59:41 zerochaos Exp $
+
+*multimon-ng-1.0.0 (27 Jun 2013)
+*multimon-ng-9999 (27 Jun 2013)
+
+ 27 Jun 2013; Rick Farina <zerochaos@gentoo.org> +metadata.xml,
+ +multimon-ng-1.0.0.ebuild, +multimon-ng-9999.ebuild:
+ initial commit of multimon-ng
diff --git a/net-analyzer/multimon-ng/metadata.xml b/net-analyzer/multimon-ng/metadata.xml
new file mode 100644
index 000000000000..044f12194316
--- /dev/null
+++ b/net-analyzer/multimon-ng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<herd>radio</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-analyzer/multimon-ng/multimon-ng-1.0.0.ebuild b/net-analyzer/multimon-ng/multimon-ng-1.0.0.ebuild
new file mode 100644
index 000000000000..54bf7ef34b6d
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/multimon-ng/multimon-ng-1.0.0.ebuild,v 1.1 2013/06/26 23:59:41 zerochaos Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimonNG"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-sound/pulseaudio
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
new file mode 100644
index 000000000000..e5652d65a581
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/multimon-ng/multimon-ng-9999.ebuild,v 1.1 2013/06/26 23:59:41 zerochaos Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimonNG"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-sound/pulseaudio
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+}